Results 1 to 16 of 16

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: T-mobile internet APN fix iOS 4.0

  1. #1
    Default T-mobile internet/MMS APN fix iOS 4.0
    After searching online since the new jailbreak by comex, going through some threads here and on other fourms, I was able to finally add the APN settings.

    If you have not already used it, or lived under a rock; Here you go:


    The jailbreak works for most devices, just check on the site above for more info. This process below is used on a iphone 3gs new bootrom, although it should work for any of the older iphones.

    Before discussing any solutions, if you do not see the cellular data option/resetting cellular data settings, restore to 4.0 or 4.0.1 and rejailbreak the phone. Most of the problems come from upgrading a already used iphone. It's suggested to wipe it clean first and then jailbreak.

    If it still does not work, do the following:

    As for getting the APN settings to work, you'll need to install supreme preferences 3.0. Make sure that it is 3.0. Also it does require winterboard to be installed first. I have noticed that the settings do change for my MMS settings when turned off/reboot (everything but the APN for MMS)

    Here is what you do:

    -After you got winterboard, install supreme preferences 3.0 (from cydia, find a repo that has it)

    -go to winterboard, select supreme preferences 3.0 and respring

    -go to settings, supreme preferences 3.0, applications, phone, cellular data editing [ON].

    -now you may be able to change the settings on your phone!

    ****read this if you have problems with MMS****

    This may be trivial, but make sure your settings are close to EXACT as what I am about to post here. This is only for the supreme preference 3.0 settings. I had different settings on two phones and it seems like the settings make a difference in the problem with the MMS. Just try to copy exactly as possible, as any variation can mess up the MMS. Hopefully, this should work for most users.









    Last edited by ctscloud23; 2010-08-06 at 07:36 AM. Reason: added MMS solution

  2. #2
    What repo did you use and what are the APN settings?

  3. #3
    It's very easy to find a repo that has supreme preference, just google it. Don't thnik we're allowed to link the repo's here. The APN settings depend on what data plan you are using. So I wouldn't know which ones.

  4. #4
    Figured it out, the only dilemma im having is sending and receiving mms?

  5. #5
    That is correct, I have been having a bit trouble with the MMS portion..

    I had the problem with the camera icon not being displayed in text msg app. I'll edit the first post with the solution to that.

  6. #6
    Thanks man appreciate it, I have the pic icon on sms, I just get the error message saying it cannot be sent

  7. #7
    About the error message, first check supreme preference and then check your MMS settings, make sure you're using the right set.

  8. #8
    I got supreme preferences downloaded, but I cant seem to get into where its located? If you can IM on yahoo, jramosent

  9. #9
    Sorry dont got yahoo, but it should be in settings app.

  10. #10
    Got it, just cant seem to get mms to work yet

  11. #11
    What's Jailbreak?
    Join Date
    Feb 2008
    Thanked 2 Times in 1 Post
    add in cydia and download the tmobile mms fix

  12. #12
    Quote Originally Posted by invisible03 View Post
    add in cydia and download the tmobile mms fix
    How can you be sure that works for everyone? I have already tried it that way.

  13. #13
    cant find supreme prefs 3.0 anywhere

  14. #14
    you need to add a source not provided by cydia. But I would suggest to restore completely first and then rejailbreak.

  15. #15
    Quote Originally Posted by invisible03 View Post
    add in cydia and download the tmobile mms fix
    worked like a charm for me

  16. #16
    I added this link to the cydia sources section after adding it go in it and look for tmobile mms fix, and install. After it finishes installing hit the reboot button.. Thats it, from there it shoulb be working. Have someone send u a picture message to check it out... it worked for me and I have the iphone 3g 4.0n

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts