Page 14 of 14 FirstFirst ... 4121314
Results 261 to 266 of 266

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: T-Mobile USA MMS Fix for iOS4

  1. #261
    MMShas been working fine for about a month now. I can recieve mms but cannot send, has anyone else ran into this prob? if so, have you fixed it?


  2. #262
    Quote Originally Posted by baud0f24o0 View Post
    playboyjenna, I did all those as well and ended up with the same MMS issues. Basically, the MMS APN settings need to be specified in order for MMS to go through. Normally that is found in the 'Cellular Data Network' tab in 'General > Network' area. That was hidden in mine. I looked everywhere for a way to unhide that setting and came up with nothing.

    I finally tried something random and searched all my repos for something that might work. I found Installed it, restarted the device, and when I went back to 'General > Network', Cellular Data Network was now there. From there, I entered the settings posted earlier in this thread.

    With all those settings in properly, the last step is to download the 'T-Mobile US MMS Fix...' and restarted one last time. After that, I sent a test MMS to a friend and got a confirm that they received it.

    I hope this helps, if not, PM me and we'll get this sorted for you.


    Mod edit, warez repo removed
    This is what also worked for me..However, I am finding that the cellular data fields that I had to manually input (which did allow sending and receiving of mms) won't save so after a few mins, or an hour or so, They just vanish I don't even have to reboot for this to happen. I am stuck manually inputting all the cellular data fields every time I want to send a picture message. Any clue on why this isnt saving?

  3. #263
    iPhone? More like MyPhone
    Join Date
    Jul 2009
    Nashville, TN
    Thanked 14 Times in 14 Posts

    After searching forever I found this thread and remembered I used it a few years back on my 3g. It totally worked on my 4 as well BUT I had to change the apn from to EPC seems to only work when the internet apn is also epc.

  4. #264
    Duplicate post. Sorry
    Last edited by wyvon54; 2011-11-14 at 04:10 PM. Reason: Duplicate

  5. #265
    I have come back to this forum as you all were a great help last year to get my MMS working on my 3Gs. I up graded my iOS to 4.3.3 last week and have found that my MMS is again not working. I have tried all suggestions in this forum. With Pushfix, changing the plist, etc. The only way I was able to get it to work was using siNfuliphonerepro - Tether Me Cracked. The only problem with is was that cut me off from Safari and each MMS I received came through several times. This is unacceptable. I do not know what else to do unless I go back down to a lower iOS. Any suggestions? Any and all help would be greatly appreciated!!

    I have a 3GS
    unlocked with Sn0breeze
    jailbroken with Ultrasn0w
    Old baseband
    iOS 4.3.3
    firmware 6.15.00
    On T-Mobile unlimited talk & text, $30 data plan


  6. #266
    It works flawless on iPhone 4 4.0.1 with 1.59.00 baseband and 3gs 4.2.1 (new bootroom) with 5.13.04 baseband. However my APN's:
    Cellular Data is
    MMS is
    The rest on MMS are the same.

    Just update 4.0.1 to 5.0.1 with preserved baseband 1.59, and MMS does works.

    Million thanks Fernandorinto
    Last edited by Bs0d; 2012-01-12 at 06:08 AM.

Page 14 of 14 FirstFirst ... 4121314
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts