Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Unlocked iphone 3g edge problems

  1. #1
    Default Unlocked iphone 3g edge problems
    So I went to t mobile and got web2go yesterday, and i've confirmed that it's working on my razr.

    in my iphone's cellular data network, i put in "internet2.voicestream.com" and i rebooted the phone, but i'm still going without any internet it says on safari. i can't load weather or connect to youtube either. i've tried "epc.tmobile.com" & "wap.voicestream.com", neither of those are working either.

    now here's the catch - i slipped my sim card into my friend's iphone 3gs with the same exact settings, and it works just fine on his phone. so i've come to the conclusion that there's something wrong with my phone, and i'm assuming it's one of the many things in cydia. (i bought the phone used, with this stuff already installed)

    any help/input would be really nice, i've been told that i should just wait for the service to actually "activate" but since it's working on a different iphone & even my razr, i'm assuming that it's activated.
    ~ Thanks in advance

    Running 3.1.2 firmware, 5.11.07 baseband btw. unlocked/jailbroken with blackra1n.

  2. #2
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Go to cydia, search for "Legacy" and download the first result. Reset network settings. See how it works.
    If I helped you out, please use the Thanks button ------------------------->

  3. The Following 2 Users Say Thank You to adp For This Useful Post:

    Failbait (2010-03-28), iporter (2010-04-29)

  4. #3
    You sure did help I already had the Legacy package installed, simple reset of network settings did the trick.

    Thanks alot

    EDIT: Btw, just wondering but, do you know if the web2go t-mobile data plan is unlimited using iPhone? I've heard that it's only like 50MB of data, but the lady at the store told me that it was unlimited, assuming i'd use my razr though.

  5. #4
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Quote Originally Posted by Failbait View Post
    You sure did help I already had the Legacy package installed, simple reset of network settings did the trick.

    Thanks alot

    EDIT: Btw, just wondering but, do you know if the web2go t-mobile data plan is unlimited using iPhone? I've heard that it's only like 50MB of data, but the lady at the store told me that it was unlimited, assuming i'd use my razr though.
    Yea it's unlimited now. Used to be 100mb but that changed last year. Good luck
    If I helped you out, please use the Thanks button ------------------------->

  6. The Following User Says Thank You to adp For This Useful Post:

    iporter (2010-04-29)

  7. #5
    Having the same issues ... iPhone 3g and have the web2go with tmobile ... has been working flawlessly for a couple of months ... earlier this week, the network was gone. I can still make calls and what not, but the 'edge' network disappeared. I've reset the network settings, use "wap.voicestream.come", "internet2.voicestream.com", and "epc.tmobile.com". Data Roaming is on, 3G is off ... I got online and looked for Legacy in Cydia and couldn't find. I'm stumped ... I put my SIM in my wife's Blackberry and the internet works fine. No lock when it's in my unlocked iPhone.

    Anybody got some suggestions I'd GREATLY appreciate it.

  8. #6
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Quote Originally Posted by iporter View Post
    Having the same issues ... iPhone 3g and have the web2go with tmobile ... has been working flawlessly for a couple of months ... earlier this week, the network was gone. I can still make calls and what not, but the 'edge' network disappeared. I've reset the network settings, use "wap.voicestream.come", "internet2.voicestream.com", and "epc.tmobile.com". Data Roaming is on, 3G is off ... I got online and looked for Legacy in Cydia and couldn't find. I'm stumped ... I put my SIM in my wife's Blackberry and the internet works fine. No lock when it's in my unlocked iPhone.

    Anybody got some suggestions I'd GREATLY appreciate it.
    1) Make sure the Modmyi repo is in your list in Cydia. Then search for "Legacy" again - it's there.

    2) It may just be a local data outage in your area. If you "E" sign disappears then it's most likely local repairs/upgrades.
    If I helped you out, please use the Thanks button ------------------------->

  9. The Following User Says Thank You to adp For This Useful Post:

    iporter (2010-04-26)

  10. #7
    1) Make sure the Modmyi repo is in your list in Cydia. Then search for "Legacy" again - it's there.

    2) It may just be a local data outage in your area. If you "E" sign disappears then it's most likely local repairs/upgrades.


    Read more about hacking by modmyi.com
    Thanks ADP, I checked out my list ... I do have Modmyi repo in my Cydia list, as well as Legacy. Would it still be a problem with TMobile if I take my SIM out of my phone, put it in my wife's Blackberry and the internet work, but not work when it's in mine?

    I appreciate your help.

  11. #8
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    You have the blacberry data plan?
    If I helped you out, please use the Thanks button ------------------------->

  12. The Following User Says Thank You to adp For This Useful Post:

    iporter (2010-04-29)

  13. #9
    No, my plan is just the Web2Go plan ... I just stuck my SIM card in her phone and was able to jump on the internet.

  14. #10
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Wow...that's new. I thought T-mobile would block web2go data on a blackberry. Unless it's not an "officially" supported blackberry (meaning the ones you buy off in the T-mobile store). Anyways, did the data work in your iPhone? As far as being an issue on the blackberry, I'm not entirely sure. I have heard of them blocking web2go for their android based phones. I know that it's ok for the iPhone though.
    If I helped you out, please use the Thanks button ------------------------->

  15. The Following User Says Thank You to adp For This Useful Post:

    iporter (2010-04-29)

  16. #11
    Yea, I bought her Blackberry in the TMobile store. And scratch that, I don't have "Web2Go" I have "SmartPhone Web".

    I'm really stumped on what to do. My Cellular Data settings are good, Cydia and it's packages are all there, TMobile is reporting no outages. I was with a girl at work with an unlocked iPhone (non 3G) on TMobile ... she had the Edge Network, but I don't. I'm not sure what to do and it's so frustrating.

    Oh well ... I really appreciate your help bro.

  17. #12
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Oh ok. Well since you said you had web2go, I linked you to the web2go carrier bundle. Go back into Cydia and uninstall it. Then search for "T-Mobile US - Postpaid/Flexpaid" and it should be the very first result. Then go to settings - general - reset and reset network settings. That should do it.
    If I helped you out, please use the Thanks button ------------------------->

  18. The Following User Says Thank You to adp For This Useful Post:

    iporter (2010-04-29)

  19. #13
    Okay, I went into Cydia, uninstalled the Legacy package (correct?) and downloaded T-Mobile US-Postpaid/Flexpaid pack. Reset my network settings and I'm in the same spot ... no internet. I know it's got to be something simple that I'm not seeing. Does the APN have to be something specific? I've tried epc.tmobile.com, internet2.voicestream.com and wap.voicestream.com. Data Roaming is 'on', and Enable 3G is 'off'.

    Also, what's a quick fix to enable my phone to so it will tether to my Mac? When I click on the option in setting it says I have to contact TMobile. Fortunately at the moment I've been able to jump on my neighbors wireless modem to make changes.
    Last edited by iporter; 2010-04-27 at 06:13 AM. Reason: Automerged Doublepost

  20. #14
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Tethering should be enabled after you install the carrier bundle. The APN for your data plan should be epc.tmobile.com, but since you told me that data works on a blackberry, try deleting the carrier bundle again and search in cydia for: "T-Mobile US - Postpaid/Flexpaid BlackBerry"

    I also forgot to mention, you might be interested in switching to web2go as you'll be paying a lot less money for the same data speed on the iPhone. I think your data plan is 24.99, web2go is 9.99 and there's no difference. Let me know if you need details on how to switch.
    If I helped you out, please use the Thanks button ------------------------->

  21. The Following User Says Thank You to adp For This Useful Post:

    iporter (2010-04-29)

  22. #15
    iporter are you in Atlanta? Because I am having this same problem. What happens is that when I am at home( 12 miles from downtown Atlana) I have my Edge data service with no problem. But when I am in downtown Atlanta, I lose my edge data service. I called t-mobile but they said they had no outages.

  23. #16
    I am a few hours from Atlanta and I havnt had edge service for over a week now. Mine is on simple mobile service that is ran on the backbone of T-mobile so no matter what anyone says something has changed in the last week with the network so and I'm about to put this stupid iphone up on e-bay. This thing has just turned into way to much of a hassle. I'm going back to my blackberry if I cant get my edge service fixed soon.

  24. #17
    Well an hour ago my edge service was restored, so I'm good now

    cancel my last post i had edge service for about an hour downtown then it went out again
    Last edited by Wakil17; 2010-04-28 at 02:17 AM. Reason: Automerged Doublepost

  25. #18
    Close ... I'm in Columbus ... 1.5 hours south of Atlanta. My problem though is that I don't have any EDGE service at all. I haven't had it since Thursday night/Friday morning.

    Quote Originally Posted by adp View Post
    Tethering should be enabled after you install the carrier bundle. The APN for your data plan should be epc.tmobile.com, but since you told me that data works on a blackberry, try deleting the carrier bundle again and search in cydia for: "T-Mobile US - Postpaid/Flexpaid BlackBerry"

    I also forgot to mention, you might be interested in switching to web2go as you'll be paying a lot less money for the same data speed on the iPhone. I think your data plan is 24.99, web2go is 9.99 and there's no difference. Let me know if you need details on how to switch.
    I'm at a loss for words ... I've installed T-Mobile US - Postpaid/Flexpaid BlackBerry, T-Mobile US - Postpaid/Flexpaid, and the one for Legacy ... none of the carrier bundle packs seem to work. And the tethering doesn't become enabled with any of the bundle ... which is weird. Something has got to be wrong with the phone itself. Not sure what to do at this point ... I might have to find someone to send it to so they can look at it.
    Last edited by iporter; 2010-04-28 at 02:50 AM. Reason: Automerged Doublepost

  26. #19
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Why don't you just switch to web2go?
    If I helped you out, please use the Thanks button ------------------------->

  27. The Following User Says Thank You to adp For This Useful Post:

    iporter (2010-04-29)

  28. #20
    I dont think Web2Go is the solution alsomy edge went out last fridat too!

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •