Results 1 to 19 of 19

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone not receiving calls

  1. #1
    Default iPhone not receiving calls
    For some reason for the past two days my iPhone will not receive phone calls. It's unlocked and jailbroken on 3.0.1. I can make calls and send texts. Just my iPhone will not ring and will go straight to voicemail.

    Could it be my iPhone or the sim card? I have full service in my house.

  2. #2
    Your forwarding calls to yourself. Go find the GSM code the stop it. I had this problem before too when I got my phone. There is a glitch that forwards the call to your number(voicemail) and a few people have had it.

    Hit thanks if I helped

  3. #3
    Quote Originally Posted by Harman_M View Post
    Your forwarding calls to yourself. Go find the GSM code the stop it. I had this problem before too when I got my phone. There is a glitch that forwards the call to your number(voicemail) and a few people have had it.

    Hit thanks if I helped
    How would I do that?

  4. #4
    Search google for call forwarding GSM codes.

    I can help you if you need.

    ##21#

    Enter that into your keypad and press send.
    Last edited by Harman_M; 2009-08-29 at 06:23 PM. Reason: Automerged Doublepost

  5. The Following User Says Thank You to Harman_M For This Useful Post:

    GreekSkillz (2009-08-29)

  6. #5
    Quote Originally Posted by Harman_M View Post
    Search google for call forwarding GSM codes.

    I can help you if you need.

    ##21#

    Enter that into your keypad and press send.
    Okay. I'll try doing that after my iPhone is done restoring. I'll let you know what happens. Thanks for the help.

  7. #6
    You restored it? That could stop forwarding but you shouldn't have.
    Last edited by Harman_M; 2009-08-30 at 01:01 AM.

  8. The Following User Says Thank You to Harman_M For This Useful Post:

    GreekSkillz (2009-08-29)

  9. #7
    Yeah, I was already restoring it while I posted the thread. Everything seems to be working ok now. Thanks for the help.

    I'm still having the same issue. Most phone calls aren't coming through.
    Last edited by GreekSkillz; 2009-08-29 at 10:35 PM. Reason: Automerged Doublepost

  10. #8
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    If the problem is still there you may be right. It could be as simply as the SIM card. You may want to try that to at least eliminate that as a possibility.

  11. #9
    Hit *#21# and tell me the output.

    It could very well be your sim.

    Are any calls at all going through?

  12. #10
    Every so often I have to keep putting in ##21# and restarting my iPhone. I'm going to call T-Mobile soon an activate this extra sim card I have lying around.

    Could this be happening because I recently took off my data plan? I had the $9.99 unlimited plan before T-Mobile canceled it on all non T-Mobile phones.

    Okay, I just replaced my sim card with the new one. Hopefully this work. If it's not the sim card causing the problems, what would I do then?
    Last edited by GreekSkillz; 2009-08-30 at 05:22 PM. Reason: Automerged Doublepost

  13. #11
    I hope it's not your phone. Maybe try and get a new sim card.

  14. #12
    I activated an unused sim-card I had lying around and still the same problems.

    **edit**

    I put my iPhone back on 3.0 to see if that fixes the issue. If not I have no idea.

    Yeah, I'm definitely not getting any phone calls.
    Last edited by GreekSkillz; 2009-08-31 at 12:11 AM. Reason: Automerged Doublepost

  15. #13
    Default Same story
    Mine used to do the same thing (3.0.1/jailbroken) right after I hooked it up to T-Mobile. the customer service said it maight take a day for the phone to register in the network, and it truly got really goood the next day.

    worked perfectly for a month, now I'm gettin same problem, i can call anyone as many times i want, never fails/drops. 5 times out of 15 people can call me.

    tried to do *#21# - it says everything is disabled. didn't help.

    tried taking the SIM out, rebooting, - didn't help.

    maybe i installed some program from cydia, that prevents it from receiving calls? (can i reinstall cydia inside cydia, just select the pagage and reinstall it, or ultrasn0w?)

    my 3G newtork service is off, i dont have data plan service, i would like to get 5.99$ (everyone is talking about it!) but t-mo rep is telling me they got now only 25$ data plan. but not having data plan - could that cause that?

    any ideas would be appreciated, it is just driving me nuts

    thanks a lot!

  16. #14
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    8
    Thanks
    1
    Thanked 2 Times in 1 Post
    I'm in the Chicago area and it happens to me as well when I switched. Although I've noticed, it's only Sprint users who try to call me.

  17. #15
    Default Fix
    Hi guys. This happened to me too. If you're on T-Mobile with an iPhone (3g or up I assume) then you are not able to use 3G because the iPhone's 3g frequency receiver doesn't match up with T-Mobile's 3g frequency. Therefore you are using EDGE for data and calls at the same time; and that means your calls are getting forwarded because the internet is using up the EDGE. If you toggle off your "cellular data" in options, then you will receive calls like normal--this is is what I resorted to. I don't use data for push (I have email set for every 15 mins--I don't want to be obsessive and answer everything right away) so I keep the cellular data off when my phone is idle and turn it on when I want to use the web. It's not difficult if you have SBSettings and can toggle it on and off easily. So that's my answer, best of luck to all of you!

  18. The Following User Says Thank You to nadej For This Useful Post:

    the_major (2010-12-27)

  19. #16
    What's happening is that you have an application of some sort that is keeping a network connection open at all times while on edge. You don't have to turn it off, but you need to identify what application is doing this to you.

  20. #17
    Quote Originally Posted by Numbski View Post
    What's happening is that you have an application of some sort that is keeping a network connection open at all times while on edge. You don't have to turn it off, but you need to identify what application is doing this to you.
    Unfortunately I have scoured through every setting on the phone to turn off push notifications, automatic updating and other notifications, set email to manual, etc. It will receive a call after that but when I reboot, it's back to the problem and no calls are received...SOMETHING is in the background sending/receiving data but I don't have any access to it to stop it.

  21. #18
    Ugh I think I'm having the same problem with my 3G running 3.1.2....

    I had the 9.99 TZones plan for a long time, and just recently stopped receiving calls. So I guess that plan will no longer work, eh? It's called "Unlimited Web for Phones" on my bill.

    So I deleted the "epc.tmobile.com" line from my APN settings, rebooted, set mail push to manual....rebooted....and am now running only on WiFi. It's now about a 50/50 chance if a call actually comes in.

    For those of us on the 9.99 or 5.99 plans, we should just delete those from our TMo accounts, right, and either just run on wifi or buck up for the 25 dollar plan? Or will there be some sort of fix?
    Last edited by eirefire22; 2011-01-02 at 10:42 PM.

  22. #19
    anybody have an update on this... Which app is screwing up the Edge? When i turn it off it works fine... However with Edge on, phone will never ring.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •