Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cydia Install without Jailbreaking again

  1. #1
    Default Cydia Install without Jailbreaking again
    I finally got my phone jailbroken unlocked and running beautifully. I was downloading Mcleaner via Cydia and my phone rebooted for some reason. Once it came back up Cydia will not run it will start up and then go back to the home screen. I was wondering if there is a way to reinstall cydia WITHOUT jailbreaking again.

    I also noticed Mcleaner didnt fully install.

    Any suggestions?

  2. The Following User Says Thank You to jaimeme1618 For This Useful Post:

    Hhryan9 (2011-03-05)

  3. #2
    Livin the iPhone Life Simtech's Avatar
    Join Date
    Aug 2007
    Location
    LA
    Posts
    2,387
    Thanks
    105
    Thanked 304 Times in 276 Posts

    nope...

  4. #3
    Retired Moderator battlecrushr's Avatar
    Join Date
    Jun 2009
    Location
    Houston follow @al_da_beast
    Posts
    7,940
    Thanks
    273
    Thanked 1,034 Times in 956 Posts

    ya u need to use terminal though do u hav it

  5. #4
    I do have terminal installed on the iphone. I have never used it but I am fairly technical. Is there a guide for it? Man I would hate to try to jailbreak it again. Any help would be appreciated.

    I came across this while earching for a fix. It was a pain in the ***** but IT WORKED !!! No need to jailbreak it again.

    At some point in the last 24 hours Saurik released a couple of updates to Mobilesubstrate through Cydia. Usually I try to keep updated with the latest and greatest (I’m a technology junkie) so I ran the upgrade will I grabbed my morning cup of tea (I’m also English after all). Normally after an upgrade you’ll see a prompt to restart springboard, however with this update the phone rebooted part way through the install. A worrying signal. After the reboot everything seemed to be fine, except Cydia refused to start fully. After showing the default Cydia screen fir a few seconds, Cydia would disappear.

    After a couple of reboots to make sure the issue wasn’t going to solve itself, I had a quick look on Saurik’s twitterfeed but he had no mention of the issue. Several followers however were having the same issue. Time to find a solution.

    I dropped to the terminal (although making an SSH connection would also have done the trick) and su’d to root. For those new to this the default password for root is alpine and if you’ve upgraded to version 3.0 this WILL have been reset. So change the root and mobile users passwords using ‘passwd’ before somebody else connects and does Anyway, I digress.

    After getting root access it’s time to see what state the mobilesubstrate and cydia packages were in. After an ‘apt-get update’ (to get the updated package lists) and and ‘apt-get install cydia’ it looks like the package is corrupted, as I’m prompted to run ‘dpkg –configure -a’. After this is completed, I reran the ‘apt-get install cydia’, and then an ‘apt-get upgrade’ to reinstall the failed mobilesubstrate and in my case the new VoIP 3G app. After another reboot (type reboot at the prompt or whatever your preferred method is) things seem to be running fine again.

    For those with short attention spans .:

    * Shell access (terminal or ssh)
    * Su to root
    * dpkg -configure -a
    * apt-get update
    * apt-get install cydia (if this fails add –fix-missing)
    * apt-get upgrade (to install mobilesubstrate correctly)
    * reboot

    I hope this solves your issues as easily as it did mine. Let me know if you have any issues.

    update: There are a few other guides going around telling you to connect the iphone to your system (or useiFile) and then delete specific files. I’ve not tested these fixes, but the chance of deleting files you need are always there. I’d suggest using the easy fix using apt-get before trying the file deletion route. However it’s a personal choice.

    Fixing Cydia Ramblings of the šnal security guy
    Last edited by jaimeme1618; 2009-08-01 at 05:01 AM. Reason: Automerged Doublepost

  6. The Following User Says Thank You to jaimeme1618 For This Useful Post:

    Lantry (2010-11-23)

  7. #5
    Can anyone tell me how to restore Cydia without "rejailbreaking" it again? I totally lost the app icon.. i tried all of the steps/guides to retrieve it..but failed

    Is there a way to just download the app?

    Thanks in advance

  8. #6
    iPhone? More like MyPhone posrjak's Avatar
    Join Date
    Sep 2007
    Location
    PDX
    Posts
    195
    Thanks
    15
    Thanked 7 Times in 7 Posts

    You can try to reinstall it with blackra1n. Or try to reinstall with rock.

  9. #7
    yup,thanks! but don't want to re-jailbreak again is there any link /website just to download an app of cydia?

    I tried also installing it with the terminal app and do the "apt-get install cydia" with the deb file, but no success..

  10. #8
    Why don't you want to jailbreak again? it isn't going to mess up your phone... and even the dev team has said, if you accidentally delete cydia, or something isn't working, just re-jailbreak...

    It just seems to me, all the stuff your doing in terminal, and all that fun stuff, you'd literally have to wait 5 minutes for your phone to be rejailbroken... and if your running 3.1.2 it'll take 30 seconds...
    The only thing I ask in return for helping, is that you click the thanks button, Thanks!

  11. #9
    I ran into the same issue. I could not open Cydia after downloading a corrupt file. I you have Rock, install or open. Rock will inform you of any errors or corrupt files that is causing problems. Follow the prompts or directions to restore. Before you exit Rock, make sure you install Cydia installer pack. I did this in less then 1 minute and Cydia is working perfectly without losing apps.

  12. #10
    I want to install Cydia without jailbreak.
    Last edited by Zion Shamo; 2010-10-08 at 02:52 PM.

  13. The Following User Says Thank You to Zion Shamo For This Useful Post:

    teakimlong (2010-10-07)

  14. #11
    Quote Originally Posted by jaimeme1618 View Post
    * Shell access (terminal or ssh)
    * Su to root
    * dpkg -configure -a
    * apt-get update
    * apt-get install cydia (if this fails add –fix-missing)
    * apt-get upgrade (to install mobilesubstrate correctly)
    * reboot
    This worked for me, although it kept giving me errors until i looked in another forum which gave similar instructions, except there were two dashes in dpkg -configure -a. (should be: dpkg --configure -a) after trying your instructions with the two dashes in ONLY THIS LINE, it worked. thank you.
    REMEMBER: only place you should need two dashes is in "dpkg --configure -a", the rest are as written.

  15. The Following User Says Thank You to Lantry For This Useful Post:

    savageinjun (2011-01-10)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •