Page 1 of 2 12 LastLast
Results 1 to 20 of 36

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: MMS 2G MMS + epc.tmobile.com - How to make it work?

  1. #1
    Default MMS 2G MMS + epc.tmobile.com - How to make it work?
    I have T-Zones and looks like I ran into a big issue here.

    The APN I use for data is: epc.tmobile.com
    The APN for MMS: wap.voicestream.com

    However, when the DATA + MMS APN are not the same, the MMS APN does not stick, it gets erased!
    It only works it both APN's are wap.voicestream.com...

    Anybody found a way around this issue?
    Thank you.
    Housekeepin'?

  2. #2
    You need to change the Data APN and IMMEDIATELY reboot your phone using the Sleep/Wake button. Once you make the change do not exit out of settings or do anything else on the phone. Modify the APN and reboot from the Data Settings screen.

  3. #3
    That method did not work.

    I entered first epc.tmobile.com under DATA...
    Then entered wap.voicestream.com for MMS, pressed return to skip a line and then rebooted iPhone.

    Had a friend send me an MMS = FAIL
    Then, went back to Cellular Data Network and MMS Settings was gone again...

    Any other sugestions???


    So far, I am only able to send/receive MMS using wap.voicestream.com for both APN configuration (Data + MMS).
    CORRECTION: Only able to RECEIVE. Still having a little trouble with Sending...
    So far out of 3 people I sent, 2 AT&T (3G / 2G) and 1 T-Mobile (Random phone), only the 3G AT&T received.
    Last edited by Oliver350Z; 2009-07-01 at 08:02 PM.
    Housekeepin'?

  4. #4
    Green Apple
    Join Date
    Oct 2008
    Location
    Little Elm, Texas
    Posts
    49
    Thanks
    3
    Thanked 5 Times in 4 Posts

    here are the settings that work,

    Cellular Data

    APN epc.tmobile.com
    USERNAME blank
    PASSWORD blank

    MMS

    APN epc.tmobile.com
    USERNAME blank
    PASSWORD blank
    MMSC http://mms.msg.eng.t-mobile.com/mmswapen
    MMS PROXY 216.155.165.50:8080
    MMS MAX MESSAGE SIZE blank
    MMS UA PROF URL blank

    Hope it works for everyone, because it sure is working for me

    Let me know if it works for you.
    Last edited by djw78421; 2009-07-01 at 08:09 PM. Reason: Automerged Doublepost

  5. #5
    ^ NO GO... with these settings

    I get the (!) when trying to send.
    Housekeepin'?

  6. #6
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    I had to use the same APN for both Data and MMS, only way it would work for me.
    I read this on another thread that a user actually called T Mo support and they had instructed him to do it this way.
    So what ever APN setting worked for you before for data, try using it for MMS too. Hopefully it will work for you.

  7. #7
    Green Apple
    Join Date
    Mar 2008
    Location
    Scottsdale AZ
    Posts
    85
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Quote Originally Posted by Oliver350Z View Post
    ^ NO GO... with these settings

    I get the (!) when trying to send.
    i have the same problem as you! if you find a solution please pm me! thanks.

  8. #8
    Quote Originally Posted by Oliver350Z View Post
    ^ NO GO... with these settings

    I get the (!) when trying to send.
    What data plan are you on?

    I've yet to get epc and mms to work with epc as the MMS apn. Not sure why, that's how my G1 is setup.

    Have any of you installed one of the ipcc files available on this forum? Once you do that you can sftp into your phone and edit the carrier.plist directly.
    Last edited by ironicirony; 2009-07-01 at 09:27 PM. Reason: Automerged Doublepost

  9. #9
    ^^^ Sure did. Its easy to install, and worked perfect. The picture quality is now where it should be. Amazing. I wouldnt use the settings above.

  10. #10
    WORKING!!!

    He mistyped on the APN Settings...
    People with T-Zones, try this Settings...
    It should work!

    Cellular Data

    APN: epc.tmobile.com
    USERNAME: (leave blank)
    PASSWORD: (leave blank)

    MMS

    APN: epc.tmobile.com
    USERNAME: (leave blank)
    PASSWORD: (leave blank)
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS PROXY: 216.155.165.50:8080
    MMS MAX MESSAGE SIZE: (leave blank)
    MMS UA PROF URL: (leave blank)


    (Also, feel free to ask me any questions)

    EDIT (REPLY TO IRONICNY): I finally got EPC to work with MMS, see settings above.

    Steps I took:

    1) Made sure I did not have "AsBattery" installed.
    2) Installed "ActivateMMS2G"
    3) Reboot Device.
    4) Setup up MMS on Cellular Data Network (with the information above)
    5) Reboot Device.
    6) Made sure Message Settings had MMS turned on
    7) Tested Sending MMS = OK / Tested Receiving MMS = OK
    Last edited by Oliver350Z; 2009-07-01 at 10:20 PM.
    Housekeepin'?

  11. The Following 3 Users Say Thank You to Oliver350Z For This Useful Post:

    Blackstev08 (2009-09-27), falconeyez (2009-07-02), HungLO (2009-07-12)

  12. #11
    Quote Originally Posted by Oliver350Z View Post
    WORKING!!!

    He mistyped on the APN Settings...
    People with T-Zones, try this Settings...
    It should work!

    Cellular Data

    APN: epc.tmobile.com
    USERNAME: (leave blank)
    PASSWORD: (leave blank)

    MMS

    APN: epc.tmobile.com
    USERNAME: (leave blank)
    PASSWORD: (leave blank)
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS PROXY: 216.155.165.50:8080
    MMS MAX MESSAGE SIZE: (leave blank)
    MMS UA PROF URL: (leave blank)


    (Also, feel free to ask me any questions)

    EDIT (REPLY TO IRONICNY): I finally got EPC to work with MMS, see settings above.

    Steps I took:

    1) Made sure I did not have "AsBattery" installed.
    2) Installed "ActivateMMS2G"
    3) Reboot Device.
    4) Setup up MMS on Cellular Data Network (with the information above)
    5) Reboot Device.
    6) Made sure Message Settings had MMS turned on
    7) Tested Sending MMS = OK / Tested Receiving MMS = OK
    OMG!!! You're my hero! Now to get the resolution working correctly
    Last edited by falconeyez; 2009-07-02 at 12:19 AM.

  13. #12
    Green Apple
    Join Date
    Mar 2008
    Location
    Scottsdale AZ
    Posts
    85
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Default amazing thanks!
    Quote Originally Posted by Oliver350Z View Post
    WORKING!!!

    He mistyped on the APN Settings...
    People with T-Zones, try this Settings...
    It should work!

    Cellular Data

    APN: epc.tmobile.com
    USERNAME: (leave blank)
    PASSWORD: (leave blank)

    MMS

    APN: epc.tmobile.com
    USERNAME: (leave blank)
    PASSWORD: (leave blank)
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS PROXY: 216.155.165.50:8080
    MMS MAX MESSAGE SIZE: (leave blank)
    MMS UA PROF URL: (leave blank)


    (Also, feel free to ask me any questions)

    EDIT (REPLY TO IRONICNY): I finally got EPC to work with MMS, see settings above.

    Steps I took:

    1) Made sure I did not have "AsBattery" installed.
    2) Installed "ActivateMMS2G"
    3) Reboot Device.
    4) Setup up MMS on Cellular Data Network (with the information above)
    5) Reboot Device.
    6) Made sure Message Settings had MMS turned on
    7) Tested Sending MMS = OK / Tested Receiving MMS = OK
    thanks man worked great now! how do you get the image quality better?

  14. #13
    Quote Originally Posted by smokeyismyg View Post
    thanks man worked great now! how do you get the image quality better?
    Here...
    http://www.modmyi.com/forums/file-mo...esolution.html

    Or Here...
    http://www.modmyi.com/forums/t-mobil...er-bundle.html

    I'd recommend the IPCC method in the second link. You'll have to type your MMS settings in again when you're done to continue using epc for the MMS APN.

  15. #14
    Green Apple
    Join Date
    Mar 2008
    Location
    Scottsdale AZ
    Posts
    85
    Thanks
    2
    Thanked 5 Times in 5 Posts

    ok i am trying to understand the ipcc thing. is there a way for me to just change a plist or something through ssh?

  16. #15
    Quote Originally Posted by smokeyismyg View Post
    ok i am trying to understand the ipcc thing. is there a way for me to just change a plist or something through ssh?
    If you aren't using a custom carrier bundle at all you should be able to ssh into the phone and modify the carrier.plist in the unknown.bundle. What you would need to add is covered in that first link.

    However... the zip file for the ipcc in the second post contains a README that covers how to setup iTunes to install a custom ipcc. Honestly it's the better route. It solves lost setting issues and adds a real T-Mobile bundle to the phone.
    Last edited by ironicirony; 2009-07-02 at 01:40 AM.

  17. #16
    Green Apple
    Join Date
    Mar 2008
    Location
    Scottsdale AZ
    Posts
    85
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Quote Originally Posted by ironicirony View Post
    If you aren't using a custom carrier bundle at all you should be able to ssh into the phone and modify the carrier.plist in the unknown.bundle. What you would need to add is covered in that first link.

    However... the zip file for the ipcc in the second post contains a README that covers how to setup iTunes to install a custom ipcc. Honestly it's the better route. It solves lost setting issues and adds a real T-Mobile bundle to the phone.
    ok ill look into it. thing is my t-mobile logo is already fine it always has been. i have never had that scrolling issue. basically i don't want to mess up my phone with not being able to use edge or something or lose service. so i don't like to mod files that i can't change back. basically what i am saying is will i do any harm to my phone by doing this? and you said if i don't have a custom carrier bundle i can just change the plist? so what do i need the ipcc for?
    also where is the bundle file located through ssh? can you give me the directory path? thanks and once again i am not using a carrier bundle....i just want to clear up the picture quality.
    Last edited by smokeyismyg; 2009-07-02 at 01:48 AM. Reason: merge double post

  18. #17
    Quote Originally Posted by smokeyismyg View Post
    ok ill look into it. thing is my t-mobile logo is already fine it always has been. i have never had that scrolling issue. basically i don't want to mess up my phone with not being able to use edge or something or lose service. so i don't like to mod files that i can't change back. basically what i am saying is will i do any harm to my phone by doing this? and you said if i don't have a custom carrier bundle i can just change the plist? so what do i need the ipcc for?
    In theory having a carrier specific ipcc makes things work better... not worse. I do understand the if it ain't broke don't fix it motto however.

    As far as not being able to change back, if it breaks something that can't be fixed by reconfiguring the Data Settings (which it shouldn't)... you can SSH into the phone and delete the TMobile_US Bundle. After a reboot you should be back to where you were.

    As for editing the plist, it's actually a bit trickier when you don't have a custom carrier bundle. You'll need to pull the carrier.plist and convert it first (it will be in binary on the phone), make your edits, and then re-upload it.

  19. #18
    Green Apple
    Join Date
    Mar 2008
    Location
    Scottsdale AZ
    Posts
    85
    Thanks
    2
    Thanked 5 Times in 5 Posts

    oh alright well i think i am happy the way it is then as long as it works. i appreciate your help! but some people aren't getting my mms it says it sent on my iphone though. anyway do you need an internet plan for this to work i am trying to set it up for my friend and he doesn't have a data plan but has unlimited mms and text on his account.

  20. #19
    Quote Originally Posted by smokeyismyg View Post
    oh alright well i think i am happy the way it is then as long as it works. i appreciate your help! but some people aren't getting my mms it says it sent on my iphone though. anyway do you need an internet plan for this to work i am trying to set it up for my friend and he doesn't have a data plan but has unlimited mms and text on his account.
    I don't think he should need a data plan.

  21. #20
    Green Apple
    Join Date
    Mar 2008
    Location
    Scottsdale AZ
    Posts
    85
    Thanks
    2
    Thanked 5 Times in 5 Posts

    Quote Originally Posted by ironicirony View Post
    I don't think he should need a data plan.
    ok testing now thanks for your reply. for the modding the plist flie for the clearer pictures can you give me the ssh directory or path to get to the bundles folder. also is this what i put in ?<key>MMS</key>
    <dict>
    <key>GroupModeEnabled</key>
    <false/>
    <key>MMSC</key>
    <string>http://blah.blah.blah</string>
    <key>Proxy</key>
    <string>255.255.255.255:8080</string>
    <key>UserAgent</key>
    <string>SonyEricssonW800i/R1L</string>
    <key>UAProf</key>
    <string>http://wap.sonyericsson.com/UAprof/W800iR101.xml</string>
    <key>Version</key>
    <string>1.2</string>
    </dict>

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •