Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Tmobile voicemail issue

  1. #1
    Default Tmobile voicemail issue
    I've had a nagging issue with my iPhone for some time now and finally I'm sick of tolerating it...

    My "New Voicemail" dot is CONSTANTLY comming back on even if I don't have any new voicemails. I use youmail and have the phone set up so it dials youmail to check my messages but in order for me to clear the dot I need to call the TMOBILE voicemail phone number even though I don't use them.

    Has anyone else experienced this issue?

  2. #2
    We all do. Just a minor annoyance with having a jailbroken iPhone on a network that doesn't have visual voicemail.

  3. #3
    Livin the iPhone Life adp's Avatar
    Join Date
    Jan 2009
    Location
    South FL
    Posts
    1,789
    Thanks
    32
    Thanked 460 Times in 321 Posts

    Quote Originally Posted by ohsoferrety View Post
    We all do. Just a minor annoyance with having a jailbroken iPhone on a network that doesn't have visual voicemail.
    Uhh...I don't think so. I've never experienced that problem. I only get the red dot when I get a new voicemail. That's it. It doesn't pop up whenever I don't have a new message. I'm not saying it doesn't happen to anyone, but I'm pretty sure its not a general problem.

    What FW are you running? Perhaps an unlock issue? Or it may be a compatibility issue with a 3rd party app. I downloaded "Pandora Controls" for my 3.0 FW, and right after this happened, my e-mails would not delete. Every time I locked my phone they would come back up as new.
    If I helped you out, please use the Thanks button ------------------------->

  4. #4
    Weird. My iPhone, since the day I unlocked it (with every firmware), plus any other unlocked iPhone with T-Mobile I've ever laid hands on, has had the "red-dot" issue. Usually happens when signal goes out (ie - put on airplane mode, travelled in and out of service area, just turning on the phone).
    Last edited by ohsoferrety; 2009-06-28 at 11:35 PM. Reason: correction

  5. #5
    Quote Originally Posted by ohsoferrety View Post
    We all do. Just a minor annoyance with having a jailbroken iPhone on a network that doesn't have visual voicemail.
    Not true. Ive always had my iPhone (original and 3G) on Tmo and have never experienced this issue.

    Quote Originally Posted by ohsoferrety View Post
    Weird. My iPhone, since the day I unlocked it (with every firmware), plus any other unlocked iPhone with T-Mobile I've ever laid hands on, has had the "red-dot" issue. Usually happens when signal goes out (ie - put on airplane mode, travelled in and out of service area, just turning on the phone).
    What sort of jailbroken apps are you running? If I were you I would restore (using your method of choice) and see if it happens right out of the gate. I have a feeling its an app causing the conflict. Let me know what happens, Im curious.
    Last edited by justinclark; 2009-06-29 at 02:41 AM. Reason: Automerged Doublepost

  6. #6
    Quote Originally Posted by Lemony Vengeance View Post
    I've had a nagging issue with my iPhone for some time now and finally I'm sick of tolerating it...

    My "New Voicemail" dot is CONSTANTLY comming back on even if I don't have any new voicemails. I use youmail and have the phone set up so it dials youmail to check my messages but in order for me to clear the dot I need to call the TMOBILE voicemail phone number even though I don't use them.

    Has anyone else experienced this issue?
    I've had the exact same problem. You need to upgrade your sim to a new 64k sim card. For some reason certain old t-mobile sim cards causes the problem you describe. T-mobile should replace the sim card free of charge. T-mobile didnt charge me

  7. #7
    Free? I don't know about that.. tmobile tries to charge me for EVERYTHING. also, how do I tell the difference between a 32K and 64K sim?

  8. #8
    Quote Originally Posted by Lemony Vengeance View Post
    Free? I don't know about that.. tmobile tries to charge me for EVERYTHING. also, how do I tell the difference between a 32K and 64K sim?
    If they try to charge you just go to another retail store. The SKU (top barcode) on the back of the sim should end in 20, not 10.

  9. #9
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    Quote Originally Posted by Joe270 View Post
    I've had the exact same problem. You need to upgrade your sim to a new 64k sim card. For some reason certain old t-mobile sim cards causes the problem you describe. T-mobile should replace the sim card free of charge. T-mobile didnt charge me

    ummm no i have a sim from when t-mobile first came out it has the old T on it and everything, its one of the good sims that you can actually change the voicemail number on

  10. #10
    Quote Originally Posted by Pcpro745 View Post
    ummm no i have a sim from when t-mobile first came out it has the old T on it and everything, its one of the good sims that you can actually change the voicemail number on
    I didn't say all old sim cards....

  11. #11
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    Got ya!

  12. #12
    Quote Originally Posted by Joe270 View Post
    I've had the exact same problem. You need to upgrade your sim to a new 64k sim card. For some reason certain old t-mobile sim cards causes the problem you describe. T-mobile should replace the sim card free of charge. T-mobile didnt charge me
    I can vouch for this. Had the red voicemail button on phone app, had to call it to remove it, but upon restarting the phone it always came back.

    Heard about this like 6 months ago, and went ahead to the T Mobile Store and told them I was having signal problems, dropped calls, and I thought it was my SIM. They went ahead and got a new SIM for me and even transferred my contacts FREE OF CHARGE.

    When I put in in my iPhone, what do you know, no more blank red icon upon restart.

  13. #13
    i too have to probably agree with this as well...i had an older card with my iphone a few months back, i went in told them i was having connection problems, they gave me a new one...worked...in fact i just j/b and unlocked an iphone i just bought for my gf, her sim card is at least a good 3-4 years old and wouldn't you know it the vm indicater is going crazy on hers...guess it's time to go get her a new sim as well

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •