Page 1 of 2 12 LastLast
Results 1 to 20 of 23

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Want an iphone but have questions*please help*

  1. #1
    Green Apple iphoneraz's Avatar
    Join Date
    Jun 2009
    Location
    Az
    Posts
    49
    Thanks
    6
    Thanked 2 Times in 1 Post
    Question Want an iphone but have questions*please help*
    First let me start by saying I am a noob But we all were at some time A good friend of mine got a 3G for free from work, now he is going to upgrade to the 3Gs and will sell me his 3G for cheap. this is where the questions come in. I've searched for hours and hours trying to get answers that I'm confident with but not there yet. So while I'll probably get flamed for not searching here goes.

    How can I use the 3G on tmobile? Do I need a sim adapter (gevey?) should i just forget the 3G and get a 2G?

    What is the cheapest data plan I can use on tmobile? I've serched this but alot of the posts coming up are old and tmobile has changed data plans recently, also getting contradicting info about what plans work and what plans don't work. Ie. does the 19.99 so called unlimited data (100mb cap)and messaging phone plan work? can anyone really confirm? Does the 24.99 G1 plan have any messaging (300,400) with it? it does not specify on tmobiles website.

    If I use it without a data plan for a while what do I need to do to prevent data charges?

    I would really appreciate some help, in fact a sticky with all this info (up to date) would be awesome! This site has been very helpful so far. we unlocked a 2G for my brother and it works fine but he's got the 34.99 plan and I don't want to pay that much, plus his is a 2G. Thanks in advance!!

  2. #2
    iPhone? More like MyPhone owensdus's Avatar
    Join Date
    Aug 2007
    Location
    Good Ole Oklahoma
    Posts
    119
    Thanks
    3
    Thanked 5 Times in 5 Posts

    First I would tell your friend not to upgrade the firmware when 3.0 comes out. then it just depends on what firmware is on it. If it has the latest 2.2.1 I would go with a gevey 3g plus2 sim adapter. But if it is 2.2 I would jailbreak it using quickpwn and then install yellows0nw from cydia. If is is a lower firmware then either of these I would recommend upgrading to the 2.2 because of how easy it is to unlock it.

    As to data I am using the tmo 24 dollar plan and 20 dollar unlimited text. you can call tmo and they will hook you up on what plans you need. They have a deparment just for unsupported phone, like the iphone. There is also the 5.99 data hack in cydia, but Im not sure if it works on 2.2.

    let me know if this helped.
    Last edited by owensdus; 2009-06-10 at 05:19 PM.

  3. The Following User Says Thank You to owensdus For This Useful Post:

    iphoneraz (2009-06-10)

  4. #3
    Green Apple iphoneraz's Avatar
    Join Date
    Jun 2009
    Location
    Az
    Posts
    49
    Thanks
    6
    Thanked 2 Times in 1 Post
    yes this helps, at least i now understand that the 3G can be unlocked with yellowsn0w or a sim adapter. And thanks for confirming, I was already planning on telling him not to update to 3.0.

    Anymore input or help is appreciated. If anyone is currently using a data plan less than 30.00/month your insight would be awesome.

    Also I thought the 5.99 hack (tzones) is no longer avail/doable?

    Anyone have a direct number to tmobile unsupported devices CS?

  5. #4
    I had a 3G a few weeks ago and I could not get service on it and now I have a 2G. But I learned from my mistakes. To see if you can unlock it using yellowsnOw you need to see what Modem firmwire if its 02.28.00 then things are looking good and it will work. If you have 02.30.03 i think it is, you can jailbreak it an then download a app called fizzydowngrader and it will downgrade it for you safetly only if you have bootloader 5.9 (5.09). If none of that works then use a sim adapter. Just wanted to let you know.

  6. #5
    Green Apple iphoneraz's Avatar
    Join Date
    Jun 2009
    Location
    Az
    Posts
    49
    Thanks
    6
    Thanked 2 Times in 1 Post
    okay i will keep this in mind, needs to get all that info from my friends iphone. any instructions on where to go for all the info? guess i need to do more research since i'm not familiar with some of there terms like boot loader.

  7. #6
    once you download the fizzydowngrader it will tell you what bootloader version he has. It will not harm the phone if it can or can not downgrade so he will not experience any difference with his phone. If you do a search on here on how to downgrade 3g the fizzydowngrader should come up somewhere.

  8. #7
    Green Apple iphoneraz's Avatar
    Join Date
    Jun 2009
    Location
    Az
    Posts
    49
    Thanks
    6
    Thanked 2 Times in 1 Post
    so the thing to do is find out the firmware, if it is not 02.28.00 then jailbreak it, dwnload fizzydowngrader and find out the bootloader and go from there.

    so if the bootloader is not 5.09 then the only thing to do is use a sim adapter? or is there a way to really downgrade the iphone 3G to iphone 2G type firmware/bootloader ect? thanks guys!

  9. #8
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    nope, sim adapter only

  10. #9

  11. #10
    Green Apple iphoneraz's Avatar
    Join Date
    Jun 2009
    Location
    Az
    Posts
    49
    Thanks
    6
    Thanked 2 Times in 1 Post
    thanks blkcadi. nice I'm in AZ as well. so i guess i really need to find out the boot loader first. sounds like that is pretty important. is fizzydowngrader the only way to find out what boot loader the phone has? is there another way? does it have to first be jailbroken to find out the boot loader version. sorry for the many questions but i need iphone

  12. #11
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    yup, download in Cydia. Must be jailbroken to get this app. It's called Fuzzyband, not fizzyband btw

    As far as data plans and messaging, it's best to speak to a rep from T-Mo. they are quite helpful.
    Last edited by Bo Troxell; 2009-06-10 at 10:06 PM. Reason: Automerged Doublepost

  13. #12
    Green Apple iphoneraz's Avatar
    Join Date
    Jun 2009
    Location
    Az
    Posts
    49
    Thanks
    6
    Thanked 2 Times in 1 Post
    Quote Originally Posted by slinky1914 View Post
    great thanks! this seems pretty clear and easy to follow. i need to get my hands on that iphone soon and see what version it is, what firmware it has and what bootloader. then go from there. thanks.

  14. #13
    YellowSn0w only works with BB 2.28.00 (at the moment - this could change in the next few weeks)
    BB2.28.00 came with FW2.20
    If a device has FW2.21 it will have BB2.30.03 (unless someone was clever and upgraded the FW while preserving the BB which is very unlikely)
    Unless the device was built before week 29 of 2008 it will not have BL5.8 - the majority of devices were built after that and have a later BL and so the BB can not be downgraded.
    If the device is not jailbroken you can not use fuzzy but the 3rd 4th and 5th numbers of the serial number will give you an idea - if they are greater than 829 you will have a higher BL unless the first 2 digits are 5K in which case it is a refurb and you can't tell.
    Things are likely to change with the imminent release of FW 3.0
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  15. #14
    I have bootloader 5.09 and fuzzydowngrader said enjoy your aids (aka cannot downgrade baseband). I noticed before someone wanted an iphone with 5.09 bootloader on it, but from everything I have read I cannot unlock with this bootloader. Did I miss something?

  16. #15
    The unlock has nothing to do with the BL. Only BB 2.28.00 can currently be unlocked with YellowSn0w but that could change after the release of the 3Gs next week.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  17. #16
    Retired Moderator Zwayne's Avatar
    Join Date
    Nov 2007
    Location
    Independence, LA
    Posts
    5,633
    Thanks
    656
    Thanked 764 Times in 591 Posts

    You would be correct, in that you can't unlock with BL 5.09 & baseband 2.30.00 let me make that clear!!!

    vvvvSome people.....
    Last edited by Zwayne; 2009-06-13 at 12:33 AM.

  18. #17
    Not true!
    The BL is nothing to do with the unlock. My phone is unlocked with BL 5.9.
    What you can't do with BL 5.9 or above is downgrade the BB.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  19. #18
    Green Apple iphoneraz's Avatar
    Join Date
    Jun 2009
    Location
    Az
    Posts
    49
    Thanks
    6
    Thanked 2 Times in 1 Post
    Quote Originally Posted by confucious View Post
    Not true!
    The BL is nothing to do with the unlock. My phone is unlocked with BL 5.9.
    What you can't do with BL 5.9 or above is downgrade the BB.
    is your phone unlocked with a sim adapter? what makes a phone unlockable at this time?

  20. #19
    Retired Moderator Zwayne's Avatar
    Join Date
    Nov 2007
    Location
    Independence, LA
    Posts
    5,633
    Thanks
    656
    Thanked 764 Times in 591 Posts

    If you have baseband 2.28.00 then your phone can be unlocked by yellowsn0w.

  21. #20
    Green Apple iphoneraz's Avatar
    Join Date
    Jun 2009
    Location
    Az
    Posts
    49
    Thanks
    6
    Thanked 2 Times in 1 Post
    Quote Originally Posted by Zwayne View Post
    If you have baseband 2.28.00 then your phone can be unlocked by yellowsn0w.
    even with a 5.9 bootloader? or is that not possible. i mean a 2.28.00 would not have a 5.8 BL? thx

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •