Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G; 2.2.1 with "No SIM" Problem... Need Help Solving!

  1. #1
    Exclamation iPhone 3G; 2.2.1 with "No SIM" Problem... Need Help Solving!
    Okay so last night before I went to bed my iPhone lost service and it said "No SIM" where it would usually say T-Mobile. I have had the No Service and No SIM glitches before so I thought I would just fix it in the morning (usually by just putting my sim in another phone and then back into the iphone).

    So then I woke up today and took my sim off of my SIM Unlock chip, and out of my iphone; and then put it into my backup phone. I gained service right away, went onto a webpage, then turned my phone off and removed my sim.


    Then I put my sim back onto the sim unlock chip in the iphone Sim tray and put it back into the iphone. Then I turned the iPhone on, and it still said no sim. So I repeated the whole process TWICE and still it didnt work. So then I went to seek help online. I looked at loads of threads on many forums and followed steps that worked for other people.

    I tried resetting my network settings multiple times; didnt work. I tried removed and cleaning my Sim card; didnt work. I even tried resetting all settings on my iPhone and it didnt work, and after that I tried resetting my network setting again and it still didnt work!




    I have no idea's what left to do, when my dad gets home later I am going to see if his Sim card will work in my phone. I have never had this problem where it wouldn't go away before, so the only other thing I can think of to do would be to restore the whole phone in iTunes (Which I REALLY do not want to do!).


    So if you guys can help me at all, please do so.

    Please DO NOT waste my time with double posts on something that was already suggested, or suggest something that I've already tried (Read this whole post before posting!)


    Thanks
    Kahl

  2. #2
    You need a new sim-adaptor. Yours crapped out.

  3. #3
    Are you sure?


    FML!



  4. #4
    Dont turn your iPhone off when you remove and re-insert your sim.

  5. #5
    Livin the iPhone Life
    Join Date
    Jan 2008
    Location
    sd
    Posts
    1,084
    Thanks
    8
    Thanked 99 Times in 79 Posts

    yah try it without turning the phone on/off. if that still doesnt work, get a new sim adapter
    1.1.1>1.1.2>1.1.4>2.0>2.1>2.2>3.1>3.1.2 blackra1n'd

    waitin on my white iphone 4

  6. #6
    Already tried that.

  7. #7
    Try a restore. I doubt it will work, but you never know...

    You may want to try downgrading to 2.2. This is beleived to be impossible because when you upgrade, i
    Tunes also upgrades the baseband, but this guy seemed to get it done.
    Last edited by navyfootball94; 2009-03-29 at 05:51 AM.

  8. #8
    Thanks man, nice info there, I just don't want to be bothered with downgrading the whole phone or restoring it, I'm trying to get another sim adapter from the manufacturer at the moment.

  9. #9
    Default SIM Card Adapter
    It's been such a long time, but...Do you remember how did you solved the "No SIM Card Inserted" problem? Did you replace the SIM Card adapter?
    TIA

  10. #10
    why are you still on 3.1.2?


    Like A Boss

  11. #11
    Default No SIM problem
    Yeah, I'm still on 3.1.2 since it was working fine (until I dropped it and got the message). Truth is I bought it already jailbroke, so I didn't want to mess trying to upgrade it. Do you think that upgrading it would solve the problem?
    Thx

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •