Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: T-Mobile not being recognized after Jailbreak

  1. #1
    Default T-Mobile not being recognized after Jailbreak
    So I'm using an iPhone 3G 2.2.1 with a turbo sim unlock. When I received the turbo sim i put it in the iPhone with my t-mobile sim and T-mobile was recognized, and I was able to text/call and use the internet. However, after jailbreaking it t-mobile isn't recognized anymore. It says "Searching...." at the top and then the status bars show up as well as the Edge icon right next to each other. I go to settings and the Carrier tab is blank. Then after about 20 seconds it says No service, then searching... again and then the status bars show up again.. then occasionally it says no sim installed. But basically after jailbreaking the phone i have not been able to text/call, t-mobile is not being recognized at all.

    anyone know a solution?

    Thanks in advance.

  2. #2
    I'm not positive but I think you are pretty much F'ed. I don't think you can unlock after jailbreaking using 2.2.1 firmware. I also don't think you can downgrade your firmware and have it work once you have jailbroken using 2.2.1 either. I would research before taking my word for it but I think that's how it works.

  3. #3
    Ok. Well make sure 3g is OFF. Also, remove your sim card, load it into a t-mobile phone. Let the sim card stay in there for a minute or 2 after bootup, and then load it back into the iphone.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •