Hey everybody. So, I jailbreaked my old First-Gen iPhone for my sister as she's on T-Mobile, using Pawnage 2.0 when Firmware 2.0 was first released.

Everything was working just fine until a couple of weeks ago when she was in a text message screen and couldn't click the "Messages" button on the top left to get back to a list view of her messages.

She went on to check some other first-party AND third-party applications and found that the top part of the screen wasn't functioning on just SOME of the other iPhone's applications (which leads me to believe that it's probably a software issue and NOT the touchscreen itself as the top part is still functional in some applications).

We tried "restoring" the phone, but to no avail. We tried re-Pwning the phone with Pawnage 2.0.3 for Firmware 2.0.2. Everything's working fine except for the same problem.

I've included some screencaps below to indicate some examples of what's working and what's not ... RED doesn't work, GREEN works fine:



Any suggestions on how we can fix this problem would be greatly appreciated. Thanks all. Look forward to hearing back.