Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: New T-Zones hack 1.1.x owners - THE INSTRUCTIONS ARE WRONG!!!!

  1. #1
    What's Jailbreak?
    Join Date
    Aug 2008
    Location
    Tampa, FL
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Default New T-Zones hack 1.1.x owners - THE INSTRUCTIONS ARE WRONG!!!!
    If you were like me and your hack still wasn't working after making the aforementioned proxy changes listed here: T-Zones Changes IPs. New Hack - iPhone News & Review then read on...

    You CANNOT just change the 10.0.0.0″ to 25.0.0.0″ in the proxy.pac file. You must edit the file so BOTH addresses are listed in the config. Code listed below:

    Code:
    function FindProxyForURL(url, host)
    {
    if ((isInNet(myIpAddress(), "25.0.0.0", "255.0.0.0")) || (isInNet(myIpAddress(), "10.0.0.0", "255.0.0.0")))
    return "PROXY 216.155.165.50:8080";
    else
    return "DIRECT";
    }
    After 3 days of trying my Internet is finally back up. Hopefully if you were scratching your head like I was, this will work for you as it did me.

    - The Spectacle
    Last edited by The Spectacle; 2008-08-30 at 12:08 AM.

  2. #2
    Hi, i followed the instructions of the OP and i still can't connect to the internet. Instead, I will receive this error "HTTP ERROR: $CODES$ $MESSAGE$ Request URI=/" despite of countless tries.

    Is there anybody there kindly enough to explain my situation. Thank you.
    Last edited by mikeyiphone; 2008-08-30 at 04:19 PM.

  3. #3
    Quote Originally Posted by mikeyiphone View Post
    Hi, i followed the instructions of the OP and i still can't connect to the internet. Instead, I will receive this error "HTTP ERROR: $ $ Request URI=/" despite of countless tries.

    Is there anybody there kindly enough to explain my situation. Thank you.
    i was having the same problem - edited the proxy.pac exactly as shown and still nothing was working. but thanks to a post by b4lyph on another thread, i got it rolling and now everything is back to normal and working. you need to edit the proxy.pac as shown in TWO places, not just one. here's his post that has the directions i followed to get it back up and running:

    I am pretty sure I found out the answer to why it is not working even when you changed the proxy.pac file in /var/preferences/. The reason is the proxy.pac file needs to be in "TWO" places. The first one is in /var/preferences and the next one is in /private/var/root. If both of your proxy.pac files are setup like this:

    function FindProxyForURL(url, host)
    {
    if ((isInNet(myIpAddress(), "25.0.0.0", "255.0.0.0")) || (isInNet(myIpAddress(), "10.0.0.0", "255.0.0.0")))
    return "PROXY 216.155.165.50:8080";
    else
    return "DIRECT";
    }

    like the other user said, than you should be browsing the internet once again. Hit me up if you need any additional help.
    i made sure BOTH were edited the same, rebooted, and then tried the stocks app. was patient for about a minute, then data started flowing. checked weather, maps, safari all after that and all worked fine. hope that works for you.

  4. #4
    Green Apple BearZ's Avatar
    Join Date
    Nov 2007
    Location
    Houston, TX
    Posts
    43
    Thanks
    2
    Thanked 4 Times in 4 Posts

    set your phone on My Tmobile to Moto Razr...that seemed to have done it for me



  5. #5
    I'm still getting the same error. Just to make sure that i'm not doing anything wrong, i'm only editing the proxy.pac file via wordpad or notepad then transfer it to my iphone via ibrickr. I think this is the simplest way to do it since i'm also not familiar with the ssh thing and winscp. Here is my encoding from preference.plist, i downloaded this from here (http://www.modmyi.com/forums/t-mobil...x-1-1-4-a.html) Let me know i'f there is anything wrong with it. Any help will be greatly appreciated. By the way, preference.plist file is installed in these locations

    (preferences.plist)
    library/preferences/systemconfiguration
    var/preferences/systemconfiguration
    private/var/preferences/systemconfiguration

    (edited) Sorry for the lost list of preferences.plist that kind of flooded the forum.
    Last edited by mikeyiphone; 2008-09-03 at 03:22 PM. Reason: Automerged Doublepost

  6. #6
    Default still no internet
    i edited the proxy.pac file in 2 places like stated. still having the same problem as mikey in post #2. what could be the problem?

  7. #7
    Quote Originally Posted by allbuss View Post
    i edited the proxy.pac file in 2 places like stated. still having the same problem as mikey in post #2. what could be the problem?
    Make sure the file actually did get updated. If you uploaded a modified version of the proxy.pac file, then look at the byte count to make sure it is actually the modified version Or just download the file from your iPhone and check it to make sure it has been modified. Also, make sure you are using a pure text editor like TextWrangler on the MAC.


    Allan

  8. #8
    Default 2nd proxy.pac not located in /private/var/root directory
    I cannot find the 2nd proxy.pac in /private/var/root directory. Is this the right location of this file?
    Since, I wasn't able the find the second proxy.pac, I decided to copy/paste the proxy.pac from "/var/preferences" to "/private/var/root". Essentially, I had both proxy.pac in both locations. Next I saved the settings, reset iphone network settings, and re-applied the APN...and still the Tzones failed. Any ideas why my Tzones is not working?



    updated both proxy.pac to:

    function FindProxyForURL(url, host)
    {
    if ((isInNet(myIpAddress(), "25.0.0.0", "255.0.0.0")) || (isInNet(myIpAddress(), "10.0.0.0", "255.0.0.0")))
    return "PROXY 216.155.165.50:8080";
    else
    return "DIRECT";
    }

  9. #9
    Quote Originally Posted by rnguyen77 View Post
    ..and still the Tzones failed. Any ideas why my Tzones is not working?

    When you are only using the EDGE (no WIFI access), do you get an IP address (dial *3001#12345#*) and does it start with 10.x.x.x or 25.x.x.x?

  10. #10
    iPhone? More like MyPhone
    Join Date
    Jul 2008
    Location
    right in the middle of the US
    Posts
    140
    Thanks
    4
    Thanked 7 Times in 5 Posts

    i ran whatip with my wifi connect turned off and got pdp_ip0: 25.x.x.x

    this is without running the new tzones hack.

    no edge access though.

    on the gf's phone without tzones, it returns no network found which makes sense.

  11. #11
    (UPDATED)

    I deleted proxy.pac and preference list from their corresponding locations and installed tmobile zones hack 1.1.4 (bigboss) from the installer and guess what happened...It now works. As what had been mentioned from other forums, tmobile was having some major technical problems on their servers and network for the last 3 weeks. I'll be willing to help. Just post your questions

  12. #12
    Default back up and running
    i too followed the instructions from the first post... and the internet went out completely. but i was already having trouble with the "HTTP ERROR: $CODES$ $MESSAGE$ Request URI=/" error.

    so i followed the instructions from this thread...

    i replaced the proxy.pac content with

    function FindProxyForURL(url, host)
    {
    if ((isInNet(myIpAddress(), "25.0.0.0", "255.0.0.0")) || (isInNet(myIpAddress(), "10.0.0.0", "255.0.0.0")))
    return "PROXY 216.155.165.50:8080";
    else
    return "DIRECT";
    }

    and SSH'ed the proxy.pac to two locations. it was already in the /var/preferences/ folder, so it replaced the old one and i simply added it to the /private/var/root folder.

    everything is up and running perfectly now.

    FYI a few months back i installed the 1.1.4 hack from big boss.

    ira

  13. #13
    My iPhone is a Part of Me
    Join Date
    Nov 2007
    Location
    Los Angeles
    Posts
    805
    Thanks
    414
    Thanked 107 Times in 79 Posts

    good job, i have been looking everywhere for this info. this is what the proxy.pac file looks like on a 2.0+ phone.
    i had 2.0+ and noticed but didn't save it.
    back on 1.1.4 and wanted to know how to add it instead of change it.
    awesome.

    also change your apn from wap.voicestream.com to epc.tmobile.com

    i was pullin 603kbs on edge in the walmart parking lot.
    DAMN!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •