Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: HORRIBLE T-MOBILE Signal on iphone 2g HELP

  1. #1
    Default HORRIBLE T-MOBILE Signal on iphone 2g HELP
    Anyone have any insight into this. A buddy of mine had an unlocked iphone 2g for tmobile and had great signal all the time. My phone after unlocking it has up and down signal all he time. somtimes it goes at far as saying no service or loss of cellular network.

    this is so very frustrating...

  2. #2
    Yeah when I switched to my iphone my signal also dropped. My blackberry got much better reception. I think its something you are going to have to just live with....i know it sucks ***. good luck man

  3. #3
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    My signal dropped a little bit but not much, I think they will fix that issue in 2.1

  4. #4
    Default I feel your pain
    I posted the same question. Before I got my iPhone last friday I was using the CECT P168C (iphone "clone") and I had great signal strength. Now I am using the "best phone" out there and when I am indoors my reception is poor. I hope something can be done. I wish us both luck with this issue!

  5. #5
    My iPhone is a Part of Me nycdiplomat's Avatar
    Join Date
    Nov 2007
    Location
    The big apple
    Posts
    573
    Thanks
    51
    Thanked 53 Times in 37 Posts

    yea i noticed the same thing and im having the same problems....sometimes im almost tempted to do a restore because sometimes i have no service but i see other ppl are having the same problems
    waiting on my iPhone 6+

  6. #6
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    Yeah, The only problem i have is when im in my basement, Otherwise it works fine

  7. #7
    What's Jailbreak?
    Join Date
    Jul 2008
    Location
    Oregon
    Posts
    23
    Thanks
    2
    Thanked 2 Times in 2 Posts

    Hey guys its not the phones fault! Haha its the unlocked 2.0.0 If you downgrade to 1.1.4 you'll find that the service is better than any phone out there. For some reason with the unlocked 2.0 firmware it causes it to lose service. Hopefully dev team will fix this with their update. Check this out for more info:

    http://www.modmyi.com/forums/t-mobil...e-service.html

  8. #8
    My iPhone is a Part of Me
    Join Date
    Jul 2008
    Location
    Minnesota
    Posts
    732
    Thanks
    12
    Thanked 27 Times in 25 Posts

    I hear with 2.0.1 you get better service, Not sure if its true but will find out soon

  9. #9
    Default Awesome
    Thanks for the feedback everyone. helps knowing im not the only one. Im hoping 2.0.1 will help once it is dealt with. I know it came out today. But yea i get pretty poor signal when im in doors but it seems when im outside driving to work or just outside in general the reception is much better.
    weird stuff.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •