Quote Originally Posted by wellcome2phily View Post
This is really upsetting me! I want my internet to work.. I have 1.1.2 unlocked 4gb iPhone.. I had a 1.0.2 phone, and my internet all of the sudden stopped working.. This is why I upgraded.. I thought it would fix it. But i still get the "Error 502 - Bad Request....." I forgot what else.. but yea I still get that.. And its getting annoying cause i want my internet to work. My internet used to work with wap.voicestream.com, im under the 19.99 plan. Ive tried internet2 and internet3.. any hep?
Do a little bit of basic troubleshooting here. Do you have a t-mobile branded phone that you can test your SIM in to make sure that the internet access is actually working? Can you use a friends Dash, Wing, Shadow, MDA, SDA, etc.? Not blackberry, BB requires a different net feature.

This will at least let you know whether or not your net access is working from t-mobile. And if you don't test it in a t-mobile phone, there's nothing they can really do for you.