Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Classicbadge properties not consistently applied!!!! PLEASE HELP!!!

  1. #1
    Default Classicbadge properties not consistently applied!!!! PLEASE HELP!!!
    I'm fairly desperate!! I have Classicbadge installed and I have created a custom SB badge and I've edited my info.plist with the following:

    <dict>
    <key>BadgeStyle</key>
    <string>padding-bottom: 3px;font-family: Helvetica;font-weight: bold;font-size: 12px;color:rgba(255,255,255,1);text-shadow:rgba(0,0,0,1) 0px 1px 0px;</string>
    </dict>

    This for 2 reasons:
    1.) To centre the number within the notification badge
    2.) To give the number a shadow and therefore depth

    My issue is the parameters laid out in the plist don't consistently apply to the notifications number. It's completely random changing all the time from properly themed to some or other default (I assume one laid on within the Classicbadge app itself).

    Cannot begin to tell you how frustrating it is!!

    If anyone has some suggestions I would really appreciate them.

    TIA

    See image, Tapatalk is how I intended the number to appear and Gmail shows the style it reverts to.


    Last edited by sand_man; 2014-11-02 at 12:02 PM.

  2. #2

  3. #3
    I've mailed the developer! There has to be a simple explanation for why this is happening. Perhaps there is an info.plist located in the Classicbadges folder that overrides the custom one located in the Winterboard themes folder...

    But a solution has to be found!!! It's like a rattle in the dashboard of your new car! It's a small thing but it cheapens the ride!!

  4. The Following User Says Thank You to sand_man For This Useful Post:

    .:JimmyL:. (2014-11-02)

  5. #4
    In the info.plist I've removed 'font-family: Helvetica;'

    I'm trying to tie in Bytafont/2 with issue but either way not specifying font-family seems to work.

    @.:JimmyL:. let me know if this correlates with your own experience...

  6. #5
    Or not. Frustratingly the issue continues although not as frequently as before.

    Any feedback, advice and/or opinions would be greatly appreciated...

  7. #6

  8. #7
    Okay, let me ask this?

    1.) Is there an info.plist anywhere in iOS 8's system files that dictates where the notification number stands on the homescreen?
    2.) Where would the Classicbadges application reside within the iOS 8 directory?

    I suspected Icon0matic and/or Bytafont2 may be causing the issue but uninstalling both apps does not fully resolve the issue.

    I've amended the info.plist located in the applied theme's folder to mirror the properties I want from my badge but that not fully resolve the issue either.

  9. #8

  10. #9
    Etch A Sketch Sk37cH's Avatar
    Join Date
    May 2011
    Location
    Oz maaaaaate ;)
    Posts
    2,533
    Thanks
    6,115
    Thanked 10,215 Times in 2,246 Posts

    This issue was so widespread I actually repositioned about 50 badge images just to have an option for no plist. It happened to me occasionally, and more frequent with others. In the end, I also use the modified images without a plist. With fonts, you'll never keep everyone happy (from a theme developer point of view).

    Sorry I can't be of any more help, but I've lost many hours on this issue already. Cheers.

  11. #10
    Quote Originally Posted by Sk37cH View Post
    This issue was so widespread I actually repositioned about 50 badge images just to have an option for no plist. It happened to me occasionally, and more frequent with others. In the end, I also use the modified images without a plist. With fonts, you'll never keep everyone happy (from a theme developer point of view).

    Sorry I can't be of any more help, but I've lost many hours on this issue already. Cheers.
    Thanks for that!! Never realized this was a common issue!

    The positioning of the badge is an easy fix. Applying a shadow and changing the default size of the number is sadly hit and miss, not that there is anything wrong with the code, just that sometimes it works and sometimes not!

  12. #11
    Will this is really all I can do with the notification badges! Pity, it's amazing what a difference resizing and applying a shadow makes to the notification badge! I really hope this is sorted in a Winterboard update, although I'm not holding my breath.

    I wasn't really expecting a response from the developer re my issue but disappointed, none the less, at the lack of any sort of acknowledgement.


  13. #12
    Coolstar has updated Classicbadges!!

    The ability to manipulate the badge number and consistently apply the changes now appears to be a done deal!! Not sure about the shadow though. Still a work in progress I believe...

    Last edited by sand_man; 2014-11-25 at 07:49 PM.

  14. #13
    Well, for those of you like me who absolutely love the ability to add a shadow to the notification badge digit, it's now doable again and applies with the consistency one would expect. Anemone dependent of course...




Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •