Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: cannot get icon to change

  1. #1
    Default cannot get icon to change
    I cannot get 1 App Store icon to change, the bundle identifier says: Q5AWL8WCY6.iMapMyRidePlus, but the icon still won't change.

  2. #2
    If I had a nickel... thazsar's Avatar
    Join Date
    Jan 2010
    Location
    Dallas, TX
    Posts
    5,693
    Thanks
    1,594
    Thanked 5,057 Times in 2,011 Posts

    Quote Originally Posted by minion1836 View Post
    I cannot get 1 App Store icon to change, the bundle identifier says: Q5AWL8WCY6.iMapMyRidePlus, but the icon still won't change.
    If you have iFile, do this for us...
    - if you haven't already done so...
    --touch the Settings icon (bottom left)
    --select File Manager
    --turn on Application Names

    Now,
    - press the Home icon (aka /var/mobile)
    - open Applications
    - open iMapMyiRidePlus
    - open the iMapMyRide.app folder (not sure exactly what it's called
    - scroll down to Info.plist and open it using Property List Viewer
    - put your device in landscape mode and take a picture of the file contents

    Send us the screenshots and we can tell you the correct Bundle ID

  3. #3

  4. #4
    What's Jailbreak?
    Join Date
    Oct 2013
    Posts
    9
    Thanks
    0
    Thanked 3 Times in 1 Post
    Have you tryed Ifunbox?

  5. #5
    Quote Originally Posted by Kerimo666 View Post
    Have you tryed Ifunbox?
    I use cyberduck

  6. #6
    If I had a nickel... thazsar's Avatar
    Join Date
    Jan 2010
    Location
    Dallas, TX
    Posts
    5,693
    Thanks
    1,594
    Thanked 5,057 Times in 2,011 Posts

    Default cannot get icon to change
    I figured it out! Granted...I accidentally bought the app to do so! LOL!

    *40x40 is what worked on my ip5S. You'll need to create a non-retina image for the 29x29, as well

    Name your icons this:


  7. #7
    I have these in my theme folder:



    there are 2 different apps: mapmyride & mapmyride+, I have the + version (sorry for not saying which one I am using).
    Last edited by minion1836; 2014-06-30 at 02:57 PM.

  8. #8
    If I had a nickel... thazsar's Avatar
    Join Date
    Jan 2010
    Location
    Dallas, TX
    Posts
    5,693
    Thanks
    1,594
    Thanked 5,057 Times in 2,011 Posts

    Quote Originally Posted by minion1836 View Post
    I have these in my theme folder:



    there are 2 different apps: mapmyride & mapmyride+, I have the + version (sorry for not saying which one I am using).
    My bad, I thought I accidentally bought the 'plus' version. I got the Free one (thank goodness).

    Are there not
    'MapMyRide App [email protected]' icons
    in the Plus version?

  9. #9
    Quote Originally Posted by thazsar View Post
    My bad, I thought I accidentally bought the 'plus' version. I got the Free one (thank goodness).

    Are there not
    'MapMyRide App [email protected]' icons
    in the Plus version?
    no, I already have named them that.

    these are all the app icon names:
    AppIcon29x29.png
    [email protected]
    AppIcon40x40.png
    [email protected]
    AppIcon57x57.png
    [email protected]
    AppIcon60x60.png
    [email protected]
    AppIcon76x76.png
    [email protected]
    Last edited by minion1836; 2014-06-30 at 08:14 PM.

  10. #10
    If I had a nickel... thazsar's Avatar
    Join Date
    Jan 2010
    Location
    Dallas, TX
    Posts
    5,693
    Thanks
    1,594
    Thanked 5,057 Times in 2,011 Posts

    I understand BUT you need to use the exact names I have in that screenshot.

    Theming:
    '[email protected]'
    doesn't work

    They need to be labelled:
    'MapMyRide App [email protected]'

  11. #11
    i renamed the icons to "MapMyRide App [email protected]" and still nothing, I deleted and redownloaded the app.
    when I go to the app, I find icons that are label "[email protected]" & "AppIcon29x29.png", there are 10 total icons.

    when you do open the info.plist you do see "MapMyRide App [email protected]", but not in the app.

    Problem solved.

    You both sets of icons in order for it to work, these are the names.

    AppIcon29x29.png
    [email protected]
    AppIcon40x40.png
    [email protected]
    AppIcon57x57.png
    [email protected]
    AppIcon60x60.png
    [email protected]
    AppIcon76x76.png
    [email protected]
    MapMyRidePlus App Icons29x29.png
    MapMyRidePlus App [email protected]
    MapMyRidePlus App [email protected]
    MapMyRidePlus App Icons57x57.png
    MapMyRidePlus App [email protected]
    MapMyRidePlus App [email protected]

    Thanks for the help.
    Last edited by minion1836; 2014-07-01 at 03:09 AM.

  12. #12
    If I had a nickel... thazsar's Avatar
    Join Date
    Jan 2010
    Location
    Dallas, TX
    Posts
    5,693
    Thanks
    1,594
    Thanked 5,057 Times in 2,011 Posts

    Default cannot get icon to change
    To humor me, could you remove all the icons except the 'MapMyRidePlus...40x40..' Icon and see if you still see your custom icon?

    This was the specific icon that worked for me when I made that post about the MapMyRide icons. It looks like you needed 'Plus' at the end, though. I even removed all the others and my icon was still themed using the MMR 40x40 one! Just curious if you'll get the same results...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •