Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Themes Won't Show in SMB; Tried Everything!

  1. #1
    Default Themes Won't Show in SMB; Tried Everything!
    Hello all,

    I have 1.1.3 BL 4.6 unlocked using ZiPhone. None of the themes I download or copy to /var/root/Library/Summberboard/Themes show up in SMB. I tried both fixes (separately and together) that I found in Installer/Tweaks 1.1.3. I've already uninstalled, restarted, installed, restarted. I don't know what else to do. I'm using OS X Leopard. Please help. Thanks.

  2. #2
    Livin the iPhone Life nickh's Avatar
    Join Date
    Sep 2007
    Melbourne, Australia
    Thanked 148 Times in 118 Posts

    I had same problem, ended up SSH ing them on to phone no probs what so ever.

  3. #3
    I already tried SSHing the themes to the phone, but they still won't appear.

  4. #4
    iPhone? More like MyPhone
    Join Date
    Mar 2008
    Not too far from Mr. Miyagi's place
    Thanked 21 Times in 17 Posts

    Newer versions of SummerBoard use the mobile user for storage.

    Copy all the themes you have in root to mobile:

    cp -Rp /private/var/root/Library/SummerBoard/Themes/* /private/var/mobile/Library/SummerBoard/Themes/

    (the above is one command, there's a space between the * and the /)

    Make sure you have Default and the other stock ones.

    Then we'll remove the old stuff, symlink root's SummerBoard stuff as well as /private/var:

    rm -rf /private/var/root/Library/SummerBoard
    rm -rf /private/var/Library/SummerBoard
    ln -s /private/var/mobile/Library/SummerBoard /private/var/root/Library/SummerBoard
    ln -s /private/var/mobile/Library /private/var/Library
    ln -s /private/var/mobile/Media /privcate/var/Media

    And finally, make sure permissions and ownership is happy in the newer location:

    chown -R root:mobile /private/var/mobile/Library/SummerBoard
    chmod -R 0755 /private/var/mobile/Library/SummerBoard

    You shouldn't have to bother with with again, hopefully. The other symlinks are a catch for applications using old (and possibly now unused) paths.
    Last edited by kcrmson; 2008-03-19 at 08:26 PM. Reason: Couple lines wrapped funny
    I came, I saw, I forgot what the hell I was there for.

  5. The Following 3 Users Say Thank You to kcrmson For This Useful Post:

    DARKoo7 (2008-04-16), iceman_007 (2008-03-20), MJedi (2008-03-20)

  6. #5
    It worked! Your steps should be included in the guide or FAQ. Thank you very much.

  7. #6
    Thanks for the info. It works now, your help is much appreciated.

  8. #7
    I have an issue with the Summerboard theme I got from Installer (Leopard 10.5.1). None of the elements get applied. Another theme, aglitchTheme (from this site), that I ssh'ed to the correct location does not get applied either. I have other themes that I ssh'ed and some themes from Installer that do work. Does the theme need to be 1.1.3-compatible to work? Thanks.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts