Results 1 to 18 of 18

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: please need help with two app icon names wont change in winterboard

  1. #1
    iPhoneaholic richhee's Avatar
    Join Date
    Feb 2008
    Location
    lynn ma usa
    Posts
    348
    Thanks
    62
    Thanked 102 Times in 83 Posts

    Default please need help with two app icon names wont change in winterboard
    i created a theme and everything works perfect except 2 app icons wont change 1 is crazy dummy the other is quit it i named them exactly as seen on springboard and tried 10 diff names i checked the wiki nothing works please help have been tring for a week

  2. #2
    You may have to SSH into the phone and find the app folder, and double check the name.

    But if its not changing the image isnt named properly.

  3. #3
    I had a problem like this. Then I noticed when saving files from Photoshop it would change a title like this "Toy Bot" to "Toy_Bot" so it wasn't working.

  4. The Following User Says Thank You to Kariodude For This Useful Post:

    richhee (2009-08-23)

  5. #4
    Default App Icon Name
    This may sound like a lot of work but if you install the Erica utilities which includes plutil you can then view the Info.plist file in each application folder. The Applications display name is what the icon needs to be named. This application is named 400 Sounds Lite, but the application folder name is that long number, then in to the iMakeSounds3Lite.app folder you view the Info.plist file.

    So my icon has to be named 400 Sounds 2.png

    /var/mobile/Applications/88BF69D8-E4FF-49E6-9D5D-5C8D9D171CCC/iMakeSounds3Lite.app root# plutil Info.plist
    {
    CFBundleDevelopmentRegion = English;
    CFBundleDisplayName = "400 Sounds 2";
    CFBundleExecutable = iMakeSounds3Lite;
    CFBundleIconFile = "Icon.png";
    CFBundleIdentifier = "com.jlcmobile.iMakeSounds3Lite";
    CFBundleInfoDictionaryVersion = "6.0";
    CFBundleName = iMakeSounds3Lite;
    CFBundlePackageType = APPL;
    CFBundleResourceSpecification = "ResourceRules.plist";
    CFBundleSignature = "????";

    If you do a ls */ from the /var/mobile/Applications folder it will list all of the subfolders and you can determine which of those long numbered folders has your app in it.

  6. #5
    iPhoneaholic richhee's Avatar
    Join Date
    Feb 2008
    Location
    lynn ma usa
    Posts
    348
    Thanks
    62
    Thanked 102 Times in 83 Posts

    Default thanks for help
    well thank you everyone for trying to help photoshop is not renaming so thats not the problem and i just tried the other suggestion i sshed foud the the app checked the info.plist checked cfbundle name renamed icon to match and it still didn't work please any other suggestions im going crazy
    Last edited by richhee; 2009-08-20 at 12:31 AM. Reason: Automerged Doublepost

  7. #6
    My iPhone is a Part of Me Chefanim's Avatar
    Join Date
    Jul 2008
    Location
    Panama City, FL
    Posts
    894
    Thanks
    42
    Thanked 153 Times in 132 Posts

    Just replace the Icon.png file in the folder of the app you are trying to change
    So long, and thanks for all the fish

  8. #7
    iPhoneaholic richhee's Avatar
    Join Date
    Feb 2008
    Location
    lynn ma usa
    Posts
    348
    Thanks
    62
    Thanked 102 Times in 83 Posts

    Default thanks
    i know i could do that and tried but did not work plus i would prefer winterboard to do it

  9. #8
    Quote Originally Posted by richhee View Post
    i know i could do that and tried but did not work
    OK, if changing the icon inside the .app folder didn't work, then nothing will ever work. I'm pretty sure it's impossible for that not to have worked.

  10. #9
    iPhoneaholic richhee's Avatar
    Join Date
    Feb 2008
    Location
    lynn ma usa
    Posts
    348
    Thanks
    62
    Thanked 102 Times in 83 Posts

    Default please help then
    ok well heres what im doing i ssh into my phone go to var/mobile/applications find the app and transfer the icon.png to the pc i open the png and theres nothing there i tried to replace anyway and does nothing

  11. #10
    Default App icon
    Quote Originally Posted by richhee View Post
    ok well heres what im doing i ssh into my phone go to var/mobile/applications find the app and transfer the icon.png to the pc i open the png and theres nothing there i tried to replace anyway and does nothing
    You have to run fixpng on the icon.png if you want to view it, however if you find the actual display name for the app, you can just drop your icon file you created in your theme's icon folder and not worry about messing with the icon.png in the application folder. Can you send me the Info.plist file from your applications folder and I'll check the display name for you if you don't have the plutil installed? Not sure if you can attach it to a post here or not.

    Just attach the Info.plist file to your post. You can attach both if you want and I'll view them and post back the app display name so you can get your icon names correct.
    Last edited by phatboyfromla; 2009-08-21 at 10:46 PM.

  12. #11
    iPhoneaholic richhee's Avatar
    Join Date
    Feb 2008
    Location
    lynn ma usa
    Posts
    348
    Thanks
    62
    Thanked 102 Times in 83 Posts

    Default thank you so much for your help
    thank you so much for your help it wont let me attatch so i put them in seperate folders and made a zip file and heres the link

    RapidShare: 1-CLICK Web hosting - Easy Filehosting

  13. #12
    CrazyDummy

    QuitIt!

    Have you tried these as your icon names? Drop them in to your icons folder under your theme and let me know if it works. Case sensitive also.

  14. #13
    iPhoneaholic richhee's Avatar
    Join Date
    Feb 2008
    Location
    lynn ma usa
    Posts
    348
    Thanks
    62
    Thanked 102 Times in 83 Posts

    Default yes tried
    yes i tried both those names 10 times exactly as you have them writtenand it does not work ive even restored my phone reinstalled winterboard and same thing i dont know what else to do

  15. #14
    And you're putting them in the icon folder under your theme folder and respringing? You're using WinterBoard right?
    Last edited by phatboyfromla; 2009-08-22 at 01:30 AM.

  16. #15
    Also make sure the permissions on the icon file are
    Attached Thumbnails Attached Thumbnails -permissions.jpg  

  17. The Following User Says Thank You to phatboyfromla For This Useful Post:

    richhee (2009-08-22)

  18. #16
    iPhoneaholic richhee's Avatar
    Join Date
    Feb 2008
    Location
    lynn ma usa
    Posts
    348
    Thanks
    62
    Thanked 102 Times in 83 Posts

    Default tried that
    i checked permissions all set right

  19. #17
    Just curious, what theme are you using?

  20. #18
    iPhoneaholic richhee's Avatar
    Join Date
    Feb 2008
    Location
    lynn ma usa
    Posts
    348
    Thanks
    62
    Thanked 102 Times in 83 Posts

    Default i made it
    i fixed it thank you everyone for your help there was a problem with the pic i just made new ones thanx
    Last edited by richhee; 2009-08-23 at 04:36 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •