Today I finally decided its time to Jailbreak my iPhone. I followed the guide and downloaded redsn0w 0.9.5b5-5 OS X. upon trying to launch redsn0w i get the following error:

"You cannot open the application "redsn0w" because it is not supported on this architecture"

I understand this error usually means Intel-based Macs only. But I am happily running a Mac G5 and have no plans on upgrading in the near future.

Is there an alternative solution?


Thanks,
John