Page 1 of 2 12 LastLast
Results 1 to 20 of 28

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Stuck in Safe Mode (iOS4)

  1. #1
    Default Stuck in Safe Mode (iOS4)
    I just jailbreaked my iPhone 3g with redsnow for iOS4! Everything worked out perfect! Then I went into cydia and installed some stuff, like sbsettings which doesnt work. then i made an update (i believe it was mobile substrate). now after soft reloading i am stuck in safe mode! i wanted to delete mobile substrate but i cant find it under packages... any solutions?? :/

    Thanks!

  2. #2
    Retired Moderator Cer0's Avatar
    Join Date
    Apr 2008
    Location
    MN/WI
    Posts
    14,099
    Thanks
    395
    Thanked 1,182 Times in 915 Posts

    Right now a lot of the apps are not updated for the new 4.0. They seem to be causing a lot of problems at the moment. I think the only thing to do at the moment would be restore and wait to hear if it has been updated.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]

  3. The Following User Says Thank You to Cer0 For This Useful Post:

    AlexCrammer (2010-06-26)

  4. #3
    Thanks for your answer.. I might as well just leave it on iOS4 and wait for an update! Since I can still use everything that I need to use

    I also just found out I am not the only one with this problem:
    Saurik Updates Cydia And MobileSubstrate For iOS 4 | FSMdotCOM

  5. #4
    D'oh! I forgot to check to see if Five-Column Springboard was compatible. Now even after uninstalling I'm still stuck in safe mode. I hope there's a fix for this...

  6. The Following User Says Thank You to KevinDooley For This Useful Post:

    Bigjohn0812 (2010-06-24)

  7. #5
    Likewise - I'm not sure if it has a real affect other than being annoying.

  8. #6
    What's Jailbreak? EP1808's Avatar
    Join Date
    Jun 2010
    Location
    Ohio
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 1 Post
    There is a program called Icon Support. It gets installed with 5 Icon. 5 Icon must be uninstalled along with Icon Support. They wont work without each other. Best bet is to uninstall and wait for the ios4 update

  9. The Following 2 Users Say Thank You to EP1808 For This Useful Post:

    hashiriya (2010-06-23), m.catamount (2010-06-23)

  10. #7
    Green Apple
    Join Date
    May 2008
    Location
    Scottsdale, AZ
    Posts
    89
    Thanks
    6
    Thanked 15 Times in 13 Posts

    Mobile Substrate won't show up in packages unless you tell Cydia you are a developer: in Manage->Settings select "Developer (No Filters)". Just be happy Cydia works at all for you, because it doesn't for me...

  11. The Following User Says Thank You to Puka1701 For This Useful Post:

    Mr.hack (2010-11-09)

  12. #8
    Quote Originally Posted by EP1808 View Post
    There is a program called Icon Support. It gets installed with 5 Icon. 5 Icon must be uninstalled along with Icon Support. They wont work without each other. Best bet is to uninstall and wait for the ios4 update
    I had the same issue with the constant safe mode, deleted icon support and it fixed it, thanks!

  13. #9
    @EP1808
    Icon support was the culprit for me too.
    Good call.
    Thanks.

  14. #10
    I had to delete MyWi and then everything worked fine.

  15. #11
    MobileSubstrate just got updated today to work with iOS 4. Go into Cydia and check for an upgrade on it, or if there is not upgrade available, uninstall it and reboot. Then install it again through Cydia.

  16. #12
    Quote Originally Posted by AlexCrammer View Post
    MobileSubstrate just got updated today to work with iOS 4. Go into Cydia and check for an upgrade on it, or if there is not upgrade available, uninstall it and reboot. Then install it again through Cydia.
    thanks for the help, but for some reason i dont even have mobilesubstrate installed. And i cant find it when i search!any ideas?this safe mode thing is really annoying me now.

    ok my bad i actually do have it installed and its the latest version but im still stuck in safe mode. if anyone can help it would be much appreciated!

    ok i think iv solved this.
    1.uninstall mobile substrate (if you cant see it go to cydia>manage>settings and set to developer)
    2.reinstall mobile substrate

    and that should do the trick
    Last edited by lethalk; 2010-06-26 at 12:03 PM. Reason: Automerged Doublepost

  17. The Following User Says Thank You to lethalk For This Useful Post:

    Einstein3000 (2010-06-30)

  18. #13
    Is there a trick to removing the 5 column springboard? I've removed mobile subtrate but as soon as I reinstall it I go straight back to safe mode. Every time I try remove 5 column springboard it gives me an error and won't do it.

  19. #14
    Mattsmum, try seeing if you have the package "IconSupport" installed. this may be the culprit. uninstall it if it is.

  20. #15
    No don't have icon support. I need to get rid of this 5 column springboard.

    Ok found a solution some people have installed the app Rock and Uninstalled it and that worked. That didn't work for me so installed the app RubyGems which will force remove packages. Problem gone and no more safemode!
    Last edited by Mattsmum; 2010-06-27 at 03:21 PM. Reason: Automerged Doublepost

  21. #16
    I thinkI figured out what the problem was:
    Lockdown
    MewSeek

    Those 2 programs make it stuck in safe mode!

    Edit: i think a lot of programs/extensions that r not supported yet crash the SB.. so always install stuff and respring to see if it has any effects.. if not just leave it and u will be good! otherwise remove it instantly! The removing part didnt work for me with the 2 programs that i mentioned above... i had to restore :/
    Last edited by Marv1993; 2010-06-28 at 02:08 AM.

  22. #17
    after removing all said programs I still had the problem however I uninstalled IBlacklist and now everything is working again

  23. #18
    iPhone? More like MyPhone rorencia's Avatar
    Join Date
    Nov 2008
    Location
    Utah
    Posts
    211
    Thanks
    364
    Thanked 166 Times in 111 Posts

    Quote Originally Posted by AlexCrammer View Post
    MobileSubstrate just got updated today to work with iOS 4. Go into Cydia and check for an upgrade on it, or if there is not upgrade available, uninstall it and reboot. Then install it again through Cydia.
    The above solution worked. Thanks.

  24. #19
    StatusNotifier was the culprit in my case, finally got out of the dreaded safe mode. I even re-installed Winterboard with no issues so far. Now I will go home and do the new redsnow to activate the MMS. Now all we need is for developers to catch up to iOS 4.0 and make all the cydia software compatible.

    Quote Originally Posted by Marv1993 View Post
    I thinkI figured out what the problem was:
    Lockdown
    MewSeek

    Those 2 programs make it stuck in safe mode!

    Edit: i think a lot of programs/extensions that r not supported yet crash the SB.. so always install stuff and respring to see if it has any effects.. if not just leave it and u will be good! otherwise remove it instantly! The removing part didnt work for me with the 2 programs that i mentioned above... i had to restore :/
    mewseek isn't causing the problem for me, but it keeps crashing after loading it up.
    Last edited by bluenautica; 2010-06-30 at 05:11 AM. Reason: Automerged Doublepost

  25. #20
    Thanks Lethalk your soilution worked major props
    Theming, A New Friendship??

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •