Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: NO SERVICE after redsn0w jailbreak on 2G iPhone

  1. #1
    Default NO SERVICE after redsn0w jailbreak on 2G iPhone
    I was able to jailbreak this iphone 2G using Redsn0w and everything went well but now I have no phone service on AT&T. Everything else works. I do not wish to activate this iphone using iTunes because I don't want to register it with AT&T. But I do want a working phone. Is there any way around this?
    "Travel light, live light, spread the light, be the light"

  2. #2
    Are you using an ATT goPhone sim card? B/c I had the same exact problem. (after I JB/UL my iPhone 2G) Interestingly, the Tmobile prepaid sim card worked, but I liked the ATT one better b/c I could log in at Sbux and get wifi access as an ATT customer.

    If you are a regular ATT customer, I"m not sure what to tell you. You said you JB the phone, but did you unlock it as well? If not, that may be the answer....

  3. #3
    Yeah, it's an ATT sim card. And I did unlock the phone. But I think I just figured out what the problem is. This iphone is on 3.1.3 firmware. I have another jailbroken iphone on 3.1.2 and it works great. I have a data block on my ATT account so I don't ever receive data on my iphone. So they don't charge me for a data plan. I'm sort of flying under the radar here, but they can't really charge me for a data plan when I don't use any data. But I did come in the back door so I don't want to register my iphone with ATT.

    So I think I need to get the 3.1.3 firmware off my phone and install the earlier version. Is this easy to do?
    "Travel light, live light, spread the light, be the light"

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •