Results 1 to 18 of 18

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: OMG Help!!!!!

  1. #1
    Default OMG Help!!!!!
    OH man I'm so screwed... I really need some help.

    I had a perfectly fine jailbroken 1.1.4 iPhone 2G. I heard that iNethack was available in the AppStore now, so I wanted to upgrade to get it.

    Big mistake.

    I used redsn0w 0.7.2... Got stuck on the Downloading Jailbreak Data... screen on my iPhone. Rebooted the phone, and got the connect to iTunes screen. iTunes can't restore.

    So, I tried redsn0w 0.8... Got stuck on the same screen. What am I doing wrong? How can I get the phone back to normal. Even not jailbroken is better than a brick.

  2. #2
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    You need to restore in DFU mode then use redsn0w again

  3. #3
    I can't restore in iTunes error 1604. What do I do? I need some real help here... I have no phone, and the phone won't reboot. I can't restore. What do I do?
    Last edited by RedBandit; 2009-08-24 at 01:35 AM.

  4. #4
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    Did you try DFU Mode? How to DFU

  5. #5
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    You didn't listen to SB and put your phone into DFU mode first.

  6. #6
    Yes I've tried DFU mode. I still get Unknown Error 1604.

    When the iPhone boots, it shows the USB cable and iTunes icon. After plugging the iPhone in, I get the error 1604.

  7. #7
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    If you are in DFU then you would not have the USB cable screen, the screen would just be black.

  8. #8
    Ok... I keep getting a message telling me iTunes needs to check the iPod software update server to identify this device. Am I doing it wrong?

    Also, should the phone be off or on before Step 1 on the iClarified page?

    I've gotten iTunes to attempt a restore with the iPhone screen all black. Still getting unknown error 1604. ANY ideas or feedback or anything would be appreciated. I'm screwed without a phone!! Help please!!
    Last edited by RedBandit; 2009-08-24 at 02:37 AM. Reason: Automerged Doublepost

  9. #9
    Forum Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    DFU mode
    INSTRUCTIONS
    Step 1. Turn off iPhone
    Step 2. Hold down the power and home button.
    Step 3. When you see the Apple logo, release the power button but continue holding the home button down.
    Step 4. Open iTunes and wait for it to tell you that it detects iPhone in restore/recovery mode.

    Alternative Method:
    Step 1. Connect iPhone to USB then listen to the sound when it connects and disconnects.
    Step 2. Hold the home and power buttons until hear the disconnect sound then release power button.
    Step 3. Wait until you hear another sound then release home button

  10. The Following User Says Thank You to Bo Troxell For This Useful Post:

    RedBandit (2009-09-06)

  11. #10
    I've been trying this for hours and hours and hours... I've seen 20 YouTube videos, dozens of forum posts... I don't know what to do. It's so late, I need a phone. When I follow the instructions here, the iPhone screen goes all black. iTunes asks me to check the iPod software update server to identify this device. There's no choice but to click check. If I click Restore, the iPhone screen goes all white, then back to all black, then shows the Apple logo. Nothing happens for a while and I get error 1604.
    Following the same steps again, but this time shift-clicking Restore, does almost the same thing, but instead brings up the Apple logo with a progress bar that fills up halfway before giving me error 20. What am I doing wrong?

  12. #11
    what did you use to initally jailbreak your iphone? thats my first question.

    also DFU mode should be done without even being plugged into your computer. then you plug it in once it tells you to connect to itunes or has a custom logo for dfu mode (some have steve jobs)

    you can download the official 3.0 firmware file here just in case you have a bad one.make sure you choose to save the file and not to open it with iTunes

    http://appldnld.apple.com.edgesuite....1_Restore.ipsw

    then if your going to connect make sure itunes is updated to the latest version. then plug your phone in and itunes will say it has detected an iphone in recovery mode and needs to be restored. then shift restore and select the ipsw i gave you the link for. Then just let it do its thing

    let me know what happens with that
    The beatings will continue until morale improves.

  13. #12
    When the iPhone was 1.1.4, I used winPwn.

    This time around, I used redsn0w 0.7.2. When that failed, I used redsn0w 0.8.

    I've tried DFU restoring into firmwares 1.1.4 (didn't even start), 3.0.0 (got half-way on progress bar, then failed Error 1604), and 3.0.1 (got maybe 90% done on progress bar! then failed Error 10).

    I've deleted the iTunes Library xml. Tried installing iTunes as a new user. I've also tried non-DFU restoring into firmwares 1.1.4 (didn't even start), 3.0.0 (got half-way on progress bar, then failed Error 20), and 3.0.1 (got maybe 75% done on progress bar, then failed Error 10).

    I'm trying your f/w now. Thanks!

    With your firmware, I get error 10. Progress bar about half-way through.
    Last edited by RedBandit; 2009-08-24 at 06:15 AM. Reason: Automerged Doublepost

  14. #13
    what version of itunes is it that your installing? is it 8.2?

    installing as a new user wouldnt fix any corruption in itunes. it still stores program files in the same place. try a full removal and reinstall of itunes. thats my best suggestion at this point
    The beatings will continue until morale improves.

  15. #14
    There is so much crap on here. When you see "Steve Jobs", this is restore not DFU.

    Here is what you need to do to put it in DFU. Plug your iPhone in. Open up iTunes. Now turn off your phone. When the phone is off, press and hold both power and home button (Power = top and Home = bottom). Count to ten (not too fast, not too slow). Then release the power button (top one only) and keep holding the home button (bottom one) until iTunes recognizes your iPhone in recovery (at this point you can let go of the home button and you will notice that the screen is black).

    You are now in DFU. Just to make sure, ensure that you have the proper ipsw fle. There is one for the 2G, 3G and 3GS but also there are ipsw files for ipod 1G and 2G. If you try and install the wrong firmware, you can really screw up your phone.

    My suggestion is to follow this:

    Jailbreak steps:
    1- *Plug iphone in*
    2- *Let itunes upgrade it to 3.0.1
    3- *Download the 3.0 firmware (from modmyi.com)
    4- *Download the redsn0w app (from this site of Dev-Team Blog)
    5- *Run redsn0w
    6- *When prompted, pick the 3.0 file (not the 3.0.1, they are the same except for the sms fix which is now on your phone)
    7- *Pick "Cydia and unlock" in your choices
    8- *Locate the 3.9 and 4.6 bootloaders
    9- *Close your phone
    10- *Put your phone in DFU and let redsn0w jailbreak your phone. (Redsn0w gives you the steps to do it)
    11- *Let it reboot and voilą.

    If your phone gets stuck at the "waiting for reboot", simply unplug your usb cable for about 3 seconds and plug it back in. If that doesn't work, then try it again with another version of redsn0w. For some, redsn0w 0.7 and 0.72 worked but for others, it was 0.8. If you need more help, write to me [email protected]

  16. The Following User Says Thank You to satch2501 For This Useful Post:

    RedBandit (2009-09-06)

  17. #15
    regardless of the ingenious comments from some people the issue seems to be with the install of the firmware. and once your phone has reached DFU mode it restarts again and shows the connect to itunes logo which is commonly replaced by the steve jobs picture. ive only done this a million times.
    The beatings will continue until morale improves.

  18. #16
    My iPod is a Part of Me bteamer's Avatar
    Join Date
    Jun 2008
    Location
    California
    Posts
    1,686
    Thanks
    36
    Thanked 112 Times in 86 Posts

    I always DFU with my phone plugged in.
    Quote Originally Posted by bhz1 View Post
    LOL! DOesnt everyone know that only real women know how to handle a stick?
    Quote Originally Posted by ALL DAY View Post
    As long as Miguel can blow...he's straight.
    Quote Originally Posted by bhz1 View Post
    I dread that first dusting of the white stuff.
    Quote Originally Posted by blkcadi View Post
    ready for a romp buddy? ohhhhhhhhhhhhhhhhh

  19. #17
    I dunno which of these steps fixed the problem. But, I did fix it, thanks to everyone here.

    I deleted and re-installed iTunes. Then, I deleted the library files as described [ame="http://www.youtube.com/watch?v=uzeB1VfsBnU"]really poorly here[/ame].

    Still didn't work.

    So, I ran redsn0w 0.8 again... Amazingly, the iPhone was now jailbroken!

    Still didn't sync with iTunes though.

    Deleting the same library files again didn't work.

    Installing iTunes as a new user on my computer let me sync my iPhone again.

    Deleting the library files created for the new user, let me restore and sync my old iPhone without the contacts.

    Opening MS Outlook gave me a list of all of my old contacts. I was able to type them in manually.

    Using the Microsoft Camera & Scanner Wizard restored a seemingly random selection of my photos. However, the camera roll does not show previews for the restored photos. Instead, the screen shows all black when I look at the camera roll. I can scroll up and down the blackness. Wierdly, tapping a section of the blackness, shows a photo, and lets me scroll through the rest normally. However, the previews are not generated correctly.

    Everything's back to normal now! Sorry it took so long to reply... Thanks for the help!

  20. #18
    iPhone? More like MyPhone jltdhome's Avatar
    Join Date
    Oct 2007
    Location
    Corpus Christi, TX
    Posts
    101
    Thanks
    7
    Thanked 14 Times in 11 Posts

    :-) Posts like these make me smile. The answer is given like 50 times and yet they dont listen.
    Lightning from the Sky - Thunder from the Sea

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •