Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: redsn0w & legitimate activation!???

  1. #1
    Default redsn0w & legitimate activation!???
    Hiya,

    I have a legitimatly activated iPhone, does anyone know how to modify redsn0w to stop it hacktivating??

    :: If your phone is already activated normally, redsn0w wont work as you'll end up with no carrier signal, or carrier is not available. I had to use pwnage and create a 3.0 custom firmware with activation UNticked.... id prefer to be on 3.0.1 and wondered if anyone new if this was possible?

    J
    do'h

  2. The Following User Says Thank You to jtanner For This Useful Post:

    nutz (2010-11-04)

  3. #2
    If you leave the original SIM in when you run RedSn0w it won't hactivate.. It is not a problem.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  4. #3
    Quote Originally Posted by confucious View Post
    If you leave the original SIM in when you run RedSn0w it won't hactivate.. It is not a problem.
    The original sim WAS in it when i ran redsn0w!!
    do'h

  5. #4
    Then it should still be activated - what's the problem?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  6. #5
    yes, but redsn0w HACKTIVATED it - theres no option to stop redsn0w from doing it.... hence the reason ppl with legit iPhones have had problems. There's no problem anymore cause i just used pwnage and unticked the activate option. But the phone is on 3.0 ... i cant up to 3.0.1 as the hacktivation step in redsn0w inteferes with the legit activation and results in zero signal and zero carrier options. My problem is solved as such, i just wondered if anyone knew a way to stop redsn0w performing that step.

    J
    do'h

  7. #6
    I don't know what you did but if you activate in iTunes then leave the SIM in then RedSn0w does NOT hactivate.

  8. #7
    Quote Originally Posted by confucious View Post
    I don't know what you did but if you activate in iTunes then leave the SIM in then RedSn0w does NOT hactivate.
    hmm ok, may be this is where the problem lies. the 3G was 14 months old and was activated from new. My steps were:

    DFU mode,
    Restore 3.0.1
    Redsn0w

    Perhaps i shouldve done:

    DFU Mode,
    restore 3.0.1,
    Connect iTunes,
    Activate,
    Redsn0w.
    do'h

  9. #8
    A restore of any sorts wipes out activation. You need to activate or hactivate again.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  10. #9
    yes i know that

    All i can say is, this 3G had issues after using redsn0w... the same issues it would appear a good few ppl have had.... and the solution was to use pwnage, disable activation, and let the phone activate itself. For some reason, hacktivation was causing problems.

    i started hacking iPhones when they came out,the 1st 2G version i bought back in 2006 from the Apple store on 5th in NY (Wooo! )

    Then hacked it back here in the UK. And i must say ive not really come across this issue before.... but this time i did, and hacktivation was the problem. i was just curious if there was a way to force redsn0w to skip the hackitvation (assuming the norm method of ignoring it isnt working)

    J
    do'h

  11. #10
    Hactivation causes problems with Push notification.
    If a device has been activated it does not get hactivated, if it hasn't it does. RedSn0w is very simple.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  12. #11
    Quote Originally Posted by confucious View Post
    Hactivation causes problems with Push notification.
    If a device has been activated it does not get hactivated, if it hasn't it does. RedSn0w is very simple.
    Right....so, the CORRECT way then if i have a legit phone and simply want jailbreak, would be to restore... then activate through itunes BEFORE running redsn0w??

    As for push .... that brings me to my next question..... how can i check my 3GS to see if push is working correctly??
    do'h

  13. #12
    Exactly.

    And to check, not sure, get someone to message you then reply and get them to reply? Should be pretty much immediate.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  14. The Following User Says Thank You to confucious For This Useful Post:

    jtanner (2009-08-15)

  15. #13
    ok, so thats where i went wrong, i ignored the activation step so redsn0w would of Hacktivated, and this obv doesnt like the legitimate sim card. instead of pwning version 3.0, i shudda restore again to 3.0.1, THEN ACTIVATED, THEN run redsn0w... ill remember that for next time

    Erm, message who on what? im confused? Erm, i have Prowl installed and i have a website wish will send a notification to Prowl -- will that do as a test? (since Prowl uses push i believe??)

    J

    UPDATE::

    HAHA, i just killed my Wi-Fi, then run my test web page -- prowl pushed to my phone fine so i guess im all ok on my 3GS too

    Thanks fot all your help confucious
    Last edited by jtanner; 2009-08-15 at 11:22 PM. Reason: UPDATE:
    do'h

  16. #14
    Glad it's working.
    Push is normally used on IM apps, that's why I suggested what I did. But glad it's sorted
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  17. The Following 2 Users Say Thank You to confucious For This Useful Post:

    jtanner (2009-08-17), nutz (2010-11-04)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •