Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 2G redsn0w hacktivate "No Service"

  1. #1
    Default iPhone 2G redsn0w hacktivate "No Service"
    Hello there!
    Please forgive me if this has been discussed in detail somewhere, I have been searching for hours for my problem, but I think I may have a somewhat unique problem.

    I have a used iPhone 2G that was given to me from a friend, and I would like to use it with one of my SIM cards without having to upgrade my plan or renew my contract. I installed redsn0w, and it bypassed the activation for me--but now I only see "No Service" after a short "Searching..." period. Should I have told redsn0w to unlock the phone, even though I am using an ATT SIM, just without the iPhone plan? Or, is there a way to legitimately activate the iPhone without changing my ATT plan?

    Also, do you think this could be because I have an older SIM card? It is a 3G SIM, however it isn't the same style as the newer ones (it's from around 2005-6).

    Sorry if this has been discussed before, I just am not entirely sure what to look for, since "iPhone ultrasn0w activation no service" doesn't exactly turn up many results related to the problem I'm having.

    Thank you for your time!
    Last edited by tylerfixer; 2009-08-06 at 09:20 AM. Reason: corrected some confusing information

  2. #2
    well, I can only give you some general advice:

    1. Have you only done the jailbreak once? Sometimes something goes wrong, maybe re-jailbreaking from scratch would help (so restore to 3.0.1, then jailbreak)

    2. Have you tried installing ultrasn0w? I don't live in the US and I guess normally any AT&T card should work, but it can't hurt to install ultrasn0w

    3. Have you tried PwnageTool? I jailbroke and activated my 2G via PwnageTool and it worked fine

    4. Could be your sim card. I read that some older sim cards make problems, though I guess yours should work if it supports 3G. But it could be the issue, just saying ...

  3. #3
    I have tried the jailbreak twice (once with an inactive SIM that was from the original owner, and once again with the new SIM to try to 'hacktivate' the phone).

    From what I've been reading, I think that ultrasn0w is only for the iPhone 3G.

    I do believe that you are right about the SIM card being too old-- I just popped it out a second ago, and it's a Cingular 3G SIM. I think (for whatever reason) the iPhone won't download the tower list from the SIM or the network. I will try again with the SIM from my primary phone (brand new SIM), and I think that'll work.

    Thank you for your quick reply!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •