Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3G SSH Not Working 3.0

  1. #1
    Default 3G SSH Not Working 3.0
    I just recently updated my jailbroken iPhone 3G (formerly 2.2.1) to 3.0. It's been a long road (albeit a two day one), with many issues. Most of the things I'll list here probably have nothing to do with my SSH issue, but I figure an overload of information is better than an underload.
    Originally, I prepped myself for the big update (copied out SMS, Safari bookmarks, etc. via SSH, and thank God for that) and shift+clicked update to the 3.0 firmware (it is the correct 3G 3.0 Firmware; iPhone1,2_3.0_7A341_Restore.ipsw), where I soon received an error because, silly me, I had forgotten to update iTunes. So, after updating iTunes, the firmware update went relatively smoothly, since I restored rather than updated, I was prompted to restore to a backup, which I did.
    I noticed something was amiss when my home screen came up - I was missing my Settings app, presumably because I had forgotten to unhide all of my apps when I updated. Also, my apps were extremely spaced out because of the skin (iHome) I was formerly using. Long story short, I did another restore to a backup I believe, and I was on track. I had Settings restored, and things seemed to be on track. I attempted to sync my phone with iTunes, but I had a hellacious time syncing apps. I seemed to get three or four apps synced, which would disappear at various times. I updated through the App Store, and some would appear, some would disappear. Some of the icons were switched as well. It was at this point I decided to restore fresh, no back up. (I'd like to point out how great it is having Outlook synced with my iPhone; all of my contacts, calender entries, and notes are stored within Outlook. I don't have to worry about losing them with a restore!)
    After this restore, I believe things were looking better than usual, and after a successful sync, I had everything I needed. I now attempted to apply my theme again (iHome, an iNav based theme), which is where trouble re-began. At this point, I had reinstalled all of the apps from Cydia I had written down that I thought I would need, and SSH was working fine (I had dragged my SMS conversations over as well as my Safari bookmarks, it worked like a charm.) After a day or so of struggling to move 90 blank icons across the screen, safe mode crash after safe mode crash, I finally got the theme right this afternoon. At which point, my iPhone awarded me with a cycle of Safe Mode to Respring crashes - over and over and over again.
    I restored once more, when I decided I would not use an iNav theme (I'm not so sure the 3G has enough power to support a theme like that and 3.0, as opposed to the 3GS). This may be where my SSH trouble began (remember my SSH problem?) After that safe mode crash restoral, I couldn't get into SSH for the life of me. I have restored my phone perhaps five or more times since then, jailbreaking in Redsn0w, installing OpenSSH, reinstalling OpenSSH, reinstalling OpenSSL, trying various different methods, including ToggleSSH, all to no avail. When I attempt to log into my phone with WinSCP, I get the error, "Network error: Connection timed out." - and yes, I am sure I have the login correct. ([email protected];alpine)
    I also gave iPhone Tunnel Suite a try, but at this point in the night, I am too exhausted to find a version that wasn't in a foreign language.
    Long story short, I restored from 2.2.1 to 3.0, SSH worked(through several restores), I restored to 3.0 (maybe a fourth time), SSH didn't work.
    I hope this isn't too much information, and maybe this thread can even help someone somehow - I know forums can really come in handy sometimes. Google + forums are the solutions to all tech related problems...
    Anyways, thanks!
    Last edited by twitchytack; 2009-06-30 at 06:23 AM. Reason: Forgot to add winscp login correctness

  2. #2
    wow this sounds like the crap i am dealing with....ssh doesnt work with everything i have tried...itunnel, iphone browser, iphone PC suite (my favorite), winscp, etc.....plus i come to find out vwallpapers/skew isnt working....the only two things i want to work and they arent....woohoo 3.0 OS = PITA research all over again

  3. #3
    To be honest, the research wouldn't be so bad if I had something to research FROM. I guess this is what we get for playing with the [relatively] new firmware, eh? Worse comes to worse, I downgrade to 2.2.1, though I really like the features native to 3.0.

  4. #4
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    Ive had issues with losing SSH with every upgrade since 2.2 (might have been 2.1). What I found is sometimes I need to reinstall Open SSH, toggle it off and then on again. Hard reboot the iPhone. Also on OSX I have to delete the known hosts file then reboot the mac. Then SSH will finally work. With WinSCP it seems to work after I get it working on the Mac so probably toggling SSH off and on and the hard reboot of the iphone does the trick.

  5. #5
    My iPhone is a Part of Me lach's Avatar
    Join Date
    Jan 2009
    Location
    Australia
    Posts
    516
    Thanks
    30
    Thanked 82 Times in 67 Posts

    ^^ I have had to do the same thing, rebooting the phone after installing ssh and likewise with the computer. Somehow that seems to fix the problem!

  6. #6
    Default 2G 3G iPhone 3.0 sshd host key fix
    Hi all. After updating to 3.0 from 1.1.3, I found my ssh server (i.e. sshd) was NOT running. After fiddling with it from the command prompt it was clear the host keys weren't generated.

    Here is how to tell if this is your problem:

    1. Ensure you have an app that will get you to a console (e.g. MobileTerm)
    2. Get to a command prompt (by opening that app)
    3. Now get a root session (i.e. 'su' or 'sudo -i')
    4. start the sshd server with the full path: '/usr/sbin/sshd'
    5. if sshd can't find host keys, then you'll need to generate them


    Here's how to generate the iPhone sshd host keys:

    1. get a root prompt (see above)
    2. generate the keys: '/usr/libexec/sshd-keygen-wrapper'


    Igf the keygen program moves after I've written this, you can find it's path with 'find / | grep sshd-keygen-wrapper' or simply look in the "Filesystem Content' menu for the OpenSSh package.

    Good luck!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •