Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3gs new bootrom 3.1.2 not recognized in DFU by pwnage

  1. #1
    Default 3gs new bootrom 3.1.2 not recognized in DFU by pwnage
    Hey,

    I'm trying to figure out a way to get this 3GS up to 4.1

    Its new bootrom, running 3.1.2. It was unjailbroken but since I was having no luck getting pwnagetool to recognize it in DFU mode I tried to run redsn0w tethered on it, that didn't help either.

    Now I'm thinking, what about Spirit + Spirit2pwn, would I need to be in DFU since the phone may technically be "pwned"?

    I really need to get this phone sorted so just considering all options really.

    Is there any risk running spirit on a phone that is redsn0w jailbroken on 3.1.2? And is the spirit2pwn repo up at the moment?

    Thanks

  2. #2
    This is my 3rd edit, I've been thinking about your problem.

    Latest pwnagetool needs your phone to be put in DFU by pwnagetool so it can put part of the exploit into your phone to make sure the restore of the custom firmware goes without error (1600 or 1604 from what I'm seeing). I understand that you have had success with 3G phone already, could it be that they were already pwn'd? Phones which are already pwn'd with older custom firmwares can just be restored without the pwnagetool DFU (I am thinking - not confirmed yet).

    So coming back to it, maybe your method of putting the phone into DFU is not working and didn't work on the 3G phones either (they just didn't need the exploit or were already pwn'd).

    As to your problem with this specific phone, firstly don't use spirit2pwn on new bootrom it will kill the phone. You can jailbreak with spirit and unlock there obviously, but getting 4.1 is going to be hard as the tool for this is currently Mac only. Can you get access to a Mac to put it in DFU then go home and restore?

    Only other options are to wait for sn0wbreeze which will likely have a windows version to get it into DFU, or try a jailbreak with blackrain and try the custom restore again, but that will result in a tethered jailbreak if you can't do the custom restore (but only while you wait for snowbreeze).
    Last edited by eyeRobot; 2010-10-22 at 07:29 AM.

  3. #3
    I'm already on the tethered jailbreak, as I used redsn0w 9.4 to try to get it "pwned" so I wouldn't have to use DFU. This didn't work. The phone just sits in restore mode after it reboots from DFU (since it can't boot as it's tethered).

    Hmm, you could be right about the DFU thing but it's weird. Here's the full situation:

    First 3G phone: Jailbroken on 4.0.2 with redsn0w. Worked first time no problems.

    Second 3G phone: Not jailbroken. PwnageTool recognized it in DFU mode, but when I went to restore to custom firmware it goes to the pineapple logo and just sits there with the thing going round and iTunes says "preparing iPhone for restore". Left it for 30 min but didn't work so restarted the phone and just jailbroke it on 4.0. Had to send it to a buyer so didn't get the chance to test if it would work after the 4.0 jailbreak.

    3GS Phone: PwnageTool does not recognize it in DFU mode at all. When trying to restore from iTunes it does not bypass the "Checking apple servers" bit so I just get a 1600 error.

    I am doing all of this in VMware on Mac OS X Leopard 10.5.2 with iTunes 10.0.1.

    The weird part is how PwnageTool recognizes the 3G phones in DFU but not the 3GS. No idea why that happens :S

  4. #4
    Suppose buying a Mac is a but of an extreme solution to jailbreaking your phone?

  5. #5
    It is considering I have no idea whether it would work or not. Shame I don't know someone with a Mac.

    I managed to get PwnageTool to accept the device in DFU mode now but it still doesn't seem to make a difference.

    How I did it was having the phone in DFU, start the DFU process, unplug the phone and plug it back in, the phone boots to recovery logo, put it back into DFU again, PwnageTool says SUCCESS!

    However when I try to run the custom firmware in iTunes it still asks to connect to iTunes servers to verify the restore which I think is the part the DFU exploit is supposed to skip :S

    Same result, error 1600 after a few min.
    Last edited by bellyfrog; 2010-10-23 at 03:00 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •