Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3GS restarts every 3-4 minutes after jailbreaking to 4.0 with pwnage

  1. #1
    Default 3GS restarts every 3-4 minutes after jailbreaking to 4.0 with pwnage
    Has anyone found a solution to this issue? I've read several people are having the same problem.

    Just used pwnage to upgrade a jailbroken 3GS (done with pwnage on 3.1.2) to 4.0, and after spending several hours learning how to get it out of the recovery loop (using iRecovery), I was thrilled to see iOS 4. However, after playing with it for 3-4 minutes it crashed - the system restarted to the boot screen. The same process of restarting every 3-4 minutes is still occurring now several hours later, no matter whether I try to use the phone or not. I've experimented and this occurs while it is backing up/syncing, as well as trying to restore (so can't restore to any other version before it reboots).

    I tried to downgrade to 3.1.2 as I read someone had success with this, but didn't know about SHSH blurbs... (stupid, not to do the research, I know). When I try to downgrade I get a 1600 or 1604 error. I'm on mac platform, but tried to use iREB on parallels without success (not sure if this is because it only works with 3G, but it didn't make my screen white).

    One other issue I recently wet the phone in salt water and had to disassemble, soak in distilled water (yes I tried the rice in the bag trick), and although the phone worked well for 3 weeks before upgrading I think I have a bad battery, based on the code from iRecovery:
    Boot Failure Count: 0 Panic Fail Count: 0
    Entering recovery mode, starting command prompt
    gas gauge SWI line low: issuing reset
    gas gauge read timed out
    hdqgauge voltage bogus: -1mV

    I'm planning to replace the battery, as this rebooting may be a hardware check failure unique to 4.0, but not confident that will work.

    It has been about 12 hours, and I'm ready to give the phone away to my worst enemy. Any thoughts as to why this happens or possible solutions?

    Thanks

  2. #2
    Research tinyumbrella and see what SHSH files you've got

    You can use tinyumbrella to easily go to stock firmwares you have the SHSH for, it will also kick you out of recovery mode.

    Make sure you are in recovery mode (not DFU) when restoring.

    Easiest thing to try is to go to 4.0.1 or 4.0 and then jailbreak with jailbreakme and see if it's the same problem.

    Hardware fault sounds likely.

  3. #3
    Default Also got the 3-4 minute reboot cycle
    My 3GS has also been for a swim, but was successfully dried out and working again with software v3.something.

    Unfortunately I accidentally accepted the upgrade to v4... which is when the trouble started.

    Having been through the error 29 recovery loop and got out of that using iRecover, I can see that I also get the gas gauge errors. My phone is not jailbroken.

    The battery percentage is reported as high, but even if plugged into a mains charger the phone reboots itself continuously.

    I can't see how it can be a fundamental battery problem, as it worked just fine under 3.x. I can imagine that there's some additional (& superfluous) software test condition in v4 that is now failing.

    Anyone got any further clues on what to try next...?

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You should text msg Steve Job about the failing iOS 4.1. I have a jailbroken 4.0 and is very stable, never reboots itself, no more crashes and performs faster than 3.xx

  5. #5
    Default Text message Steve Jobs?
    Not sure how excited he'd be to help us out of this one.

    I just replaced the battery with an aftermarket one from China. I've downgraded to 3.1.2 and phone works fine now.

    I plan to try to upgrade to 4.0 again now that I have the new battery in and I'll let you know how it goes.

    Anyone have advice on best software to jailbreak up to 4.0 from 3.1.2? I get the 1602 error when I try with Pwnage.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •