Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone Screen Freeze Lock Out - Possible Fix, Probable Cause?

  1. #1
    Smile iPhone Screen Freeze Lock Out - Possible Fix, Probable Cause?
    I have a jailbroken 2G iPhone running on T-Mobile, Firmware 3.0, BB 3.9. I've owned it for two years (since 2007). I am using the latest iTunes build 8.2.1(6). I've always used Pwnage, which is why I've put this thread here ... if a mod feels it would be better to place it in another channel, by all means please do so. I honestly can't say if what I describe below would play out the same way with a QuickPwnd phone.

    Roughly five or six days ago, the screen on my iPhone began locking up. The software was running, calls would come in, texts would be received, but I was unable to use the touchscreen at all. This wasn't a case of a "dead strip," the entire screen was unresponsive. For a while, a hard reset (more like five or six resets) would restore the screen for a while, but as soon as I got a phone call or did anything where the screen passively changes modes (when you take a call and hold the phone to your face, the screen blanks so you don't accidentally hang up or activate something), the phone would lock up again. Eventually, even this stopped working and the screen refused to come back to life.

    I tried just about every fix I've found on these forums. I tried ******* with the screen sensitivity vis a vis SSH and the PowerPref plist files, I tried removing that file altogether, I tried Reset on the settings in all panels (APN and General>Network), and of course I tried many, many, many, many hard resets and restore varieties.

    After reading a ton of forums (here, hackint0sh, fixya, etc), I came to the same conclusion that many others did: the screen is broken, take it to the Apple Store or buy a new one.

    I'd given up. I removed the T-Mobile SIM, did a DFU Restore and then put in the AT&T SIM. I was sitting there debating whether or not to activate the phone via iTunes, get an AT&T number, bring it to the AStore the next day, and then cancel the AT&T account ... and that's when I noticed that my screen was back to normal. I could move sliders, although I couldn't do anything beyond the restore screen since I don't have an AT&T account.

    So, I took it out of the dock and I put the T-Mobile SIM back in. Then I put it back in DFU, ran Pwnage again and restored with the custom build ... voila! I had a working iPhone again.

    I then restored from a back up from just before my problems started -- nothing special installed from Cydia at that point, except Cycorder. Also of note: I use an Exchange Server at work, and therefore after I restored, I was forced to use a passcode again (Exchange will not allow you to have unlocked phone on the server).

    It seemed to work fine. I was able to use the phone, set it down, make calls, hang up, etc. Nothing locked.

    I then installed Cydia's MMS activation hack, set up my wap.voicestream.com stuff, etc.

    A couple of hours later, I went to use my phone and I was right back where I started. Locked. Useless. I rebooted a dozen times, no result.

    So, I wiped it all again in DFU ... still no luck. I took out the T-Mobile SIM, did a DFU restore with NO SIM in the phone, and my phone was restored to normal working order.

    Now, maybe I'm crazy, but would it be impossible to think that there's something going on wherein AT&T is aware of activity on their network and is able to bullet the iPhone and relock it?

    I noticed that the only MMS APN settings that would work for T-Mobile (on my plan anyway) involved using an apple.com UA Prof -- the sonyericsson one fails for me every time. Is it possible that this rdf is feeding information about our jailbroken iPhones to AT&T who can then contact T-Mobile or otherwise interfere with the operation of the device? It seems unlikely, and probably illegal, but I wouldn't be shocked to learn that it's true.

    The only other theory I have is that something to do with the MMS enabler Cydia hack by itself, or perhaps the ActiveSync connection to my work's Exchange Server set up (or perhaps both in concert!) is somehow messing with the phone and locking it as illegal even after being Pwnd.

    Any theories here? The exact same thing happened to my boss just two months ago after he moved from Edge to T-Zones and updated his APN settings. He also uses an Exchange Server.

    I'm hoping there's someone knowledgeable about telephony that can throw out some plausible theories ... my paranoid sketches above are pure speculation, and poorly informed at that.

    If nothing else, I hope this thread is useful for someone else who is suffering the same tech failure that I was and who is considering scrapping their 2G iPhone because of a dead screen.

    I plan to keep testing by incrementally adding apps/hacks and trying to deduce what combination, or what single mod, is creating the havok. Right now, I've got NOTHING installed outside of the basic Cydia app and my contacts. I'm going to start with the MMS without any passcode, no screen lock, and no ActiveSync connections set up.

    NOTE: if you've just got a "dead strip" and other areas of your screen are working, this will not help you. Try the screen sensitivity hack instead.

  2. The Following User Says Thank You to spire For This Useful Post:

    dude111 (2010-07-26)

  3. #2
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,096
    Thanks
    333
    Thanked 603 Times in 506 Posts

    Have you tried monitoring your memory?

  4. #3
    I don't know about memory monitoring - I suppose I can try that, but unless I can pull it up by shaking the phone, when the screen locks up it probably won't do me a lot of good. I'll look into it, though.

    I was able to get the phone to misbehave by installing the Essential Upgrades for Cydia (the upgrade from the initial Cydia install to current trunk). It said "RESTART" at the bottom, but it just dropped me to home. So I restarted manually, and when it rebooted the screen was unresponsive. Five or six hard restarts later, no different.

    I've restored to a back up from just before I launched Cydia for the first time and so far, it has been stable for an hour or so. My cellular data network APN is set to wap.voicemail, and I've tested WiFi and all seems normal. Edge seems to be working alright ... slow as ****, but what else is new?

  5. #4
    i have the same exact problem. did you figure out what is wrong?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •