Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: For when Shift + Restore doesn't work... (custom firmware restore)

  1. #1
    Livin the iPhone Life sziklassy's Avatar
    Join Date
    Jan 2008
    Location
    Iowa (ISU for Vet School!)
    Posts
    3,920
    Thanks
    69
    Thanked 310 Times in 264 Posts

    Default For when Shift + Restore doesn't work... (custom firmware restore)
    Well I spent alot of time trying to restore a custom firm made by Wally (thanks Wally!) and I just couldn't get Shift + restore to work... it would always just want to do the stock restore that iTunes downloads.

    Well I let the stock file download but told it not to update.

    I then navigated to the iphone firmware folder and renamed the STOCK APPLE firmware (i just added the word STOCK after it).

    I also renamed the custom firmware to the stock name (minus the words "STOCK APPLE" of course) and placed it in the firmware folder.

    I then told iTunes to do a restore... really I didn't expect this to work.

    BUT IT DID!!!!

    For reasons unknown to me, some people are having trouble doing shift + restore on their phones. I NEVER had this issue and even did a restore (to 2.0.2) on the 8.0 firmware the other day with no issues. Then today, when I finally found the right pwnd firmware for me, shift+restore WOULD NOT let me pick what firmware I wanted.

    Essentially I have done nothing special here, per se. I have just simply "tricked" iTunes into believing that my custom firmware was downloaded by iTunes itself since apparently the only check it does is a file name check.

    Hopefully this helps some of you that have had trouble with shift+restore. I did this on windows Vista, but I have no reason to believe why it would work any differently on XP or even OSX for that matter.

    It might be worth noting that the checking iPhone software seemed to take longer than I remember but, against my instincts to freak out and assume all hope was lost, I let it sit for about 5 minutes. Of course you already know the outcome of this...
    Last edited by sziklassy; 2008-09-17 at 11:30 PM.
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------
    I once prayed to God for an iPhone, but quickly found out He didn't work that way...so I stole an iPhone and prayed for His forgiveness.

    A dog is the only thing on earth that loves you more than you love yourself. - Josh Billings

  2. #2
    i remember trying to jailbreak one of my friends phones on my laptop (running vista) and the shift+restore wouldnt work either. Try ctrl+restore or shift+restore. I remember i held down a different button + restore and it worked

  3. #3
    My iPhone is a Part of Me JazJon's Avatar
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    623
    Thanks
    38
    Thanked 55 Times in 42 Posts

    Oh yeah? wow that's even easier. Can someone else confirm that fixed their problem of not being able to shift restore as well?

    I kept getting errors until I followed this thread here:
    http://www.modmyi.com/forums/pwnage/...-1600-yay.html

    Your way of renamming is even easier. I have a friend I need to help jailbreak later tonight, I'll see if it works for me too. (renaming)

  4. #4
    Default Solved
    I dont know anything else BUT all of you whos running WINDOWS VISTA ULTIMATE 64bit Run the itunes in administrator. I know I know u are the only user on your pc and priviledged to administrator BUT its not enough you must run the itunes in administrator mode. (right click the itunes.exe -> properties -> compatibility -> privilege level at the bottom thick the box (if its grey google how u will be able to change it)! AND VOLA u are able to restore your phone with the shift click method!!!!

  5. The Following User Says Thank You to Pualikas For This Useful Post:

    redwolf (2010-09-26)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •