Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cydia consistently kills iPhone 3g requiring restore

  1. #1
    Default Cydia consistently kills iPhone 3g requiring restore
    Note: I accidently posted this in the iPod forum instead of iPhone. Reposting here.

    Well, I've tried two phones now and each time running Cydia on the latest 2.0.2 firmware, and jailbreaking using both quickpwn and the new winpwn results in the same thing, a frozen at the apple logo phone.

    Generally the problem occurs during an install of apps from Cydia. Using Installer has yet to have any issues. Cydia will run through some process then either lockup OR lockup moving to the main iPhone menu. In most cases there will be the spinning hourglass in the middle of the screen probably indicating that Cydia is working on something prior to closing.

    I have to say, I don't know if it's shitty Apple software or shitty other software, but it's getting old.

    If I don't jailbreak the phone, or don't run Cydia I have no problems.

    Two phones, the second without anything from the old phone touching it, would indicate it's not the hardware.

    Getting sick of looking at the Apple logo of death on restart

  2. #2
    the only time i got stuck on the boot logo was when i installed MiVtones from the MMi repo. After that my phone was fubar'd. Everything else installs with ease though and my phone has been working since i haven't installed Mivtones, which i'm asssuming right now just isn't ready for this FW.

  3. #3
    I'm hoping that the process described in Cpjr's post will fix the issues. But something is causing phones to be very unstable after pwning them and installing apps from Cydia. I never before had any problems with my iPod Touch on firmware 1.x. So whether it's 2.0.2, 2.0 in general, or problems with the pwning process or Cydia, I don't know. It's frustrating though!

    Back to the ironing board.

  4. #4
    Livin the iPhone Life 461am's Avatar
    Join Date
    Aug 2008
    Location
    Houston, TX
    Posts
    1,239
    Thanks
    28
    Thanked 183 Times in 159 Posts

    How many appstore applications do you have?

  5. #5
    Too many 40ish

    I'm trying the approach started in Cpjr's thread and expanded by Jazjon. So far so good. In a nutshell:

    1. Complete the pwn process without restoring any data or apps first. Just treat as new phone.
    2. Install the core Cydia/Installer apps you need, etc etc. Take special care that you leave time between operations before installing apps. Cydia doesn't seem to know/care if the phone is busy with other operations and will do it's thing, which can resort in a couple hours worth or restoring
    3. Begin the process of installing your apps by downloading from the iPhone Appstore application. Again, leave time in between, don't rush it.

    If you do anything that will need a reset of the phone, like changing a Winterboard theme (maybe not reset but you get the idea) and such, again be sure you begin the process only if the phone is not busy with another task, like installing an app.

    Looks like we just need to baby these things until the phone, apps and jailbreak installers are out of the teething stages.

  6. #6
    i have one major issue after jailbreaking, after running cydia my push email stops working and takes ages to actually get mail. It does eventually get it manually but wont push at all.

  7. #7
    I think the problem here has to do with the apt.saurik.com (tangelo) source... it presents lower versions of Coreutils whereas a higher version of the Core Utilities is installed by the Cydia basic package... this kind of screws up the whole update process... not sure how this comes and who is to blame, but I can recall that the last thing I saw on my screen when I tried to ssh into the iphone after coreutils update and before it died on restart was that the ssh whined about dircolors not being able to find some dynlib and a mention of coreutils...

    I can presistently reproduce this by updating the coreutils in cydia!

  8. #8
    Community Manager Bo Troxell's Avatar
    Join Date
    Aug 2008
    Location
     Valley of the Sun, ARIZONA ♥♥♥
    Posts
    35,196
    Thanks
    5,590
    Thanked 12,540 Times in 7,596 Posts

    Quote Originally Posted by Deeeep View Post
    I think the problem here has to do with the apt.saurik.com (tangelo) source... it presents lower versions of Coreutils whereas a higher version of the Core Utilities is installed by the Cydia basic package... this kind of screws up the whole update process... not sure how this comes and who is to blame, but I can recall that the last thing I saw on my screen when I tried to ssh into the iphone after coreutils update and before it died on restart was that the ssh whined about dircolors not being able to find some dynlib and a mention of coreutils...

    I can presistently reproduce this by updating the coreutils in cydia!
    you realize that you posted to a thread that is almost a year old, but thanks for the input. lolz...............O_o

  9. #9
    Ive noticed that when you install libxml2 on 3.0 with Cydia or Icy, it will always lockup andstay on bootscreen. I posted this in another thread, but dont know if anyone confirmed or not if it was just my iphone doing it.

    P.S. Posted this because my iphone is doing the same thing on some apps and they all seem to be ones that require libxml2.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •