Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Error 1604... I need massive help here :)

  1. #1
    Question Error 1604... I need massive help here :)
    Ok, so i'm going to spare you all the harshness of my story of trying to upgrade my phone, so i'll just tell you where i'm at. If you want to know the past, go ahead and ask questions.

    Ok so here's where i'm at. I have successfully restored my phone to 1.1.4 firmware. It's a custom firmware built with winpwn. Oh ya, and my phone is pwned to obviously btw..

    So now that i have a working custom 1.1.4 i want to upgrade it to 2.0 or 2.0.1. One of those would be just fine.

    Here's the problem though... i always create a custom 2.0 or 2.0.1 with winpwn, and then i go to itunes (the latest version) and do the shift-click restore to select it. The iphone starts to restore and everything seems ok, but then i get error message 1604.. Every time. I mean i've restored back to 1.1.4 so many times to try different custom 2.0 or 2.0.1 firmwares and none of them are working.. I'm not sure what to do.

    What should i do? All i want to do.. is create a custom 2.0 or 2.0.1 firmware that has the following.. Unlock, Jailbreak, Installer, Cydia.. that's it. I have a cingular sim card so i need it to be unlocked from att.

    Thanks for your help!!!!!


    UPDATE!!:: Ok, so i've got the new winpwn.. itunes is at 7.7.1, and i got the 2.0 firmware from this site. So now when i go to create a custom 2.0 firmware, i set up everything like the iClarified tutorial says, but about half way through creating the custom firmware it crashes and just closes itself... I can make custom 1.1.4 firmwares, but nothing above that.. ugh great, now what do i do
    Last edited by HyenaSpaz; 2008-08-10 at 09:48 AM. Reason: update

  2. #2
    Same problem here. The error number sometimes is also 1601.

    I followed strictly the manual, but still got the error.

    I'm using a iLiberty+ 1.1.4 iPhone, iTunes 7.7.1, WinPwn 2.0.4.

  3. #3
    You have to put it into DFU mode to work (if you're lucky just simple restore mode), just pressing the 'restore' button will not do. Now, if you were putting it in DFU mode (you didn't specify) then there could be a problem. If so, did you pwn iTunes and what version of iTunes are you using? If you want to upgrade to 2.0 or 2.0.1 you must have iTunes 7.7, nothing else will do.

  4. #4
    Ok, so what your saying is to put the iphone into DFU mode and then shift-restore it? Also, you said something about pwning itunes.. ya umm.. what?

    I'm using itunes 7.7.1 (the latest version.) I updated my itunes once i restored my phone to 1.1.4.

    Before i uninstalled my itunes then installed itunes 7.5, restored to 1.1.4, then upgraded itunes to 7.7.1. How do i repwn it then?

    Btw, i know how to put it into DFU restore
    Last edited by HyenaSpaz; 2008-08-10 at 12:07 AM. Reason: Automerged Doublepost

  5. #5
    - iTunes 7.7.1
    - iPhone 1st Gen - iLiberty+ 1.1.4 (Clean jailbreak)
    - Winpwn 2.0.4

    After I create my custom IPSW, I press the iPwner button, it says my iTunes has been Pwned, I press OK and put the iPhone in DFU.

    I have put the iPhone in DFU manually and thru iLiberty, and neither has worked. The DFU screen was just like the restore on the iPhone when I unlocked with ZiPhone. This is my first iLiberty+ unlock, and when I put it in DFU (using iLiberty+ helper) the background was red.

    After putting in DFU I start iTunes. I have killed the process iTunesHelper, to not start iTunes automatically. Yes, I have tested without killing it and has not worked. After iTunes has started it asks me to check the iPhone, if I say no it ignores my iPhone, so I click Check. After I shift+click the "Restore" button, select my custom IPSW, and the process begin:

    - Extracting Software
    - Preparing iPhone for restore ... (stays here for a long time, unusual)
    - Error 160x, x={1,3,4}
    Last edited by OrBiTaL.Zer0; 2008-08-10 at 12:31 AM.

  6. #6
    Locate your "device support" folder and remove anything that's in there. Restart the process and it should work

  7. #7
    ej satch do you can tell me how i can locate the device support? i looked on my pc and i cant find. i have exacly the same problem like guys there. thanks for help anyway , you was only one who answer at all

    hold on.... you have os x i have a vista.... well... thats it
    Last edited by kiniu; 2008-08-10 at 05:05 AM. Reason: Automerged Doublepost

  8. #8
    Wait.. where's device support?

    And does anyone have the answer or a way to solve this to my original question in the beginning of this thread? haha

  9. #9
    Do you mean mobile device support by any chance? Looks like some important stuff in there...

  10. #10
    Default Itunes can't find phone in DFU mode!
    I have a major issue and would be extremly happy for any solution!

    I have a Iphone 2G, now updated firmware from 1.1.4 to 2.0. I upgraded it with winpwn 2.0.0.4 on my PC. Everything worked fine to make the customized firmeware and everyting. BUT... I did not have the right settings made in winpwn from what I have realized now. The thing is that I didn't tick the "Activate phone" box. So when the i connected my Iphone it upgraded without unlocking it.

    If I turn the phone into DFU mode, then Itunes does not recogize it and I have to put it on to get Itunes to find it. So now the only thing that is possible is to have the phone in dock-to-itunes mode and the the phone keeps asking for my AT&T account, (that of coure I don't have)

    I have made a correct firmware to and make another update (or if does not work I will downgrade it to 1.1.4) so that is not the problem.

    The thing is that I can't get Itunes to find it and enable me to restore (and find another firmware).

    Does anyone have any ideas on how to get the phone to appear in Itunes in DFU-mode?

  11. #11
    Look in "find" on your pc and type "device support" and make sure it looks all over your computer and that its looking for a folder. Inside, there should be a file name x12220000_4_Recovery.ipsw If that file is present, copy it on your desktop and remove it from that folder. Use winpwn once again to build the custom tool and it should work. The reason I am tellig you to put it on your desktop is so you don't lose it in the case that you may need it. Another way to locate that folder is to look specifically for that file in your search engine of your pc.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •