Page 1 of 2 12 LastLast
Results 1 to 20 of 33

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: WiFi Disconnecting Issue

  1. #1
    Default WiFi Disconnecting Issue
    After running Pwnage 2.0 successfully, I'm having an issue with the Wifi on the iPhone. (First gen).

    I can connect to a Wifi network no problem, but once the phone has to access data, through Safari/App Store, it automatically switches the Wifi off and over to Edge.

    Anyone else having this issue? Anyone know a solution?

    Thanks.

    No one has a solution? I've tried downgrading and erasing the BB. Still having the issue after upgrading to 2.0 again.
    Last edited by Iceflow; 2008-07-20 at 08:01 AM. Reason: Automerged Doublepost

  2. #2
    perhaps your iPhone is not making a good connection to your router.

    I got a new ip address after pwning 2.0.

    Are the rules on your router too strict? you didn't mention the router brand or the config!
    http://jpassoc.com/x -- with free itunes under the puppy!
    If I help you out, please press THANKS!

    3g QuickPWN'ed with 2.1

  3. #3
    The router is not the issue. I used my iPhone pre 2.0 on the same network with no problems. This issue is only happening since upgrading.

  4. #4
    great!
    http://jpassoc.com/x -- with free itunes under the puppy!
    If I help you out, please press THANKS!

    3g QuickPWN'ed with 2.1

  5. #5
    iPhoneaholic opusandbill's Avatar
    Join Date
    Oct 2007
    Location
    The Republic of Texas
    Posts
    384
    Thanks
    24
    Thanked 305 Times in 60 Posts

    I have the same problem, I can select my wifi connection in settings (it evens shows me connected) but all i get on my phone is the edge symbol.

  6. #6
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I'm in the same boat. 1.1.4 after iLiberty+ was crashy but it had wireless. Perfect sweet wireless. Now after a good pwnage 2.0 my 2.5G is stable but no wireless. Well, it can get wireless for a few bytes sometimes. It mostly refuses to show the network list. If it does show, then I can associate to the network but then it drops immediately. Resetting Network Settings (in Settings - General - Reset) can help bring up the wirless on restart. But not always.
    The router itself is ok. No changes to it. MAC hasn't changed on the iPhone either.
    BL 4.6, Neutered, Unlocked. I tried it in BL 3.9 to see if that'd help either. Nope.
    I grabbed an older copy of Terminal off mobileterminal - Google Code and rolled it into another custom ispw and uploaded it to see what ifconfig would tell me.
    ifconfig tells me that it exists but doesn't have the right IP that I expect that it should.

  7. #7
    I have a variation of this problem, also on a 2G iPhone upgraded to 2.0: Whenever I turn on the WiFi, my house's network goes down and back up in a second - everything gets disconnected and reconnected after a minute or two (iPhone included) and once that's on, it's on for good with no problems. It's just the initial connection from the iPhone. I even assigned my iPhone a static IP on my Router to avoid any routing table conflicts that could be brining my router down, but still no go.

    Any ideas?

    Follow me on Twitter!

  8. #8
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Location
    Old Town
    Posts
    129
    Thanks
    23
    Thanked 9 Times in 9 Posts

    I know this may seem elementary but a good place to start. Have you guys tried to reset your network settings, reboot your iphone and then tried to access your network? Just a thought.

  9. #9
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    That is an interesting twist. Mine has DHCP reservation by MAC (it all checks out) and so I don't need to specify one. I did try it without the DHCP and as DHCP offered with the IP statically set. No difference.

    The best part is, it will connect after the settings reset for a second and then, drop off. :-)

  10. #10
    I had the same issue...wifi gets connected but drops off after..what i did was:
    -reset network settings
    -then make sure to put the right password (if there is one)
    then thats it...i got my wifi back to work again

  11. #11
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Tried re-entering the password after Network Settings Reset. Doesn't change a thing.
    Tried doing this also when no password required on router. Nada.

    It'll join for a second and drop off right away.

    And it's not just my router, another open router down the hall, yup; can't join it either.

  12. #12
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    Ive had this problem in 1.1.4 in areas with a weak wifi signal. My 1.1.4 is WinPWN'ed, but my son has a 1.1.4 Ziphone jailbreak and has the same issue.

    I am going to try and relocate my router and see if that helps. The other thing that happens in one particular room of my house is that I think my iPhone picks up my next door neighbor's wifi signal and kicks me off my own wifi. Since he has wifi security as i do I cant log on to his network, but it wont connect to mine.

    Edge is actually faster than when my iPhone lives in wifi limbo.

  13. #13
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    My signal isn't weak. I'm pretty much right beside it. In 1.1.4 it was fine.

    On an interesting note I noticed that sometimes when it DOES connect for two seconds and dies off the network name is in the list but with no lock on it even though it is secured. When trying to rejoin it at this point by tapping it I get a note saying I could not join the network.

  14. #14
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    That is definitely odd. I did play around wiht my wifi this afternoon. I have stumbler installed on my iPhone and learned that my neighbors signal is stronger than mine up in my bedroom (the room I have the problems with wifi in) I changed the broadcast channel of my router to a different one than my neighbor but apparently the iPhone cannot be locked into a specific channel. it still likes my neighbors signal better up in that room. Too bad their network is encrypted, not that I advocate stealing their bandwidth. I cant even tell my iphone to forget theri network since I can't log on to it.

    Maybe I can ask him to let me log on once so I can forget the network. He can input his own security key (I wont look). Then I can tell the iPhone to forget his network . WOnder if that would work?

  15. #15
    What's Jailbreak?
    Join Date
    Jul 2008
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Still haven't got mine sorted out yet. Tried assorted channel frequencies just for kicks.

    I did upgrade to pwnagetool 2.0.1 which someoneone on the dev-team blog said helped with wireless. So I gave it another go and...

    the signal meter is a little better!

    But it still drops off.

    I did notice if it connects to mine it will pull a DNS entry of 192.168.0.1 which is the routers and this is incorrect, it should be a different IP not the routers for DNS. Even weirder: DNS is usually the only line filled in.

  16. #16
    Default Wifi not working
    I sort of have the same problem just a little different
    I have upgraded to 2.0 like the rest of you and my wifi was working great for the first few days

    I was connected to my home network last night everything was fine
    I was also connected to my works wifi yesterday as well.

    So i get into work this morning and i cannot connect at all i have reset the network setting...Done a hard reset but nothing it just does not want to connect if it doesn't come good tonight i am going to do a restore

    I am not a noob when it come to the iphone but this is really pissing me off.

    If you can help i will be very gratefull


    HappyModding

  17. #17
    This is what my phone is doing and it really making me mad. I had no issues before 2.0. My when ever I bring my phone out of sleep it takes for ever for the phone to register that the wifi is on. You can go in to settings and it says the wifi is connected but you only see the edge symbol. I have to open program that access the internet to actually activate the wifi. So annoying any ideas?
    1st gen iPhone custom pwn’d
    www.martinisgifts.com
    *************************************
    IMob friend code 129-015-829
    Mafia Live code 223-902-644

  18. #18
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    This is what my phone is doing and it really making me mad. I had no issues before 2.0. My when ever I bring my phone out of sleep it takes for ever for the phone to register that the wifi is on. You can go in to settings and it says the wifi is connected but you only see the edge symbol. I have to open program that access the internet to actually activate the wifi. So annoying any ideas?
    I have the same problem on winpwned 1.1.4.

  19. #19
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,307
    Thanks
    12
    Thanked 562 Times in 483 Posts

    2.0 updates the Wifi config. Have you guys tried updating the firmware on your routers? You may also try switching from WEP to WPA.
    Get "iPod & iTunes for Dummies", it'll change your life.

  20. #20
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    I already run wpa. Have a Verizon Fios Actiontec router so not sure how easy to upgrade firmware.
    At this point I'm thinking of getting a 3G iPhone so I'm my bedroom it wouldn't be a big deal to not get wifi.
    Interestingly, I get a stronger wifi signal ( according to Stumbler) out sitting in my car parked 100 feet or more from my router with 2 walls inbetween than I do upstairs in the house maybe 30 feet away

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •