Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3gs - Should I go from 3.1.3 to fw4?

  1. #1
    Default iPhone 3gs - Should I go from 3.1.3 to fw4?
    Hi there,
    could anybody give me an advice whether i should upgrade to fw4 (I also need unlock) or should I stay on 3.1.3 (jb-spirit and ultrasnow).
    It took me some waiting after going from 3.1.2 to 3.1.3 by mistake and don't want to be without a phone again!!

    Thanks for your advices.

    Rgds
    Erik

  2. #2
    Drinks the Kool Aid Captinsmooth's Avatar
    Join Date
    Mar 2010
    Location
    New York
    Posts
    1,322
    Thanks
    131
    Thanked 351 Times in 199 Posts

    Well that depends on a few things. Do you have shsh blobs saved for any of the 3.1.2 to 4.x.x Ipsws? Old or new bootroom? If old bootrom then you can downgrade to 3.1.2 and jb it with blackra1n then create a custom 4.1 IPSW with snowbreeze. If new bootrom then your only choice would be jailbreakme.com since you need a unlock do you have a sim card to activate your phone if you jump to 4.0.1 and use jailbreakme.com
    This post infers no rights and is provided as is.

    Click here to follow me on twitter

  3. #3
    Thanks,
    The iPhone is New Bootrom, 5.12.07 and I have SHSH for 3.1.3 on Saurik.
    I am using a SIM-card, but this is a card that needs Unlocking.
    So, youre saying I can, using jailbreakme, it does Unlock you say, provided I have a SIMCard. The question "remains": is it worth it.... I mean, 3.1.3. runs fine....
    Rgds,
    Erik

  4. #4
    Drinks the Kool Aid Captinsmooth's Avatar
    Join Date
    Mar 2010
    Location
    New York
    Posts
    1,322
    Thanks
    131
    Thanked 351 Times in 199 Posts

    4.x.x Ios runs great on 3gs it has allot of great features. But yes you would need an official carrier sim or a universal phone book sim off ebay to activate your phone after you upgrade to 4.0.1 So you could jb and unlock it to use with your current network.

    Just stay away from 4.1.0 due to the baseband upgrade that will render your phone useless as far as unlocking it goes.
    This post infers no rights and is provided as is.

    Click here to follow me on twitter

  5. #5
    Thanks Cap,

    i think i'm gonna look for that Sim card then... Already went through Ebay.... All of them from HongKong, no problem,,
    i have bought more stuff from there, but it isn't always that good....

    So, with Sim I should do the job??

  6. #6
    Default Will i ever have to upgrade FW
    Have 3gs; 3.1.3 jb; new bootram. The phone is set up perfect and never had a problem. Have not upgraded iTunes 9.x either. Will Apple ever force me to upgrade or will I be able to use my phone for an extended period of time? Ironically, some iPhone guys told me that 3.1.3 is probably the best version to-date.

  7. #7
    I agree !! Im pretty happy the way it runs, however I also yearn for upgrading to the FW4 with new features.... but yeah, if it causes me additional time to get everything running again.... my time is pretty tight already with family life and all...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •