Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3.1.3 jailbreak question

  1. #1
    Default 3.1.3 jailbreak question
    I am fairly new to jailbreaking and have some questions.

    I purchased my iPhone last summer and have kept up with the Apple updates. I am currently running my jailbroken iPhone 3GS on 3.1.2. I used blackra1n to jailbreak my device. However, I do have some apps that I cannot sync to my device now as they require 3.1.3. I have created a custom ipsw firmware file with sn0wbreeze.

    Is this an untethered jailbreak? Has anyone done this successfully? Theoretically I can just "restore" to my custom firmware and be done with it, correct?

    Yes, I know I should just search, but I'm at work and don't want to spend a lot of time just browsing right now.

  2. #2
    If your current jailbreak is untethered, then this one will be too. You either have the old iBoot or you don't. Blackra1n vs Snowbreeze has nothing to do with your iBoot.

  3. #3
    ahhh...Thanks Beez...

    well, this is definitely an untethered JB and I am pretty sure it's the old bootrom. I have not touched it since loading the 3.1.2 firmware from Apple and then JB'ing with blackra1n.

    so, in theory, I can just load my custom 3.1.3 ipsw firmware created with sn0wbreeze and have an untethered 3.1.3 JB... Or should I wait for the new version of blackra1n and then load the Apple firmware and re-jb? Hmmm...

  4. #4
    In theory, yep, that should be it.

    My old iPhone was old iBoot like yours, and I had to load a 3.1.3 CFW onto it, and it loaded without issue. (But AT&T swore the phone was bad!Turned out to be a routing issue, the phone was fine, however they made me exchange it for a new one that has the new iBoot. It made me sad )

  5. #5
    Quote Originally Posted by BumbleBeez View Post
    In theory, yep, that should be it.

    My old iPhone was old iBoot like yours, and I had to load a 3.1.3 CFW onto it, and it loaded without issue. (But AT&T swore the phone was bad!Turned out to be a routing issue, the phone was fine, however they made me exchange it for a new one that has the new iBoot. It made me sad )
    Did you have a phone issue after the firmware load? I assume it worked fine after you loaded it and then the routing issue developed after the fact, which would have been an issue with AT&T's switches, not a FW issue.

  6. #6
    Quote Originally Posted by arvetus View Post
    Did you have a phone issue after the firmware load? I assume it worked fine after you loaded it and then the routing issue developed after the fact, which would have been an issue with AT&T's switches, not a FW issue.
    I had issues from day 1 with the phone. Couldn't receive MMS from anyone not on the AT&T network. Couldn't send pics with 3G turned on (phone would crash). Phone lost service after I sent any pic message (on Edge) until I rebooted it. Calls went right to voice mail and never rang.

    AT&T said it was the phone. The "genius" @ apple crashed it on me, so I took it off him and took it home and "restored" it to a CFW of 3.1.3.

    Needless to say, the "most recent" firmware didn't solve the issue, neither did a new SIM card. So AT&T swore it was the phone itself (hardware) and had me exchange it under warranty. The new phone they gave me had 3.1.2, but the new iBoot (so now my jailbreak is tethered) and didn't solve the issue either.

    A week or so later, finally, and AT&T level 10 billion ( I joke, but he was a pretty high level tech) figured out it had something to do with the way messages and calls to my number were being routed, and had me fixed in a few days.

    I'm just ticked I lost the old iBoot for absolutely nothing!

  7. #7
    Well that just sucks bricks! Hopefully a JB tool will be out there soon. We'll see.

    But...no such luck with 3.1.3 for me. I couldn't load my custom FW, and then got stuck in a recovery boot loop, so I reverted back to 3.1.2.

    Of course, before I started this whole process, I verified my shsh hashes were on file with Cydia so I could sign the FW with Jay's server instead of Apple's and continue loading

    Guess I'll wait until everything's official with Hotz or whoever this new group is that's supposed to have a JB tool out today. I have a few App store apps that I couldn't restore now because they require 3.1.3... so I'm now damned if I do, damned if I don't.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •