HI,

I have a 1st gen 8gb iphone that I jailbroke about 2 years ago. Not sure what version anymore. I did nothing with it since except use it as a phone. Now there are a lot of cool apps and skins though so I wanted to add those. I ran an update on installer and that took me to a 2.0 version I believe, but not really sure. I wanted to then add apps but it tells me i need jiggy run time first, but that is not under development or anywhere. Can anyone help? Do I need to virginize, upgrade, or downgrade? TIA! L Guevara