So Im in the process of unlocking and ran into a glich. I have just installed 1.1.2 and the next step is to run ibrickr, but when I do the program says the phone needs to be set "free" and downgraded to 1.0.2....but thats not what the directions say. What do I do?

http://modmyi.com/forums/showthread.php?t=30427
these are the directions im following