Hiya, here's my situation

My iPhone came with 1.0.2

I upgraded/jailbreaked to 1.1.1 using the downgrade/prep method on iNdependence a LOOOOOOOOOOONG time ago.

I then tried the iPhone plan for 3 days (buyers' remorse period) and cancelled it.

Youtube stopped working after that 3 day official trial

SO I just recently (like MONTHS after the incident) restored my iPhone to 1.1.1 so I could use Jailbreakme to activate it. It worked. I upgraded to 1.1.2 since it "came" with Oktoprep (the Jailbreakme). The Java program didn't work, saying I did NOT have Oktoprep. I downgraded to 1.1.1

Now, Jailbreakme doesn't work anymore. Neither does i.Unlock.no

Sometimes the method to "Call myself" will result in the first call going to the contacts screen which FREEZES up my phone. Sucks. Other times, when I DO get through, my phone will NOT cooperate with either of the online jailbreaking methods. They simply do not WORK.

=/

Any solutions? I'm tempted to just go back to 1.0.2 and redo this entire shenanigans.