Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: International SMS / International Assist Problem with Unlocked iPhone

  1. #1
    Default International SMS / International Assist Problem with Unlocked iPhone
    So I just spent about 2 hours googling around for a solution to this and found none.

    I have an AT&T iPhone 3G, 3.12 firmware, jailbroken & unlocked with blackra1n / blacksn0w.

    I've been taking it with me from country to country, and local calls and texts work fine - it's the international ones that have problems.

    I have all my numbers stored in the +1 XXX XXX XXXX or +44 XXXX XXXXXX format...

    The problem is, when I try to text, the iPhone is taking the "+" symbol (plus symbol) and turning it into 011, which is the US IDD code for dialing overseas. I've tried putting in 001, 002, 021 (all IDD codes here in Singapore) but the iPhone reverts them to 011.

    Things I've tried:
    * Deleting numbers from address book & entering them in manually.
    * Any/all variations of international dialing codes, from "+" symbols to 011 to 001 to 002 etc etc
    * Putting my AT&T SIM in, turning off international assist then putting the local SIM card in.

    I think what's happening is that because it's a US/AT&T phone, somewhere it's configured to automatically prefix international numbers with 011 format. But googling around, I can't find anyone else with this problem or a solution for it.

    - Aaron

  2. #2
    Lightbulb [SOLVED] unlocked iPhone local numbers international assist
    I had this problem for a few days now, but I was rather busy trying to make the data plan to settle down (it started working once I put the re-conditioned local mini-SIM into a 3G phone (one that Movistar does sell, and putting it back into my IPhone4)

    The fix:

    Go to Settings / General / International / Region Format , then select the LANGUAGE of the country you travel to, then under that language, find the country name…*and voila!

    Now the local numbers show up properly spaced and international ones are recognized as such (whether you selected the proper country for each contact in the address field)

    Oh, probably it helped to have updated the "carrier update" suggested by apple.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •