Results 1 to 16 of 16

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Not able to make calls

  1. #1
    Lightbulb Not able to make calls
    Well, FINALLY I got my iPhone. I had to wait almost a month for it to get to me, love the US APO system.

    Anyway, I have it sucessfully activated and unlocked (I think) using PF's guides (thanks btw).

    Heres what happened; followed all the steps and inserted my non-ATT sim. We use a service provided by MCI over here, with a prefix in NY (914). When I powered it up it recognized the MCI carrier and displayed MCI. I could not make outgoing calls. Had a buddy try to call me, said my number was not in service. I took the MCI sim and put it back in the RAZR and it works fine.

    I thought maybe I did something wrong, so I restored it and tried it again...same results. Now somewhere along the way I lost the MCI carrier logo, but I still show full bar for signal.

    So, I replaced the MCI sim with a local Iraqna sim, everything works great...in and out. No data plans but the voice at least works.


    I know nothing about the MCI service, other than I have voice and data. Is there anything I can do on the phone end? Are there any specific settings I can request of the MCI guys here?

    Sorry for the long post, but better to get it all out up front. Thanks again for any help of info.

  2. #2
    Former Owner / Founder of ModMyi Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,516
    Thanks
    577
    Thanked 4,905 Times in 1,247 Posts

    So you ARE able to make incoming and outgoing calls with SIM cards other than ATT? Just not the MCI?
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  3. #3
    i'm having this same problem. it works with other sim cards. just not one particular carrier. The carrier operates on frequencies i KNOW are supported by the iphone

  4. #4
    Quote Originally Posted by poetic_folly View Post
    So you ARE able to make incoming and outgoing calls with SIM cards other than ATT? Just not the MCI?
    Yes, I can put in my Iraqna sim and it works fine. This sim is basically useless to me though. The MCI sim would allows be to call the people I Work with as well and make calls to home.

  5. #5
    I know everyone is busy with the whole 1.1.1 thing, but any ideas?
    I talked to the my local GSM office, they said the MCI sim should work fine in the iPhone. The MCI sim also doesnt work in my BB Pearl, but it works in other Motorola and Nokia phones.

  6. #6
    Owner / Founder - ModMyi
    aka cash7c3
    Cody Overcash's Avatar
    Join Date
    May 2007
    Location
    Denver, CO
    Posts
    11,920
    Thanks
    339
    Thanked 15,254 Times in 649 Posts

    moved to the carriers forum

    Help us help you. Please respect our site by posting in the correct forums in the future.

  7. The Following User Says Thank You to Cody Overcash For This Useful Post:

    SadfaceHappyface (2008-01-01)

  8. #7
    Default ok
    Quote Originally Posted by cash7c3 View Post
    moved to the carriers forum

    Help us help you. Please respect our site by posting in the correct forums in the future.
    Understood, but there was no "Carriers" forum when this was first created. ( I dont think anyway, there was ATT and TMo)

    Still not working, but I dont care. As long it works when I get back home thats all that matters. I does however work with the local SIM, so it's just odd. The MCI network is an 1800MHz network, so it should work. w/e

  9. #8
    Default Problem With Unockedi-phone
    hi everyone , hope someone can help me
    I have new US I-phone unlocked by anysim but when i insert my Orange simm card I cant send or receieve calls (UK) everything else on it is great but cant get any signal. Also when I run anysim it states unlock failure as couldnt download bytes to patch

  10. #9
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    10
    Thanks
    1
    Thanked 2 Times in 1 Post
    I am having the same issue and after searching endlessly I can't find the solution. This is the issue. I unlocked the phone and am able to use all the functions except making outgoing calls. I can receive calls, send and receive text, use Wi-Fi ect. but just get a "call failed" when trying to place calls. By the way should it be any help my wireless service is prepaid with Fastlink.

    I tried a different SIM with a different company, Umniah, and it seemed to work fine. When I first unlocked my iphone it worked for 1 day before returning to this state. I have firmware 1.0.2 and just restored the phone and the same problem exists. Thanks for your help in advance.

    Chris

  11. #10
    Talking Can't make calls, but can recieve
    For weeks I have been going through this issue and finally it got resolved. This is what I did. I went into settings, then phone, and turned off call forwarding, call waiting, show my caller ID and TTY. I then shut off the iphone and turned it back on, and all of a sudden everything went back to normal. SOme of the settings got turned on again after rebooting the phone, like call waiting and show my caller id, but all works perfectly now, including, making and recieving calls as well as SMS. Thank you and good luck to you all out there going through this issue.
    Last edited by efrancis; 2007-10-16 at 04:18 PM.

  12. The Following User Says Thank You to efrancis For This Useful Post:

    colcal987 (2007-10-16)

  13. #11
    What's Jailbreak?
    Join Date
    Oct 2007
    Posts
    10
    Thanks
    1
    Thanked 2 Times in 1 Post
    Surprisingly that actually did the trick. Just go to the phone settings. At first I turned everything off and it didn't work.

    Then I turned call waiting, show my id, and TTY on and rebooted and it worked. Thanks for the info.

    Chris
    Last edited by colcal987; 2007-10-17 at 01:47 AM.

  14. #12
    I am so glad to know that it worked for you too. So now spread the word and make someone else happy. Good luck to you all, and enjoy your new toy. I know I am.

  15. #13
    I wish that process worked for me

  16. #14
    I am using Asia cell Sim on 1.1.2 it works fine
    Iraqhttp://www.modmyi.com/forums/images/icons/icon10.gif

  17. #15
    Hey Guys,
    My iphone is unlocked and its 1.1.1 version.I tried inserting an indian gsm sim card.The phone says no service in the network bar.I tried the same sim with another unlocked iphone and it works perfectly fine.I tried playing around with the phone settings as mentioned in previous posts,but that is not giving me the desired result.Please help me with this....
    Thanks,
    ALOK

  18. #16
    it worked for me
    Many Many thanks

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •