Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Rogers iPhone No Service in the US

  1. #1
    Default Rogers iPhone No Service in the US
    Unlocked iphone on Rogers, 1.1.3, works great in Canada.
    came to the US today and i get No Service everywhere i go
    is there something i can do to fix this so I can get service on my Rogers sim?

  2. #2
    iPhone? More like MyPhone doogee's Avatar
    Join Date
    Oct 2007
    Location
    Ontario, Canada
    Posts
    153
    Thanks
    4
    Thanked 8 Times in 8 Posts

    woah thats really strange. Im on rogers too. Makes me want to try it out.

  3. #3
    Not sure if this may be the case but I experienced the exact same thing you are experiencing right now. In my case though, as soon as I crossed the bridge to the U.S, my iPhone immediately said "No Service" and I started freaking out. However, after getting to my destination, I immediately called Fido CS and apparently, there was an international call block on my account. So I had them take it out and it took about an hour before my iPhone received signal again. Also, mine was (and still is as of now) running 1.1.1 firmware. But it doesnt hurt to try calling CS and see if international calling is blocked on your account.

  4. #4
    iPhone? More like MyPhone iChopPryde's Avatar
    Join Date
    Jan 2008
    Location
    Canada Ontario
    Posts
    249
    Thanks
    11
    Thanked 9 Times in 9 Posts

    also I am not sure if this could be the issue but on the phone in settings theres a roaming feature you can shut off and on

  5. #5
    Quote Originally Posted by mzkaye729 View Post
    Not sure if this may be the case but I experienced the exact same thing you are experiencing right now. In my case though, as soon as I crossed the bridge to the U.S, my iPhone immediately said "No Service" and I started freaking out. However, after getting to my destination, I immediately called Fido CS and apparently, there was an international call block on my account. So I had them take it out and it took about an hour before my iPhone received signal again. Also, mine was (and still is as of now) running 1.1.1 firmware. But it doesnt hurt to try calling CS and see if international calling is blocked on your account.
    International call blocking would not prevent you from connecting to a us network that has a roaming agreement with Rogers users.
    International call block would prevent you from calling but not result in no signal.

    Odds are the OP had his iphone to use only the Rogers network and not set to automatic switching, so when i could not find the Rogers network it never registered on the US networks cuz the option was off.

    In setting, if you click on carrier, it will go into another screen that allows you to pick to stick to rogers or Automatic.

    Set it to automatic while abroad.

    Last edited by The Punisher; 2008-02-27 at 07:38 AM.

  6. #6
    Really ? I dunno.. weird then. Because I tried switching carriers as soon as I entered the US. I could physically select the networks and there would be a checkmark beside it. I even tried automatic switching and still no signal. The only time I got signal was after I called Fido CS and had them remove that international calling block thing. Then it started giving me signal after about an hour. I dont know how else to explain it but that's how I got mine to work. But for sure though, I tried your method before I called Fido CS.. it just didnt work for me. Oh well... I was just happy I got my signal back.

  7. #7
    Quote Originally Posted by mzkaye729 View Post
    Really ? I dunno.. weird then. Because I tried switching carriers as soon as I entered the US. I could physically select the networks and there would be a checkmark beside it. I even tried automatic switching and still no signal. The only time I got signal was after I called Fido CS and had them remove that international calling block thing. Then it started giving me signal after about an hour. I dont know how else to explain it but that's how I got mine to work. But for sure though, I tried your method before I called Fido CS.. it just didnt work for me. Oh well... I was just happy I got my signal back.
    you could be right as well. I am on Rogers and when i went to cuba, my phone had signal and would register but long distance calls would not go through. I called CS and about 15 minutes later and a reboot I was able to make calls, but i always had signal/bars prior to that. ( maybe findo works diferent )

  8. #8
    I'm going to Buffalo on Saturday, so I will try it out when I get there.

  9. #9
    iPhoneaholic
    Join Date
    Sep 2007
    Location
    Milton, Ontario
    Posts
    467
    Thanks
    21
    Thanked 43 Times in 37 Posts

    I have been to the USA numerous times with my iPhone and have never lost service. I am with Rogers in Alberta.

    I have been to NY, IL, WA, PA, GA, FL and TX and it worked fine in all those places.

  10. #10
    Got back from Buffalo. Not only did my Rogers iPhone work, but I could select either AT&T or T-Mobile for the network.

  11. #11
    jp3g
    Guest
    Got my iPhone in San Francisco, ZiPhoned it in San Francisco, and used it there without problem for the remainder of my trip. I was connected to AT&T the majority of the time and connected to T-Mobile once.

    Are you on prepaid? If so, prepaid does not work outside of Canada.

  12. #12
    Quote Originally Posted by The Punisher View Post
    you could be right as well. I am on Rogers and when i went to cuba, my phone had signal and would register but long distance calls would not go through. I called CS and about 15 minutes later and a reboot I was able to make calls, but i always had signal/bars prior to that. ( maybe findo works diferent )
    Does Rogers support the international calling automaticly? or I need to ask them to remove my international calling block ?

    If there is no block now, I should pay extra fee for my account. Right ?


    Thanks
    I think ... I do ... in my utopia ...

    http://www.modmyi.com/forums/image.php?type=sigpic&userid=324941&dateline=12156  49304

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •