Results 1 to 15 of 15

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: EDGE will not turn off! Gathering unwanted data $$$$

  1. #1
    Angry EDGE will not turn off! Gathering unwanted data $$$$
    Hi I am unlocked in New Zealand on the Vodafone network running 1.0.2 and keep getting data charges when I am not even using anything to do with EDGE!

    The phone must be auto checking and updating even when in sleep and I do not want it too.

    I have tried using Services.app to disable EDGE, tried changing the text within the APN/Network settings, tried removing completely all info (APN,Username and Password) but the charges keep going up.

    Initially safari warns 'EDGE can not be activated" once I do one of the above - but then a few hours later it uses it fine, even when there are no settings.

    Has any one got any suggestions what so ever? Any thoughts on this annoyance? It is only $60 but enough to piss me off when i do not use EDGE what so ever!!

  2. #2
    Hey Bro,

    Ive used iPhone 1.0.2/1.1.1 and now on 1.1.2 and voda dont charge me unwanted EDGE usage... I used Services app from Installer and turned EDGE off on that.

    Have you changed your Carrier logo?? mine still says vodafone NZ and i want the apple logo with iphone next to it!! HELP lol

    Cheers Tim

  3. #3
    i treid it once and it worked. but since then, i changed my operator and whenever i use service to off my EDGE, my home eventually goes blank/black

    anyone else?

  4. #4
    Quote Originally Posted by dane.pablecheque View Post
    Hi I am unlocked in New Zealand on the Vodafone network running 1.0.2 and keep getting data charges when I am not even using anything to do with EDGE!

    The phone must be auto checking and updating even when in sleep and I do not want it too.

    I have tried using Services.app to disable EDGE, tried changing the text within the APN/Network settings, tried removing completely all info (APN,Username and Password) but the charges keep going up.

    Initially safari warns 'EDGE can not be activated" once I do one of the above - but then a few hours later it uses it fine, even when there are no settings.

    Has any one got any suggestions what so ever? Any thoughts on this annoyance? It is only $60 but enough to piss me off when i do not use EDGE what so ever!!
    You might want to try iToggle, but first switch edge and wifi on in services, uninstall services, also install BSD subsystem first if its already there maybe try unistalling it and installing it again, then install iToggle using modmyis installer source and try switching off edge with that, I had a probelm with services not turing off apps properly when it said it had and this did the trick for me.
    Eric's iPhone 4 4.01 offically unlocked

  5. #5
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Location
    IL
    Posts
    126
    Thanks
    9
    Thanked 4 Times in 4 Posts

    Quote Originally Posted by dane.pablecheque View Post
    Hi I am unlocked in New Zealand on the Vodafone network running 1.0.2 and keep getting data charges when I am not even using anything to do with EDGE!

    The phone must be auto checking and updating even when in sleep and I do not want it too.

    I have tried using Services.app to disable EDGE, tried changing the text within the APN/Network settings, tried removing completely all info (APN,Username and Password) but the charges keep going up.

    Initially safari warns 'EDGE can not be activated" once I do one of the above - but then a few hours later it uses it fine, even when there are no settings.

    Has any one got any suggestions what so ever? Any thoughts on this annoyance? It is only $60 but enough to piss me off when i do not use EDGE what so ever!!
    If you update and unlock to 1.1.1 or 1.1.2, apple has a on/off switch built in and dont have to use 3 party app

  6. #6
    So by the sounds of things I have 2 new options available - great news.

    iToggle being the first and upgrading to 1.1.1 being the second.

    IS the on/off EDGE 1.1.1 settings simply a straight shut down completely of all EDGE?? So could be used in your home country as well as for travelling?

    As it is advertised as being to avoid international roaming charges.. Does it restrict EDGE completely or only when you are travelling internationally??

  7. #7
    Quote Originally Posted by ericidle View Post
    You might want to try iToggle, but first switch edge and wifi on in services, uninstall services, also install BSD subsystem first if its already there maybe try unistalling it and installing it again, then install iToggle using modmyis installer source and try switching off edge with that, I had a probelm with services not turing off apps properly when it said it had and this did the trick for me.
    Tried this... does not work.

    With (Net)Services.app I can switch OFF edge, but it is ON again when I leave the program. When I restart the (Net)Services.app the edge switch is automagically back to ON again.

    If I install the latest iToggle both my EDGE and Bluetooth switches are greyed out, I cannot operate them. The before-last iToggle (the one with the phone switch) did allow me to REALLY switch edge off.

    Quote Originally Posted by atm_10142k View Post
    If you update and unlock to 1.1.1 or 1.1.2, apple has a on/off switch built in and dont have to use 3 party app
    Where is this switch? I have 112 running but I can't find any EDGE on/off switch.

  8. #8
    Quote Originally Posted by dane.pablecheque View Post
    Hi I am unlocked in New Zealand on the Vodafone network running 1.0.2 and keep getting data charges when I am not even using anything to do with EDGE!

    The phone must be auto checking and updating even when in sleep and I do not want it too.

    I have tried using Services.app to disable EDGE, tried changing the text within the APN/Network settings, tried removing completely all info (APN,Username and Password) but the charges keep going up.

    Initially safari warns 'EDGE can not be activated" once I do one of the above - but then a few hours later it uses it fine, even when there are no settings.

    Has any one got any suggestions what so ever? Any thoughts on this annoyance? It is only $60 but enough to piss me off when i do not use EDGE what so ever!!


    Hi
    I had the very same issue as you... I have a unlocked iPhone (1.0.2) running a on a prepaid NZ Vodafone sim and I kept getting data charges... I lost $50 over night the other week. I thought I'd somehow turned Edge on... but after checking I found that Edge in-fact was still off... I think the problem started after I last updated the Services.app a few weeks ago... even thought the switch say Edge is off it isn't.

    But I found a solution...
    Go to:
    Settings
    - General
    - Network
    - Edge
    and type in under the APN: www.vodafone.net.n ( know the z is missing... thats the idea)
    vodafone doesn't need a username or password so leave them blank.
    Now go to the Services.app and turn Edge ON.

    Its a little disconcerting but the iPhone put the Edge logo in the title bar but if you try and use an app that would use Edge (as long as your not in a wifi area) it will tell you it "Could not activate Edge". This is because you have given the phone an incorrect Edge (GPRS) address overriding the built-in setting hidden within your Vodafone sim card.

    If your using a wifi network the iPhone will automatically switch over to wifi and not even try and use Edge and give you full use of the wifi area your in... Once you leave the wifi network (or turn it off using services.app) the Edge logo still remains in the menu bar but don't worry... its not working, it can't.

    If you want to use Edge (out and about and need web access but don't have wifi) just go into the APN setting (above) and add a z to the end of the address (www.vodafone.net.nz) ... edge will now work.

  9. The Following User Says Thank You to msc1974 For This Useful Post:

    stefimke (2007-12-02)

  10. #9
    .... that solution does not work for all EDGE/GPRS networks. The one I am on doesn't require ANY settings at all. No network settings, no username, no password... it just goes right through anything. Resulting in not very pleasing phonebills.

    iToggle 1.0.4 worked the best for me, but 1.0.5 has greyed out EDGE and BLUETOOTH switches so ... hmm... at the moment I'm just not able to do anything about it.

  11. #10
    HEY GUYS READ THIS!!!! GET YOUR MONEY BACK.

    I had the same problem with Vodafone Australia, just ring Vodafone up, explain your entire situation, saying that it was just trying to connect, but failing, and you can get them to refund your money back. They tried to give me a compromise of a 50% refund since it was not entirely my fault, nor was it Vodafone's.

    But I insisted that while it may not be Vodafone's job to stop people from incorrect phone usage and racking up a huge data bill, it IS Vodafone's job to refund the money when this happens. Also ask them to check that it was all concurrent connection times and that there was little or no data actually being transferred. They then put a blocker on my account for the Data, which prevented this from happening in the future (there's a catch that you can't send MMS messages with this stopper, which the iPhone can't do anyway.)

    It worked for me and I got a full refund for the data bill I racked up. Just don't take no for an answer and insist on getting a full refund. If they say that they cannot do it for you, tell them to put you through to someone who can ie. supervisor.
    Last edited by McBanjo; 2007-12-02 at 03:59 PM.

  12. #11
    Quote Originally Posted by msc1974 View Post
    But I found a solution...
    Go to:
    Settings
    - General
    - Network
    - Edge
    and type in under the APN: www.vodafone.net.n ( know the z is missing... thats the idea)
    vodafone doesn't need a username or password so leave them blank.
    Now go to the Services.app and turn Edge ON.
    Tried this one - even tried removing all information completely.

    I found that once the information has been correctly entered once it is saved somewhere well beyond where you can actually edit the info from the Network settings.

    Actually often this did work and I would receive the "Cannot connect" etc, however after an hour or so it would connect no problem.

  13. #12
    "Services" works fine for me but doesn't save the "other" Edge configuration

  14. #13
    Old thread but just incase anyone reads this and is having the same issues as I was experiencing - following an upgrade to 1.1.1 and/or 1.1.2 and removing letters from the APN name works like a charm - ie:
    Go to Settings > General > Network > Edge and changing to www.vodafone.net.xx (removing/editing some of the letters) blocks the EDGE from activating.

    When you require EDGE simply edit the details back for full access.

    Works perfectly.

    iPhone 8gb
    1.0.2 OTB> 1.1.1 > 1.1.2 > 1.1.3
    Unlocked with Ziphone 2.3
    Operating in New Zealand

  15. #14
    Lightbulb Turn off EDGE with iPhone 2.0
    Hi,
    I hope you had luck. Have you tried changing the carrier Data for T-Mobile as well? As far as I know, o2 falls back to T-Mobile if their own network is unreachable.
    For the others, here's how to change the carrier data
    Rolf’s Ireland Blog Blog Archive Howto: Turn off EDGE on iPhone 2.0

    Regards

  16. #15
    What's Jailbreak?
    Join Date
    May 2008
    Location
    Malaysia
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Use BossPref to turn off EDGE and turn it on only when you need to use it.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •