This app seems very useful but when I go to install , it says something to the degree of modification or incompatibility.

Should I assume it's not ready for 4.1?