Page 7 of 9 FirstFirst ... 56789 LastLast
Results 121 to 140 of 162

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: PDF/CHM/DOC/XLS/photo viewer - all-in-one Safari/Lighttpd based (complete instruct.)

  1. #121
    hello guys,

    i am from switzerland, but i try to explain my problem I want to do this, but ive got a lot of problems on the first step(yeah, i know ). I cant install lighttpd with the installer. everytime i get the failure:main script execution failed. what can i do? all sources are up2date, i tried it many times, with deleting the queue.

    can anyone help me?

  2. #122
    i'm using version 1.5.1 (Apr 19, 2008) and when i copy multimedia files into iPhone /var/root/Sites/Multimedia files/. I can't play files .mp4

    Guide me how to play them! Thanks a lot ...
    Attached Thumbnails Attached Thumbnails -img_0001.jpg  

  3. #123
    Hi everybody...

    two more questions:

    -is not possible read multipages and multi mb pdfs? I saw many time this question but no answer
    -some pdf files don't show most of the text!! I saved them in several kind of pdf (-a, -x..) or print again in pdf but nothing when they are in the iphone most of the text is non visible... same problem if I send me the pdf by mail. So I guess this is not a bug of this great application but anyway a pain in the ***. Any idea?

  4. #124
    Hey I'm stuck right after installing lighttpd and PHP through installer. I get a 404 at 127.0.0.1...

    I've rebooted my IPhone a couple of times. I'm using fw1.1.4... anyone have any suggestions?

  5. #125
    I was wondering if you could run PHP scripts, because I got this text editor script that I would love to use for writing. Any ideas on installing this? Oh and this script does not require any MySQL or anything. The website is here:

    fusionnews.net

    Thats the script that I'm trying to install/setup/run etc.

  6. #126
    I ve done all the steps but as the friend above I still see the welcome screen. If I put : 127.0.0.1/.dirlist then I see some folders: icons , dir-generator, some photos, one folder iphonedirlist.css. I would be really greatfull if you could help me. Thanks for your effort, you are doing great job

  7. #127
    Hi all
    Just have a question...
    Everything work's fine but I can not view pdf files. When I try to open one a new screen pops and says either to download the file of change the filename.
    What should I do in order to view them?

  8. #128
    Quote Originally Posted by compassocap View Post
    I ve done all the steps but as the friend above I still see the welcome screen. If I put : 127.0.0.1/.dirlist then I see some folders: icons , dir-generator, some photos, one folder iphonedirlist.css. I would be really greatfull if you could help me. Thanks for your effort, you are doing great job

    Delete index.html and all the other files in /Sites folder. You don't need them.

    Quote Originally Posted by iojohn View Post
    Hi all
    Just have a question...
    Everything work's fine but I can not view pdf files. When I try to open one a new screen pops and says either to download the file of change the filename.
    What should I do in order to view them?
    Have you installed a patch for Safari that allows you to download files? You should turn it off when you want to open some file for viewing. You can do it with BossPrefs and appropriate BossPrefs' plugin for that patch. All available via Installer.

  9. #129
    Hey voyager, Im having a lot of trouble with this.

    Ive gotten all of the appropriate apps, but I cant figure out how to use WinSCP or where to transfer the files to my iPhone.

    could you possibly make a youtube video?
    or just explain how I get the files onto my iPhone from my windows PC?


    thanks!

  10. #130
    i fully restored my iphone so i have download all of this, but now its not working.
    I downloaded PHP, lighttpd PDF/CHM/XLS/photo viewer. (restarted iphone) nothing (turned off iphone and on) nothing.

    Downloaded Apache. tells u where to put the files. voila done.

  11. #131
    Ok, I got it all working, but it appears that the directory is not pulling information from the .css file. When I look at 127.0.0.1, I see the directory but it is presented like you would normally see it in apache and not the nice looking css'ed layout.

    Anyone know how to fix this?
    Last edited by Imagine3; 2008-06-10 at 07:59 PM.

  12. #132
    Green Apple exekias's Avatar
    Join Date
    Jun 2008
    Location
    NEW ZEALAND -> drop me a line if you live here too
    Posts
    63
    Thanks
    28
    Thanked 14 Times in 5 Posts

    Default ill help
    Quote Originally Posted by endy View Post
    hello guys,

    i am from switzerland, but i try to explain my problem I want to do this, but ive got a lot of problems on the first step(yeah, i know ). I cant install lighttpd with the installer. everytime i get the failure:main script execution failed. what can i do? all sources are up2date, i tried it many times, with deleting the queue.

    can anyone help me?
    your problem can be of many things
    1) you have run out of room to install apps, ur apps are stored in a special 300mb partition use bosstool and that will move them elsewhere to free up space.
    2) individuall refresh all your sources, try and stick with only the community sources delete all the others.
    3) Rest you NEtwork Setting, go to settings, general, at the bttonhit reset and i think it is the third option, click reset etwrok settings
    4) if none of this works u might have to te-jailbreak ur ipod/iphone

    cheers hope i helped
    "if you want some cents, go get change for a dollar but dont talk to me"

    Go one Youtube and search exekias

    IF I HELPED WHY NOT THANK ME, ITS NOT LIKE I TAKE PART OF YOUR SOUL WHEN YOU ACKNOWLEDGE MY HELP.

  13. #133
    Quote Originally Posted by exekias View Post
    your problem can be of many things
    1) you have run out of room to install apps, ur apps are stored in a special 300mb partition use bosstool and that will move them elsewhere to free up space.
    2) individuall refresh all your sources, try and stick with only the community sources delete all the others.
    3) Rest you NEtwork Setting, go to settings, general, at the bttonhit reset and i think it is the third option, click reset etwrok settings
    4) if none of this works u might have to te-jailbreak ur ipod/iphone

    cheers hope i helped
    Nope. "failure:main script execution failed" is a common problem with Installer on some devices. As I already said, google for "failure: main script execution failed" and you'll find articles on how to replace installer.app which causes the problem.

    Quote Originally Posted by andra View Post
    Hi everybody...

    two more questions:

    -is not possible read multipages and multi mb pdfs? I saw many time this question but no answer
    -some pdf files don't show most of the text!! I saved them in several kind of pdf (-a, -x..) or print again in pdf but nothing when they are in the iphone most of the text is non visible... same problem if I send me the pdf by mail. So I guess this is not a bug of this great application but anyway a pain in the ***. Any idea?
    For more demanding PDFs I use app called Solena. I believe it can be found here at MMiF

    Quote Originally Posted by zacklyn View Post
    i'm using version 1.5.1 (Apr 19, 2008) and when i copy multimedia files into iPhone /var/root/Sites/Multimedia files/. I can't play files .mp4

    Guide me how to play them! Thanks a lot ...
    Dunno what to say...I just played 2 mp4 files recorded with iPhoneVideoRecorder. I'd try restarting device or recording a test file with iPhoneVideoRecorder.

    Quote Originally Posted by martyrmachine View Post
    Hey voyager, Im having a lot of trouble with this.

    Ive gotten all of the appropriate apps, but I cant figure out how to use WinSCP or where to transfer the files to my iPhone.

    could you possibly make a youtube video?
    or just explain how I get the files onto my iPhone from my windows PC?


    thanks!
    I'm not into videocasting
    But, here, youtube winSCP - Google Search I bet you'll find enough material for learning

    Quote Originally Posted by Imagine3 View Post
    Ok, I got it all working, but it appears that the directory is not pulling information from the .css file. When I look at 127.0.0.1, I see the directory but it is presented like you would normally see it in apache and not the nice looking css'ed layout.

    Anyone know how to fix this?
    Weird. Should work outta box. Did restarting help? (as you might notice, restarting/rebooting is my first solution for everything)
    Last edited by -V-O-Y-A-G-E-R-; 2008-06-12 at 08:30 AM. Reason: Automerged Doublepost

  14. #134
    I have tried restarting many times. lol.

    Just to make sure I have it set up right, in the .dirlist folder, I have the iphonedirlist.css as well as the dir-generator.php file, 3 images and an icon folder. And I do not have to change anything in the .dirlist folder except copying over your version of the folder from the zipped file you supply.

    Then in /usr/local/etc I copied the lighttpd.conf file that you supplied.

    Do I maybe have to change permissions on any of the files?

    Regardless of if I get this working properly. Great work on this project. It is probably one of my favorite 3rd party uses of my iphone.

    -----------------------------------------
    Fixed My Problem

    I figured a way to fix my problem. In the Sites directory, I made a new directory called "files" then in there I made one called "pics" "docs" "pdf" and then just made the shortcut on my springboard look to 127.0.0.1\files\ and it presented me with my pics, docs and pdf directories like perfect.
    Last edited by Imagine3; 2008-06-16 at 09:57 PM. Reason: Fixed my problem

  15. #135
    Mine doesn't work at all. I must have missed something. Before I put the new version of .dirlist in, I did get a web page with an unformatted listing of ALL of the files in the folder (never got the lighttpd welcome screen) After I replaced .dirlist with the new version, get no page at all, can't get server to start. Any ideas (probably something wrong with my lighttpd installation, huh?)?

  16. #136
    If you got your files listed, than nothing's wrong with you Lighttpd installation. You said "after I replaced .dirlist"..you had an older version? Was it working before? Doublecheck if .dirlist is really called .dirlist (what's your computer platform)? Try renaming .dirlist into something else and then running Lighttpd. Also restart your iPhone

  17. #137
    is there any way to open an external ftp site with lighttpd?

  18. The Following User Says Thank You to persichini For This Useful Post:

    bigtummy (2008-07-22)

  19. #138
    Has anyone successfully installed lighttpd on 2.0?

    I have read that it works, but I cannot get it to work on my 1G pwned, jailbroken and unlocked 2.0. I get the 'cannot find server' message in safari, and I cannot find the folder where the config file should be (/usr/local/etc/). It does not exist on my iphone. I have removed the program and reinstalled it again, but to no avail (with miutiple reboots).

    Please help!

  20. #139
    I just manually created the directory etc at that location and copied my old lighttpd.conf and lighttpd-htpasswd.user files into it. Then I modified the old daemon with the new path of lighttpd:

    /usr/sbin/lighttpd

    and installed it in /Library/LaunchDaemons

    Finally, I activated the daemon with:

    launchctl load -w /Library/LaunchDaemons/com.amcgregor.lighttpd.plist

    There may be a better way, but that did the trick for me.

  21. #140
    Quote Originally Posted by DaveiPhone View Post
    I just manually created the directory etc at that location and copied my old lighttpd.conf and lighttpd-htpasswd.user files into it. Then I modified the old daemon with the new path of lighttpd:

    /usr/sbin/lighttpd

    and installed it in /Library/LaunchDaemons

    Finally, I activated the daemon with:

    launchctl load -w /Library/LaunchDaemons/com.amcgregor.lighttpd.plist

    There may be a better way, but that did the trick for me.
    thanks for your trick!

    But i can't dir-listing root folder? Can you help me?

Page 7 of 9 FirstFirst ... 56789 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •