Page 1 of 2 12 LastLast
Results 1 to 20 of 33

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iDialer v3.0 beta release

  1. #1
    Default iDialer v3.0 beta release
    See the new message about the Installer release of iDialer 3.0.

    Thanks to everyone that helped with developement, including tsatryan.

    Attached is iDialer v3.0 for manual installation and testing.

    Just copy the files into your existing /Applications/iDialer.app folder from a previous install.

    Changes:

    1. Loads ten times faster - handles 1000 contacts ok.
    2. Ignores missing/blank numbers
    3. Option to ignore Fax #s
    4. Compatible with 1.1.3 (and probably 1.1.4)
    5. Marks FAX #s with F: in display
    6. No longer filters out duplicate phone #s - shows all matching names
    7. Smarter font sizing for long names
    8. option to turn off sorting of matches (to speed up matching)
    9. new icon

    Please try it out if you can manually install and let me know if it works for you!
    Last edited by NetMage; 2008-03-07 at 08:21 AM. Reason: bug fixes
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

  2. The Following 5 Users Say Thank You to NetMage For This Useful Post:

    dhawalsinha (2008-03-04), elpi007 (2008-03-06), ggprince (2008-04-02), iBlade (2008-03-04), jtoktas (2008-03-06)

  3. #2
    Green Apple
    Join Date
    Oct 2007
    Location
    Somewhere Here
    Posts
    89
    Thanks
    2
    Thanked 12 Times in 10 Posts

    Tried it on my 1.1.4 phone and it works. Thanks!

  4. #3
    when can it b expected to b on the installer ?

  5. #4
    installed it and after reset a new icon popped up called "iDialer". I pushed it, and a black screen came up with white letters that said "Loading...", and then it returned me to the home screen. I went to my regular phone app but nothing seemed different.

    I'm on 1.1.4 with a modded System Info plist to tell it that it is on 1.1.3 so I can install summerboard and customize. Hope that helps with your development. Let me know what it's supposed to do and how you can get it to work on mine.

  6. #5
    Tried it on 1.1.3, works no problem so far. Thanks.
    Don't be shy if I helped you use the Thanks button, I do it.

  7. #6
    hey,
    really cool app but can you add an option to switch to retro look and work like idial with the advanced features of your app.
    thanks

  8. #7
    tntmorgan:
    can you try running from MobileTerminal or an SSH session and send me the output?

    Alternatively, if you are comfortable, can you send me your AddressBook from /var/mobile/Library/AddressBook? I'll PM my email if so.
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

  9. #8
    Hi NetMage,
    Confirmed..!!! working fine on mine (original US 1.1.1 jailbreak ==> 1.1.3 "Ziphoned")
    Only had to change permissions from 0666 to 0777 , for idialer.app (it was not showing up on springboard before that..!!!! well known issue..)
    Now ...paradise on earth!!!!
    thx
    david916

  10. #9
    Netmage

    I have the same problem as tntmorgan.

    Please PM your mail to send you the requested info.

    [Edit]

    The problem was just in permissions, some of the files were with 644. Changed to 755 and everything is working perfect with FW 1.1.4

    Thanks Netmage
    Last edited by mortiz; 2008-03-04 at 11:14 PM.

  11. #10
    Yes, depending on how you are manually installing it (not unzipping on the iPhone for example), permissions will need to be set.

    If you copy with iPhoneBrowser or similar, overwriting an existing install, permissions should be preserved.
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

  12. #11
    What's Jailbreak?
    Join Date
    Jan 2008
    Location
    Tampa, FL
    Posts
    24
    Thanks
    5
    Thanked 1 Time in 1 Post
    sweet love it
    8GB iPhone 3G
    Expensive but lovin

  13. #12
    works amazingly well on my 1.1.3, can i make it my default dialer?

  14. #13
    I think this would make a FANTASTIC default dialer if it had all the same features as the current default dialer but instead of "Keypad" it went to the IDialer screen. If you guys do that either everyone will use it of apple will steal it from you

    Great app !!
    Last edited by wijman; 2008-03-05 at 02:00 AM.

  15. #14
    I had version 3.0 running fine on 1.1.3 but when I installed 3.0-K it no longer works? Does anyone have the original 3.0 files?

  16. #15
    Here you go version 3.0
    Attached Files Attached Files
    Don't be shy if I helped you use the Thanks button, I do it.

  17. The Following 2 Users Say Thank You to iBlade For This Useful Post:

    ggprince (2008-04-02), liongrewal (2009-04-11)

  18. #16
    Thanks for the files, but now it still doesn't work. I wonder if the installer package changed something so its no longer working

    I've changed the permissions so it should not be that. Did it have/need a symbolic link change or something that got undone....

    Basically I hit the app, it clears the screen, then goes right back to summerboard. Is 3.0-k working for anyone else?

    EDIT: Ok this is weird, seeing NetMages note above, I ran it from putty and it runs then on the iPhone?? I had it in a Caterogry, tried removing it, and it will not show on the Summerboard, I think people have mentioned that problem before. Ran poof to hide/unhide, and now see it and NOW it loads???!!! I then SSH'ed and replaced v3.0 with v3.0-k and now that works as well?? Very strange?

    Edit2: BTW re-adding it to the category doesn't have any problems.
    Last edited by IvanRaide; 2008-03-10 at 08:58 PM.

  19. #17
    There appears to be some sort of package/installer issue that is sometimes causing the folder iDialer.app to not have the correct permissions.

    If you have a similar issue and can check, check if permissions on iDialer.app look like 0666 (bad) or 0755 (correct). SummerBoard will only display apps with 0755 (or most likely proper executable variations) permissions.

    If you can let me know firmware version, jailbreak method, installer version?
    Starlight Computer Wizardry
    Pocket-sized Development
    Follow me on twitter: @NetMage

  20. #18
    First, the previous version 3.0 was working and inside a Category. I upgrade to 3.0-k and it was still showing in the category but would not run. The permission seemed fine, if memory serves it was 777.

    So I ran it manually in the putty and that would work/run, but running it from the Category folder would still not work. Removing it from the Category it would not show up on Summerboard. I change the permission to 755 and back to 777 and the directory itself to 777 but it would still not show up in
    Summerboard/Springboard.

    Using POOF to hide/show fixed that, and then I was able to run it from SpringBoard, (and then re-adding it to the category did not break it again.)

    So I would normally say some type of conflict with Category but v3.0 worked ok inside a category, maybe the script didn't like what category does and caused a problem??

    Firmware 1.1.3, JB was SoftDev 1.1.3-3, installer 3.01

  21. #19
    this app works great on my 112 iphone. except i notice one problem. wen in Enter# mode wen u enter 11 digits it crashes to the springbord. like 1 800 222 3456. does anyone having same issue?

  22. The Following User Says Thank You to 4azeef For This Useful Post:

    NetMage (2008-03-12)

  23. #20
    I typed the number you have above, and it searched fine (didn't find anything), then I hit call it didn't call either? I thought it had locked up but I was able to hit back and delete the numbers. So then I noticed I was in SEARCH and I hit the 'search button' to enter ENTER mode and it crashed to the springboard.

    When I tried to start it again it immediately crashed to the springboard.

    And then when I started it a 3rd time it came up ok but was blank.

    So now that I am in enter mode, if I type your number it crashes, (so search is ok, enter is NOT).

    As a side question, does anyone have the following... when you bring up iDialer in ENTER mode it shows some number that is invalid (434)555-1212

  24. The Following User Says Thank You to IvanRaide For This Useful Post:

    NetMage (2008-03-12)

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •