Page 4 of 5 FirstFirst ... 2345 LastLast
Results 61 to 80 of 98

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Swap Photo Library app

  1. #61
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,307
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by cgonz61070 View Post
    Eurisko, I also installed your version of SwapTunes, and it's not creating the iTunes_Control 2 folder after swapping (I checked with Finder).
    Did you re-check the permissions on the .sh file? It needs to be 0755.
    Get "iPod & iTunes for Dummies", it'll change your life.

  2. #62
    I preferred to had separated version of swap (Music, Video and Picture) individually.

    BTW, please find my enhanced version of "Any copys swap".

    http://www.modmyi.com/forums/showpos...7&postcount=72

  3. #63
    Livin the iPhone Life Eurisko's Avatar
    Join Date
    Aug 2007
    Location
    Toronto, Canada
    Posts
    3,307
    Thanks
    12
    Thanked 562 Times in 483 Posts

    Quote Originally Posted by i071314 View Post
    I preferred to had separated version of swap (Music, Video and Picture) individually.

    BTW, please find my enhanced version of "Any copys swap".

    http://www.modmyi.com/forums/showpos...7&postcount=72
    If you prefer to use individual Apps then by all means use them, but that doesn't really have anything to do with this thread. Additionally, I find your "enhanced" version a bit cumbersome. The point of the swap Apps is a one-touch swapping of your libraries. Adding a bunch of prompts to the App just bogs things down.
    Get "iPod & iTunes for Dummies", it'll change your life.

  4. #64
    Agreed may be cumbersome. This is the simpliest way to swap more than 2 copies.
    Rather than rolling around.
    You know the sync of iTune is a stuid things.
    When you updated one or two pictures.
    It has to delete all and sync all over again....quite a long time.
    So I preferred to take it in difference session and sync it manually

    Sometimes, I find multi-session quite useful to hiding some library from others to view.
    Last edited by i071314; 2008-01-08 at 03:19 PM.

  5. #65
    is there a way to have itunes sync the iphone as two separate "identities"since I prefer to have my photos sync automatically,

  6. #66
    How about a bump for 1.1.3?

  7. #67
    here is swap photo updated for 1.1.3, all that is changed is location from root folder to mobile.. for now it will require manual install and make sure perms are set to 0755 on swapPhotoLibrary.sh.

    Tested and seems to work fine with 1.1.3 ready to be updated on installer source...
    Attached Files Attached Files
    Last edited by yomomma; 2008-02-04 at 09:04 PM.

  8. #68
    Hello, I was hoping to ask for a little clarification on how to install Swap Photo via SSH.

    I am having (I think) a common problem, but I can't seem to get to the "duh!" moment that everyone else is, in order to get it working. The application file that I downloaded from yomomma's last posting on this thread is ssh'd via cyberduck (mac os x) into my Touch in "private/var/mobile/library" then I made sure the permissions for all the files in that photo swap application were set to 755.

    I click on Swap Photo in my springboard (actually I have it in Catagories) it says it's switching the iphoto library, and that it is the 1.1.3 version. But then I go to my photo's on the Touch and there all still there, and when I sync it says "do you want to replace the existing photos?" I say yes, and then it writes over them.

    I'm sure I'm missing somehting really basic, but I just can't wrap my brain around this.

    Any help would be great,

    Thanks,
    Michael

  9. #69
    the photoswap.app should be installed to /Applications. Then the perms for the .sh file should be 0755 and u should be good. Sorry this is so short , posted from my iPhone

  10. #70
    I'm having trouble with SwapPhoto. Apologies in advance - bit of a noob.

    When I click on the icon it opens, displays the "Swapping Your Photo Library" message and closes right away.

    I have 1.1.3. and installed SwapPhotos via the installer. Using the File Manager on iPhone PC Suite I can see the program in the Applications folder. I opened the "swapPhotoLibrary.sh" file and see it's been updated to root/Media (which means I have the right version for 1.1.3, right?)

    When I look under var/root/Media I see folders for both Photos and Photos_2. Both are identical.

    Also, I'm lost when you all mention checking the permissions on the .sh file.

    Any help would be much appreciated!!!

  11. #71
    Anyone?

    Sorry to bump this, I just really want to use this app.

    Thanks!

  12. #72
    afaik the version on installer is NOT for 1.1.3, i'll pm and get the 1.1.3 version added. or use the one posted a couple posts up by me.

    or manually edit the .sh script and change "root" to "mobile" for 1.1.3+
    Last edited by yomomma; 2008-02-29 at 09:30 PM.

  13. #73
    Got the new version installed, now it opens, displays the launch page (which says for 1.1.3) for about 15 seconds, then closes. (which is an improvement from before! LOL.)

    I'm guessing I just need to set the permissions, but can't figure out how to do that. I installed Squid and MobileFinder on the phone and also iPhone PC Suite on my PC, but none seem to allow me to change the permissions. I can see them, but not change them.

    Am I missing something?

    Tried to set permissions with iBricker too, no luck.


    Update: Is permission 755 the same as 0755? Using Squid I can check/uncheck the read, write, exec boxes and get the permissions to: 493 (755). SwapPhoto still doesn't work tho.
    Last edited by F4i4Brian; 2008-03-02 at 08:26 PM. Reason: Automerged Doublepost

  14. #74
    can anyone help me install this app on my 1.1.3 iphone (unlocked)

  15. #75

  16. #76
    Newbie question. How do you install usind SCP> First you copy the files and then how do you add an icon to the the main screan?

  17. #77
    OK...I cant get this to work properly for some reason on 1.1.3. I copied in the new version and CHMOD 0755 all files. All works perfect except when I try to synch with the second library. I get:

    The iPhone "iPhone" cannot be synched. An unknown error occured (-54).

  18. #78
    iPhone? More like MyPhone ckybam69's Avatar
    Join Date
    Oct 2007
    Location
    ATL
    Posts
    120
    Thanks
    11
    Thanked 5 Times in 5 Posts

    Quote Originally Posted by poetic_folly View Post
    Already said I would.

    Or you can spend the 90 seconds it'd take to drag the app into your Applications folder on your iPhone and have the app already.
    PF there is some kinda problem with 1.1.4 and winscp with apps. i can use winscp for everything but when i install and app with it if messes up. the permissions are set correctly too. i think this is a problem some people are having as well. any answers?

  19. #79
    someone help! My photos are all screwed up now. no thumbnails and I cannot synch it. Keep getting this error (-54).

    ok i fixed the photos back to square one but still get an error -54 when i try to synch with the other album. But I can take the thumbs and database and copy it to photos_2 manually and it works perfect. I just cant do it through itunes. Anyone?
    Last edited by Jayman11; 2008-03-22 at 02:58 AM. Reason: Automerged Doublepost

  20. #80
    i am unable to get this to work....does this work for 1.4.4? i've looked at the .sh file and noticed that the directories are not the same as where i "think" the directories actually are...

    is it as simple as correcting the directories?

Page 4 of 5 FirstFirst ... 2345 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •