Page 1 of 2 12 LastLast
Results 1 to 20 of 35

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Req: One-Button-BT-Toggler!

  1. #1
    Default Req: One-Button-BT-Toggler!
    Is there an app that just toggles Bluetooth on/off bei just tapping the icon?

    If not, could someone just do it?

    The issue i want is just controle BT with one tap!

    Thx in advance!

    Cruzer

  2. #2
    Two taps for BT isn't too bad, but it would be nice if maybe the double tap of the home key could be remapped for something like this. I'm still holding out for a BT autoshutoff.

  3. #3
    I've thrown something together quickly.

    Needs some new Graphics then I'll put up the 1st test version later today.

  4. #4
    Quote Originally Posted by veekay View Post
    Two taps for BT isn't too bad, but it would be nice if maybe the double tap of the home key could be remapped for something like this. I'm still holding out for a BT autoshutoff.
    YES!! Touble tapping at the home button is perfect!!

    Need this to toggle bt on/off in the car!
    Would be great!!

    Thx in advance!

  5. #5
    Quote Originally Posted by Sproglet View Post
    I've thrown something together quickly.

    Needs some new Graphics then I'll put up the 1st test version later today.
    Ok the 1st test version is causing some unusual effects on my iPhone. Doing some debugging and will have something for you to try soon.

    Soz for the delay.

  6. #6
    Cool cant wait to see this its something we all need, thanks all

  7. #7
    Ok here's the 1st test version.

    It works but there are a couple of bugs to work out.

    Pressing to turn on BT seems to pause for a while but it is working

    Pressing to turn off seems to take a while but it is working (trust me)

    Needs BSDSubsystem on (doesn't everything )

    Upload to the Applications dir on your iPhone and then make sure you set the swapBT.sh file as 755 (chmod 755)

    Let me know how you get on. I'll do some more work on this to try iron out the bugs later.

    WARNING.

    I've found a major bug. Please don't reboot your iPhone while Bluetooth has been disabled by this version.

    I'll have a fix shortly.
    Last edited by Sproglet; 2008-02-17 at 11:13 PM. Reason: Bug Warning.

  8. The Following User Says Thank You to Sproglet For This Useful Post:

    dallasnights (2008-02-13)

  9. #8
    Ya i Think i found antoher bug too
    I used your program, turn on turn off then turn on
    I got a call from a friend, and although the BT icon was lit up my BT headset, Jawbone did not work. So I rebooted the phone at that point, went into general and turned it on and off and it worked again fine

    Nice work and I know you will work out the bugs, thanks for everythhing

  10. #9
    OMG this is great, excellant job, I am using Official JB 1.1.3 BTW

    Turns on great, turns off a bit slow, excellant work thank you this is one everyone has asked for for months

    Cant wait to get the next version

    WOW

    thanks again!!!!!

    BTW if you all want the same there is a great app out there for WIFI too toggle

    Put this in Sources
    http://iphone.latte.ca

    Go under Utilities and install WifiToggle

    it works great

    Thanks all

    BTW if you all want the same there is a great app out there for WIFI too toggle

    Put this in Sources
    http://iphone.latte.ca

    Go under Utilities and install WifiToggle

    it works great

    Thanks all

    Ya i Think i found antoher bug too
    I used your program, turn on turn off then turn on
    I got a call from a friend, and although the BT icon was lit up my BT headset, Jawbone did not work. So I rebooted the phone at that point, went into general and turned it on and off and it worked again fine

    Nice work and I know you will work out the bugs, thanks for everythhing

    Ya i Think i found antoher bug too
    I used your program, turn on turn off then turn on
    I got a call from a friend, and although the BT icon was lit up my BT headset, Jawbone did not work. So I rebooted the phone at that point, went into general and turned it on and off and it worked again fine

    Nice work and I know you will work out the bugs, thanks for everythhing

    Did you fix the bugs yet, thanks again for your great work
    Last edited by dallasnights; 2008-02-13 at 05:28 PM. Reason: Automerged Doublepost

  11. #10
    Did you fix the bugs yet, thanks again for your great work

  12. #11
    Getting there.

    Having trouble getting the toolchain working on my 2nd machine.

    May have something today but looking increasingly likely it will be tomorrow I'm afraid.

    Will do my best.

  13. #12
    GM Any updates yet, looking forward to trying it out

  14. #13
    1st version was a script. Don't think that's the way to go unforunately as there are a heap of "issues" related to it.

    Got most of the C written for a new app that seems to work perfectly thus far.

    Now to tidy the code and make sure everything works after reboots in all modes.

    Expect something shortly

  15. #14
    cool hey if this site continue to have problems can you post a link where we can download it, thanks so ery much

  16. #15
    Ok. I have a new totally recoded version that appears to work fine for me but of course I do need bugtesters.

    Can't seem to attach the file so PM me your email address if you want to help with the testing.

  17. #16
    Hi there, any updates to share, looking forward to it
    thanks for your great work

  18. #17
    Well now I can upload it.

    Have been testing this for a while on 2 iPhones with no ill effects.

    Let me know how you get on with it.

    Updated version is up on the Installer Repo:

    http://losprog.com/repo.xml

    Confirmed working to 1.1.4
    Last edited by Sproglet; 2008-02-28 at 06:34 PM. Reason: Removed outdated version.

  19. #18
    Works Perfectly on 1.1.3 JB official, thank you so very much, this is what we have all been asking for!!

  20. #19
    I've put up a repository to host the file since modmyi is unstable just now.

    http://losprog.com/repo.xml

    Let me know how you get on

    Forgot to say you can find it under "Utilities" with the name swapBT.
    Last edited by Sproglet; 2008-02-16 at 10:38 PM.

  21. #20
    This is confirmed to work on 1.1.4 also

  22. The Following 2 Users Say Thank You to Sproglet For This Useful Post:

    Busha (2008-02-28), iBlade (2008-02-28)

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •