Results 1 to 17 of 17

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Easiest Way to Install NES ROMs

  1. #1
    Default Easiest Way to Install NES ROMs
    What is the easiest way to do this? (Mac)

    If you are reading this... how did you do it?
    Last edited by mattportner; 2007-08-21 at 08:06 AM. Reason: Automerged Doublepost

  2. #2
    I am not really sure for Mac. However, I found that creating a folder in your var/root/media folder (that is creating a folder on the desktop and then draging it in to your media folder) is easiest. Thus, once you have accessed your media folder, create a folder called "ROMs". Inside your Roms folder, create a folder called "NES" (by performing the same procedure, i.e. creating a folder on desktop and then dragging it in). Finally, drag your roms into your newly created NES folder. It should work after that.

  3. #3
    Anyone have a walkthrough how to do this?

  4. #4
    Try this:

    Although I'm currently not able to connect via Fugu, some have succeeded. But perhaps another option to make this work (especially moving the ROMs to the iPhone) is out there and can be shared with us....

  5. #5
    i have tried the method.

    but i can't get my iPhone and Fugu to connect

  6. #6
    Former Owner / Founder of ModMyi Kyle Matthews's Avatar
    Join Date
    May 2007
    Tampa, Florida, United States
    Thanked 4,905 Times in 1,247 Posts

    Have you done our SSH and SFTP guides in the WIki?

    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  7. #7
    yes i have ssh and sftp on my phone

  8. #8
    yeah i have ssh and sftp on my phone as well, but i cant get Fugu to work!

    funny thing is i can login to my phone using WinSCP on my PC but never Fugu on MAC...... Fugu asks me for the password, dottie, and i put it in, and then it returns me back to the main login screen, gues ill use my Windows Machine to upload NES roms
    iPhone 3G 8GB (2.0.2), iPhone 2G 8GB (2.0.2)

    Macbook Pro Core 2 Duo 15inch, 4GB Ram

    Intel E8400 Core2Duo 3.0ghz (OC 3.8ghz)
    4gb DDR2 Ram
    500gb RAID0
    GeForce 8800GTS 640mb

  9. #9
    Finally got the ROMs to work with Fugo! I have attempted various methods and combination of wikis but this one worked for me!

    1) Go here (Didn't install the Lights Off.... ). Make sure you remember your new password cuz you'll need to enter this when Fugu asks for it to authenticate. "dottie" was a failure to me!

    2) Launch Fugu, establish connection (enter your iPhone's IP address, Username is root ,port 22 and Directory should be "/"). Enter your new password. This is where I got stuck before (along with others), so smooth sailing from this point on.

    3) Then jump to the end of Step 12 starting at this line: "Navigate to /var/root/media/ ..... from this wiki here:

    4) Go all the way to the end of step 13. If you are not interested in dealing with the game's audio, stop here. Make sure that each roms' permission is set so that the Octal Mode Representation is "0755".

    5) If you haven't done so already, install NES the easy way via

    Hopefully, once you launch NES, you'll see the names of the roms you dragged and dropped using Fugu! Good luck!

    Many thanks to the gang here at modmyi for your continued support! You guys rock!

  10. #10
    Quote Originally Posted by mattportner View Post
    What is the easiest way to do this? (Mac)

    If you are reading this... how did you do it?
    Good day you'll!

    I'm still seeing a few people having problems installing the NES ROMs on there iphone so I thought I would throw in my two cents.

    This is for Mac users! Sorry to the PC users!!

    So from what I'm seeing everyone knows where and how to download the NES ROMs. So I wont go over old news.

    Follow this tutorial>

    If you don't have "Cyberduck" you can get it here>

    Now, as your going down the tutorial it tells you to enter in the "Password" which on this site has it as "dottie", this might work for some but if it does not, try this password "alpine" (this one worked for me). Then you will be inside your iPhone.

    Now if you have already download the NES ROMs you'll find them already on your iPhone but when you tap that little mushroom dude's face you get the error message "no NES ROMs found"

    So this is what you need to do to make them work on your iPhone!

    With Cyberduck open and connected to your iPhone and you iPhone set with Auto-Lock "OFF", you should see three files>


    Click the arrow to the left of "Media" (wait just a little, depends on the connection speed) you should see the folder "ROMs". Now this is not mentioned in many places! If you see a white "+"(plus) in a red circle you wont be able to play your NES ROMs, until you do this>

    If you have a "Mighty Mouse" right click or, "Control" click on the "ROMs" folder. A new window will open, on the bottom of that window you will see six check boxes, check mark them all, and the "Apply changes recursively". And next to the word "Permissions" it should now read "Permissions | wrxwrxwrx (777)". After all that click "Apply". Hay presto change-o, all your NES ROMs will be working.

    Just click on the Mushroom dude's face and relive the golden age of the NES!

    Cant wait for the SNES!!!

    Hope this helps some people out there!!!

  11. #11
    Green Apple stan_the_man_123's Avatar
    Join Date
    Sep 2007
    London, United Kingdom
    Thanked 22 Times in 15 Posts

    If you are on 1.1.3 and the games are not showing, try this tutorial:
    It works with iPhones too!

  12. The Following User Says Thank You to stan_the_man_123 For This Useful Post:

    abujala (2008-02-19)

  13. #12
    iPhone? More like MyPhone abujala's Avatar
    Join Date
    Nov 2007
    Minneapolis MN.
    Thanked 14 Times in 13 Posts

    try cyberduck its works great for me never had any prob.
    2.1 T-mobile

  14. #13
    Join Date
    Nov 2008
    Team America Baby
    Thanked 7 Times in 7 Posts

    Sorry do not mean to raise a thread from the dead but I was curious is there a new way to do this now instead of the above mentioned ways? I downloaded NES but still need some ROMs installed to play the games.


  15. #14
    Wow. You SSH into var/mobile/media

    Make a folder labels ROMs.
    Throw your NES roms into the ROMs Folder.
    Next, SSH the ROMs Folder into the aforementioned location, and bam. Easy as pie.

  16. #15
    Join Date
    Nov 2008
    Team America Baby
    Thanked 7 Times in 7 Posts

    Sorry dude. I see people getting slammed for starting new thread with new questions. Didn't think it would be so bad if I used a topic that was already started. Plus this is information that is dated. I assumed there would be a different way of doing it straight from the phone at this point. I am new to this so I still need to learn what SSH is. I don't even know where to get ROM's yet either.

    We all start some where...

    With that said. I just saw there was an update for NES when I was in Cydia and I installed it. Now NES doesn't even open for me. A browser or window comes up blank for two seconds then closes. Uninstalled it for now.
    Last edited by Chad711; 2008-11-26 at 11:33 PM.

  17. #16
    NES won't open unless you have ROM's anyway. Google search for the ROM's. That's the only place to get them.

  18. #17
    I'm having the same problem after installing the update, I tried uninstalling and reinstalling it but now it doesn't even show up on the the home screen.
    Last edited by screwface; 2008-11-27 at 03:30 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts