Page 5 of 16 FirstFirst ... 3456715 ... LastLast
Results 81 to 100 of 306

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: NetServices.app - control all your services

  1. #81
    My iPhone is a Part of Me PhoneLine's Avatar
    Join Date
    Aug 2007
    Location
    New York City
    Posts
    508
    Thanks
    65
    Thanked 155 Times in 54 Posts

    Quote Originally Posted by tonydeli7 View Post
    it works for me... and i have moved my apps to media partition
    Yep, same here. Works for me and my apps are on the media partition as well.

  2. #82
    iPhoneaholic HotStuff2's Avatar
    Join Date
    Nov 2007
    Location
    Tampa Bay, FL
    Posts
    344
    Thanks
    5
    Thanked 22 Times in 17 Posts

    I like mrrippey's idea. Perhaps clicking the name of the service would open it's preferences or something. Not sure how feasible that is with WiFi or Bluetooth, since both of those service's settings are in the iPhone's default Settings app, but perhaps there's a way to do it. If there is, I'm sure Greg will find a way to do it. NetServices is THE "one app to control them all"...he won't stop until NetServices has total domination.

    Eagerly awaiting the nect version!

  3. #83
    I've tried both methods and could not get it to install.

    1) Download directly from http://homepage.mac.com/hartsteins/c...ices-0.1.3.zip
    Unzip resulting download if not unzipped already.
    Place NetServices.app directly into Applications folder on iPhone via SSH or file transfer system of your choice.

    When i used #1 method everything transfers fine, but doesn't show up on instll menu. I have looked in all packages and utilities and nothing shows netservices.

    2) The second method...Add CopyCoders to your installer sources and NetServices will become available under Utilities.
    Open Installer
    Tap Sources along bottom navigation bar
    Tap Edit along top navigation bar
    Tap Add along top navigation bar
    Enter: http://homepage.mac.com/hartsteins/c...copycoders.xml
    Tap OK
    Once Installer finishes adding source - Tap Done
    CopyCoders should now appear as a source in "Other Sources". If it does not -Tap Refresh.
    Tap Sources along bottom navigation bar
    NetServices will now be available for installation under the "Utilities" heading.

    It shows up in uncategorized and when i look in utilities nothing is there. Now here's the strange part, i am assuming this must be it because i have never seen the icon "Netservices" on the desktop before. When opening it up, it says "creating list of network services, please stand by" and closes, i still do not see the feature where i can disable edge. can anyone help me out?

  4. #84
    alexloo -

    There are a couple of problems with the way you've chosen to install.

    If you choose to download from the site and put into your Applications folder yourself - NetServices won't appear on installer as you've installed it yourself. The app will still work, but you will not be able to auto-update...etc that Installer provides.


    I would prefer if you installed via Installer.app

    The errors you're showing when trying to add CopyCoders as an installer source point to a typo when entering the CopyCoders url info. Once you enter the info and Installer updates sources, CopyCoders will appear as an entry in sources under "Other Sources" NOT "Uncatergorized".

    Once you've set this up correctly, CopyCoders will now appear as a folder on the install page of Installer. NetServices can be found there. (Now in CopyCoders folder rather than Utilities).

    BEFORE you do this. - please remove the copy of NetServices you've already put in your Applications folder yourself. Check the first post of this thread for up to date install/updates information.

    Please let me know if this has solved the issue.

    Greg

  5. The Following User Says Thank You to hartsteins For This Useful Post:

    alexloo (2007-12-02)

  6. #85
    Quote Originally Posted by hartsteins View Post
    alexloo -

    There are a couple of problems with the way you've chosen to install.

    If you choose to download from the site and put into your Applications folder yourself - NetServices won't appear on installer as you've installed it yourself. The app will still work, but you will not be able to auto-update...etc that Installer provides.


    I would prefer if you installed via Installer.app

    The errors you're showing when trying to add CopyCoders as an installer source point to a typo when entering the CopyCoders url info. Once you enter the info and Installer updates sources, CopyCoders will appear as an entry in sources under "Other Sources" NOT "Uncatergorized".

    Once you've set this up correctly, CopyCoders will now appear as a folder on the install page of Installer. NetServices can be found there. (Now in CopyCoders folder rather than Utilities).

    BEFORE you do this. - please remove the copy of NetServices you've already put in your Applications folder yourself. Check the first post of this thread for up to date install/updates information.

    Please let me know if this has solved the issue.

    Greg
    Greg, you were right, it was a typo. That's what i get for doing things late at night Also, thanks for your prompt reply and i've thanked you also

  7. #86
    Just copying and pasting my post from the other NetServices thread as it looks like this one is frequented more:

    Hey guys,

    I've got a problem where the Samba File Sharing doesn't seem to hold the state after I've closed and re-opened the NetServices app - does anybody else experience this?

    If I start Samba, and then close NetServices and re-open it, the Samba tab is in the Off position even though it's still running in the background.

    Any suggestions/quick fixes?


    EDIT: Also, I've tried removing the locking files manually such as:
    # pwd
    /usr/local/samba/var/locks
    # rm smbd.pid
    # rm nmbd.pid

    It didn't help though

    Also, once I've started Samba File Sharing through NetServices, nmdb doesn't seem to be running in a ps -A output. Is this normal?

    The process ID that is stored in nmdb.pid has a number but when I look through ps -A it doesn't look like it's still running; so it appears that nmbd starts and then stops from a wild guess. Would this effect NetServices holding the correct state? Apart from holding the right state, samba seems to function correctly.

  8. #87
    Hi, hartsteins,

    I've installed the NetServices on my iphone 1.1.1 and there is no SSH icon on the list, the same situation has happened several times when I installed Services on my iphone. I am sure that I've installed openSSH and the iphone can be accessed through winscp.

    I am a newbee of iphone. Could you please tell me how I can solve this problem? Many thanks.

  9. #88
    Default NetServices update Ver 0.1.4 is Available.
    NetServices update Ver 0.1.4 is Available.

    Please update via Installer or directly from the web site - HERE

    In addition, many of the Network Services apps have been added to the CopyCoder's installer source. If you are having any trouble accessing services that you have installed from a different source or manually, please uninstall and reinstall from the CopyCoder's source. All the network service apps from CopyCoders are set to work with NetServices.

    VERSION HISTORY

    0.1.4 - Update 12/03/07
    • Samba start/stop scripts naming issue resolved.
    • NEW - Auto-Lock - Turn Auto-Lock on & off to help maintain network connections.
    • NEW - EDGE - A new method is being applied to disconnect EDGE network more consistently.
    • NEW - AFP w/ Bonjour Naming - When sharing your iPhone's hard drive via AFP with Bonjour, it will now show your iPhone's name as set in iTunes.


    0.1.3 - Update 11/24/07
    • Primarily Maintainence Update
    • Ability to toggle Phone service has been temporarily removed until issues with iPhone FW 1.1.2 have been resolved.
    • Several memory leaks have been patched.
    • NEW - Installer Source - An assortment of Network Services have been added to the CopyCoder's Installer source.


    0.1.2 - Update 11/23/07
    • SSH launching issues have been resolved
    • Phone service problem has yet to be replicated but now no longer follows On/Off state through restart. Should toggling phone service present a problem, simply restart iPhone to restore service.
    • Additional search locations have been added for Tinyproxy's Launch Daemons in an effort to anticipate installation variations.
    • NEW - Switch Visibility - Keys have been added to the settings file (inside NetServices.app folder) to set visibility of any switches. This is handy for services that are installed but rarely turned on or off.


    0.1.1 - Initial Release
    • Users reported issues with SSH not shutting down correctly
    • User reported problems with phone service
    • Tinyproxy service was not appearing after installation



    Thank you all for your input and help in making NetServices a better product.

  10. #89
    What if I have AFPd installed from here ( http://www.eecs.berkeley.edu/~job/afpd )?

    Do I need to uninstall it before in order to install version 0.1.4 of NetServices?

  11. #90
    Quote: NEW - EDGE - A new method is being applied to disconnect EDGE network more consistently.

    Which method do you mean? By entering a fake ipadres as itoggle does?

  12. #91
    Quote Originally Posted by hartsteins View Post
    [SIZE="3"]NetServices update Ver 0.1.4 is Available.
    Thanks for the new version!!!

    However, some issues:

    * the exit-button does not do anything, I have to "exit" with the HOME button
    * the EDGE setting is NOT sticky. When EDGE is ON and I flip the switch initially it pops up a box saying that it takes 15 secs or so to toggle EDGE. The box dissappears, pops back up for 10-15 secs. Then the box dissapears, EDGE is OFF. Great so far. However, when I exit NetServices and start it rightaway again... the switch is ON again! (EDGE is also still active, that is the worst part)

  13. #92
    What's Jailbreak?
    Join Date
    Nov 2007
    Location
    Ludwigsburg, Germany
    Posts
    8
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Default AFP problem with NetServices 0.1.4
    When having AFP with Bonjour installed (using CopyCoders Repository) the NetServices app crashes on startup. Reinstalling AFP does not help :-(

  14. #93
    Default NetServices 0.1.4.1 Maintenance Update
    NetServices Ver 0.1.4.1 has been released to resolve some of the issue that were present in Ver 0.1.4.

    It is available on installer or direct from the CopyCoders website.

    - EDGE issues should be fixed
    - AFPd crashing remedied


    Greg

  15. The Following User Says Thank You to hartsteins For This Useful Post:

    therealkerni (2007-12-03)

  16. #94
    Quote Originally Posted by hartsteins View Post
    NetServices Ver 0.1.4.1 has been released to resolve some of the issue that were present in Ver 0.1.4.
    Thanks for the quick update Greg!

    However, this is what happens when I start 0.1.4.1:

    Creating List of Network Services
    Please standby...

    ... and a couple of seconds later I'm back at my springboard. No NetServices

  17. #95
    Quote Originally Posted by stefimke View Post
    Thanks for the quick update Greg!

    However, this is what happens when I start 0.1.4.1:

    Creating List of Network Services
    Please standby...

    ... and a couple of seconds later I'm back at my springboard. No NetServices
    same problem here

  18. #96
    Default NetServices 0.1.4.2 Maintenance Update
    NetServices 0.1.4.2 Maintenance Update

    - AFP with Bonjour Name Signaling has been removed due to erratic behavior (causing crashes)


    Available on Installer or at the CopyCoders website.

    Thank you for your patience and help in making NetServices a better product.


    -------------------------------------------------------

    gardz -
    Newest NetServices version should fix Samba script issues.

    locklin -
    It's not necessary to uninstall any service before installing NetServices. While they will not present any problem with NetServices, previously installed services may not appear correctly (depending on how they were installed). If a service is not appearing correctly, please uninstall it and re-install from a source on the CopyCoders repository. All of these version have been tested with NetServices.

    MP3-Junky -
    NetServices is now adjusting the Availability of the EDGE service rather than entering false APN information as it did before. This should work even when APN spoofing did not. Please let me know if it does not.

    stefimke / Clem-Clone -
    Latest update should fix crashing issues.
    Last edited by hartsteins; 2007-12-03 at 07:27 PM. Reason: Automerged Doublepost

  19. #97
    stefimke / Clem-Clone -
    Latest update should fix crashing issues.
    Sorry, still not working.
    waits, then crashes out to 'Home'

  20. #98
    Quote Originally Posted by Clem-Clone View Post
    Sorry, still not working.
    waits, then crashes out to 'Home'
    Clem-Clone,

    Please confirm that you are running NetServices 0.1.4.2.

    Also - what iPhone firmware are you running?

    thanks

    Greg

  21. #99
    iPhone? More like MyPhone Jodiedicie's Avatar
    Join Date
    Sep 2007
    Location
    California
    Posts
    248
    Thanks
    72
    Thanked 69 Times in 50 Posts

    Mine is crashing as well, but after I hit more info (probably should have done that before I installed it lol) I see it is confirmed to work with 1.1.1. I am on 1.1.2. Maybe that is what is wrong and people on 1.1.2 should go back to the former version?

    UPDATE: Just updated again to 0.1.4.2 and it is working with my 1.1.2 firmware. Thanks! I LOVE this app
    Last edited by Jodiedicie; 2007-12-03 at 07:50 PM.

  22. #100
    Quote Originally Posted by Jodiedicie View Post
    Mine is crashing as well, but after I hit more info (probably should have done that before I installed it lol) I see it is confirmed to work with 1.1.1. I am on 1.1.2. Maybe that is what is wrong and people on 1.1.2 should go back to the former version?
    Jodiedicie

    Please confirm that you are running NetServices 0.1.4.2.

    Greg

  23. The Following User Says Thank You to hartsteins For This Useful Post:

    Jodiedicie (2007-12-03)

Page 5 of 16 FirstFirst ... 3456715 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •