Page 12 of 16 FirstFirst ... 21011121314 ... LastLast
Results 221 to 240 of 306

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: NetServices.app - control all your services

  1. #221
    good idea autostarting ssh. I know that bossprefs has this option also.

  2. #222
    iPhoneaholic HotStuff2's Avatar
    Join Date
    Nov 2007
    Location
    Tampa Bay, FL
    Posts
    344
    Thanks
    5
    Thanked 22 Times in 17 Posts

    I would not want SSH to autostart on every reboot. If that happens, I'd have to go in and manually shut SSH down everytime I rebooted the iPhone, which would be annoying as hell.

  3. #223
    That's why it would be an OPTION, not everyone would want that, only those of us who prefer safety over convenience.

  4. #224
    Quote Originally Posted by DaveiPhone View Post
    My guess is that it's the result of some runaway phone process that's in a continuous loop, although I've never been able to pin it down, even looking at the processes in SysInfo.
    If you want to watch your iPhone in action, SSH in via an external terminal program and type: top -u
    You will then see a live update of running processes. Starting up apps will obviously add them to the list and you can see how processor intensive they are, how much memory they take..etc.


    Quote Originally Posted by DaveiPhone View Post
    Question: I've discovered with autosnap (when using Erica's launch daemon, not your product), that if I accidentally left if running and rebooted my phone, I would get stuck in a boot loop (Apple logo showing, never getting to Springboard). Fortunately, when this happened, I had SSH turned on, so I was able to remove the daemon and reboot through my Mac's Terminal app, which saved me from having to restore my phone.
    I suffered the same fate - scarey huh?

    Quote Originally Posted by DaveiPhone View Post
    Since you're not using the daemon in the same way, is this issue circumvented? Does autosnap automatically terminate when the phone is rebooted using your toggle?
    I am using Erica's daemon but in a different fashion. It's still the smoothest way to stop & start auto-snap, but the issue was with putting it in a LaunchDaemon folder and thereby starting auto-snap on reboot. I have a copy of Erica's LaunchDaemon in the LaunchFiles folder inside the NetServices application folder. It loads the auto-snap binary when requested, but won't load it at reboot (or springboard recycle for that matter) since it's not in one of the iPhone's LaunchDaemon folders. So to actually answer your question:
    Yes, the issue is circumvented and auto-snap will NOT load at start-up. It is the only service that will not keep its state through reboot, but as stated above - for good reason.

    Quote Originally Posted by DaveiPhone View Post
    Request: Any chance you can add a preference to SSH to start automatically when the phone is rebooted? This could potentially avert disaster as there are many ways to get stuck in a loop that prevents Springboard from loading properly.
    Hmmm - seems a bit redundant. I'm not sure how this would be different from just leaving SSH on to start with. openSSH is no battery drain so with the exception of security (change your password!) there's no reason to ever turn it off. Still if the people want it - I'll add it to the upgrade list.

    Thanks for all your ideas and help in making NetServices a better product.

    Greg

  5. #225
    Greg,

    As always, thanks for your informative and helpful reply. I'm really glad you solved the issue with autosnap, as I was pretty gun-shy about using the daemon after that incident.

    That's a great tip about using top -u in Terminal, thanks!

    Yes, the only reason I turn SSH off is for security. I use a fair number of public access points, and while I've changed my password, and it's reasonably secure, I'd rather have it off when I'm not using it.
    Last edited by DaveiPhone; 2007-12-24 at 12:12 AM.

  6. #226
    Here's a new app I built last night -

    http://www.modmyi.com/forums/showthr...953#post132953

    happy holidays

    Greg

    edit:

    If you're having troubles be sure permissions are set correctly

    SSH in and type:

    cd /Applications/iFartz.app; chmod -R 755 *

    There should be sounds
    Turn phone up & down - shake it - enjoy

    Greg
    Last edited by hartsteins; 2007-12-24 at 06:13 PM.

  7. #227
    Hey, I've got NetServices 1.6.1 running on an iPod Touch 1.1.2. i'm trying to get the AFP w/ Bonjour to work but, even when it's switch to "On" my MBP doesn't see my iPod touch at all. Both are on the same wireless network. It worked in the previous version of NetServices though


    edit: Nevermind. I was able to manually login to my iPod Touch's AFP server. Typed afp://theipaddress & then was able to login & then mount the "iPhone Root Filesystem" & "Root's Home" volumes. So, it does work on a jailbroken 1.1.2 iPod Touch, just in a roundabout sorta way
    Last edited by celebi23; 2007-12-25 at 02:28 AM.

  8. #228
    this app is so great and its come so far! what do you think about adding an addon switch for mobile scrobbler now that the scrobbler has its own deamon...just updated tonight 1.2

  9. #229
    iPhoneaholic HotStuff2's Avatar
    Join Date
    Nov 2007
    Location
    Tampa Bay, FL
    Posts
    344
    Thanks
    5
    Thanked 22 Times in 17 Posts

    OK, I have an interesting, albeit odd, issue to report. I use NetServices to turn EDGE off, and keep it off (I only have data PPU since I need it for TMs, and I don't want to get hit with data PPU charges for surfing or anything.) When I sent my iPhone Bluetooth headset back to Apple (bad battery; it only lasted a day), I turned Bluetooth off (no need to kill the battery since I have no other Bluetooth headsets now.)

    I got my replacement iPhone Bluetooth headset yesterday (yay!), and put it and the iPhone into the special cradle it comes with (the cradle charges both, and automatically pairs the headset with the iPhone.) I let it charge overnight (been fighting a bug, so basicaly I slept from 6pm last nght to 6am this morning, and figured a good overnight charge for the iPhone Bluetooth headset wouldn't hurt anyway.) When I got up this morning, I remembered that I had turned WiFi off on the iPhone, so, wanting to see if anything new was on installer, I went into NetServices to turn WiFi on. Lo and behold, Bluetooth is on (presumably auto-enabled by the pairing of the iPhone Bluetooth headset from being in the cradle), and EDGE is set to ON as well! Huh? That's just odd. I turned it off in NetServices, and got the "it takes 10-15 seconds" dialog twice, then it was off again.

    Unlikely Greg will be able to reproduce this unless he has an iPhone Bluetooth headset (which is a GREAT headset, BTW!), but thought I'd report it. Still, very strange...

  10. #230
    one question.
    is it right, that if i have edge off, that the edge icon doesn´t show in the top taskbar?

  11. #231
    iPhoneaholic HotStuff2's Avatar
    Join Date
    Nov 2007
    Location
    Tampa Bay, FL
    Posts
    344
    Thanks
    5
    Thanked 22 Times in 17 Posts

    Quote Originally Posted by The Spirit View Post
    one question.
    is it right, that if i have edge off, that the edge icon doesn´t show in the top taskbar?
    No, not always. On some firmwares, the EDGE icon will still show up, even if EDGE is off (1.1.1, IIRC, still does this. Not sure about the other firmwares.)

  12. #232
    Green Apple
    Join Date
    Oct 2007
    Location
    Somewhere Here
    Posts
    89
    Thanks
    2
    Thanked 12 Times in 10 Posts

    Can't edit the service name. When I tap on a name, it just disappears. The KB does not pop up.

  13. #233
    Quote Originally Posted by HotStuff2 View Post
    No, not always. On some firmwares, the EDGE icon will still show up, even if EDGE is off (1.1.1, IIRC, still does this. Not sure about the other firmwares.)
    i´m running on 1.1.1 and the edge icon dissapears for me if edge is shut off

  14. #234
    iPhone? More like MyPhone echo's Avatar
    Join Date
    Sep 2007
    Location
    YYZ & KUL
    Posts
    197
    Thanks
    12
    Thanked 23 Times in 21 Posts

    Quote Originally Posted by The Spirit View Post
    one question.
    is it right, that if i have edge off, that the edge icon doesn´t show in the top taskbar?
    Quote Originally Posted by HotStuff2 View Post
    No, not always. On some firmwares, the EDGE icon will still show up, even if EDGE is off (1.1.1, IIRC, still does this. Not sure about the other firmwares.)

    I was just about to ask this. On 1.1.1, the EDGE logo would turn off if I had EDGE off in NetServices. I just upgraded to 1.1.2 and the EDGE logo remains on regardless of whether EDGE is turned off or on in NetServices. Also, I've noticed that sometimes when EDGE is turned off , the square box for the EDGE icon remains but the 'E' inside is gone. The 'E' will reappear after. Will there be any update where these issues may be addresssed? I know that NetServices is only tested with 1.1.1.

    Also, I wanted to ask if anybody has noticed if their cell reception has been affected? I, being uninitiated to the world of coding, was wondering if there is anything in NetServices that could potentially affect cell reception? I notice that when EDGE is turned off or on, the cell signal drops as if recycling, and then comes back up again. That's the reason I ask if there is any coding in NetServices that could affect cellular signals.

    Finally, I wanted to send my thanks to Greg for all his hard work on this great "little" app that seems to be constantly growing and evolving. Keep up the good work!

    Best,
    e
    Last edited by echo; 2007-12-26 at 06:09 PM. Reason: grammatical
    15.4" 2.8GHz Unibody MacBook Pro
    Pwnage Unlocked 16GB iPhone (2.1)
    Apple Unlocked 16GB 3G iPhone (2.2)

  15. #235
    Quote Originally Posted by HotStuff2 View Post
    Bluetooth is on (presumably auto-enabled by the pairing of the iPhone Bluetooth headset from being in the cradle), and EDGE is set to ON as well.
    Unlikely Greg will be able to reproduce this unless he has an iPhone Bluetooth headset
    I don't have a bluetooth headset so difficult to test. Were you able to reproduce this action & result?

    Quote Originally Posted by amf View Post
    Can't edit the service name. When I tap on a name, it just disappears. The KB does not pop up.
    You are dealing with a permission error. Please try this:
    quit NetServices
    SSH into phone and type:
    cd /Applications/NetServices.app; chmod -R 755 *
    hit return
    Restart NetSevices

    Labels changing (and many other features ) should now be working correctly.

    Quote Originally Posted by The Spirit View Post
    one question.
    is it right, that if i have edge off, that the edge icon doesn´t show in the top taskbar?
    The EDGE icon is a fickle beast and different between iPhone FW 1.1.1 and 1.1.2. ON 1.1.1 the E and blue box are tied together versus 1.1.2 where the E and blue box are separate graphic elements. Originally I used a awkward hack to simply rename the graphic (then the system couldn't find it and it wouldn't appear) but when 1.1.2 changed the graphic method this became clumsy and opened the potential for having an active EDGE and a disabled graphic. It's unclear why / how the logo disappears sometime and not others. Please do not use it as an indication of EDGE viability and instead trust either the IP field in NetServices or try to access a website with EDGE & WiFi off to assure the service is disabled.

    Quote Originally Posted by echo View Post
    Is there anything in NetServices that could potentially affect cell reception?
    No, NetServices recycles the CommCenter (phone service) when EDGE is turned off and on as that is necessary for the new setting to "take" but ti starts up as left. It will cycle thgough 2 timesand often take a full 10 seconds to reestablish (find cell tower, set signal...etc).

    Quote Originally Posted by echo View Post
    Finally, I wanted to send my thanks to Greg for all his hard work on this great "little" app that seems to be constantly growing and evolving. Keep up the good work!
    You're welcome,

    Greg
    Last edited by hartsteins; 2007-12-26 at 06:38 PM.

  16. The Following User Says Thank You to hartsteins For This Useful Post:

    echo (2007-12-26)

  17. #236
    iPhoneaholic HotStuff2's Avatar
    Join Date
    Nov 2007
    Location
    Tampa Bay, FL
    Posts
    344
    Thanks
    5
    Thanked 22 Times in 17 Posts

    Quote Originally Posted by hartsteins View Post
    I don't have a bluetooth headset so difficult to test. Were you able to reproduce this action & result?
    Good question. I actually received a bad headset (the microphone didn't work), so I unpaired it yesterday and turned BT off. I swapped it out @ the Apple store today, then plugged the iPhone and the new (replacement) iPhone Bluetooth headset into the cradle when I got back to my office. Bluetooth turned on automatically, and I just checked; EDGE is still disabled. Appears to have been an isolated incident, possibly related to a bad BT headset.

    iServices rocks!

  18. #237
    Green Apple
    Join Date
    Oct 2007
    Location
    Somewhere Here
    Posts
    89
    Thanks
    2
    Thanked 12 Times in 10 Posts

    Quote Originally Posted by hartsteins View Post
    You are dealing with a permission error. Please try this:
    quit NetServices
    SSH into phone and type:
    cd /Applications/NetServices.app; chmod -R 755 *
    hit return
    Restart NetSevices

    Labels changing (and many other features ) should now be working correctly.Greg
    Done that and still can't edit the labels. Thanks!

  19. #238
    Quote Originally Posted by amf View Post
    Done that and still can't edit the labels. Thanks!
    amf - please check your mailbox - sent you a PM on the subject with some tests we can do.

    Hopefully it'll help

    Greg

  20. #239
    Greg, is the SSH included by Independence 1.3.x works on 1.1.2?

  21. #240
    hartsteins: Can you please add support for PureFTPd to NetServices?

Page 12 of 16 FirstFirst ... 21011121314 ... LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •