Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 42

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iToggle, NetInfo and FixRingtone

  1. #21
    Quote Originally Posted by bezman View Post
    whenever i turn off ssh and exit the app, and try to connect, i can , when i turn off ssh while connected, it disconnects as it should/described, but if i try to reconnect immediately, i can, and iToggle still says its off...
    I had a similar issue with tinyproxy and lighttpd. But after I unloaded them with UIctl (unload -w, "Do it") and then restarted them with iToggle, all was right with the world. =)
    Last edited by DaveiPhone; 2007-11-14 at 06:40 PM.

  2. #22
    what I did to fix the ssh problem

    Install services
    turn off ssh
    install itoggle
    uninstall services

    Works fine now

  3. #23
    iToggle is a great and very useful program, but when it is installed on my iPhone I cannot play any videos, either in iPod or YouTube. Any suggestions?

  4. #24
    Quote Originally Posted by mikeb View Post
    iToggle is a great and very useful program, but when it is installed on my iPhone I cannot play any videos, either in iPod or YouTube. Any suggestions?
    I would just uninstall it and try later because I can do both fine...

  5. #25
    Former Owner / Founder of ModMyi Kyle Matthews's Avatar
    Join Date
    May 2007
    Location
    Tampa, Florida, United States
    Posts
    8,516
    Thanks
    577
    Thanked 4,905 Times in 1,247 Posts

    I added this to the MMi source just now, iToggle that is.
    .


    ↑ ↑ ↓ ↓ ← → ← → B A [select] [start] Kyle Matthews

  6. #26
    can someone please add find ringtones also, very useful app , thanks in advance

  7. #27
    Default itoggle killed my unlocked 1.1.2 iphone
    DONT USE ITOGGLE app WITH 1.1.2. after turning off the phone (option) in the app menu it froze my phone, it wont start anymore. i see the white apple and a loading wheel , it keeps rebooting every few minutes. I can still see it in Itunes and DEMOCRACY2.

    Help, any suggestions on how to proceed fixing it ?
    Its an original 1.0.2 jail broken, upgraded to 1.1.1 unlocked and recently up grated to 1.1.2.

  8. #28
    I did the same exact thing today. Here are the steps to reset your phone.

    1) Press the power and home button untill the screen turns black. Let go of the power button and hold the home button for 10 seconds.
    2) Open itunes while holding the home button and it will recognize it as DFU mode(restore mode)
    3) Download the 1.1.1 iphone firmware and restore to 1.1.1 by pressing and holding the shift key and selecting the restore and then the 1.1.1 firmware.
    4) Activate and jailbreak by using these directions
    Code:
    1. enter *#307# press call, now use the back button on the top of your screen to remove *#307# ,  
       now enter 0 , press call, press answer, press hold, press decline. And you get to the contact 
       list. And thereafter every time you push the homebutton you just slide the "emergency call" 
       slide, then enter 0 , press call, press hold, press decline.
    
    2. Push contacts, end call and you get called again, this time hit decline and you access one of 
       menus with favorites, you can edit contacts, do a test ride on keyboard, take photos etc.
    
    3. Now edit a new contact and type in "prefs://11" as web-address and "http://jailbreakme.com" as 
       an additional URL.
    
    4. When you tap "prefs://11" you can now select your favorite WiFi gateway.
    
    5. Now press the home button and move the slider to the dial-pad.
    
    6. Now you can go back to the contact list by Dialing 0, push call, then answer, then contacts, 
       then hit the "http://jailbreakme.com" web address you typed in.
    
    7. Scroll down to the bottom, click "Install AppSnapp". Safari will exit and you'll return to your 
       springboard. Wait for the phone to reboot. You are now jailbroken. and are able to use 
       Installer.app.
    5) Install oktoprep
    6) Upgrade to 1.1.2
    7) Jailbreak again with the new jailbreak

    you should now be all set

  9. #29
    Thank for sharing the Info!

    Here we go again...

  10. #30
    how in the world do you uninstall itoggle? it seemed to have messed up my wifi and after uninstalling via installer.app, it's still there...
    21.5" iMac 3.06 GHz Intel Core i3 l 15" MacBook Pro 2.2 GHz Intel Core i7 l 17" PowerBook 1.67 GHz
    iPhone 4 32 GB l  TV 160 GB l 32 GB iPad

  11. #31
    For those who still love iToggle, like I do, here's a little tip:

    You can control Screenshot with it as well as many other services like AFP Server, lighttpd, apache, tinyproxy and so on. Here's are the settings I use to activate and deactivate Screenshot:

    icon: screenshot
    Label: Screenshot
    parameters: &
    processname: screenshot
    processpath: /usr/bin/screenshot/

    Now that's one less app I need on Springboard, since the I don't change the other settings in Screenshot.

  12. #32
    Quote Originally Posted by 2petros View Post
    DONT USE ITOGGLE app WITH 1.1.2. after turning off the phone (option) in the app menu it froze my phone, it wont start anymore. i see the white apple and a loading wheel , it keeps rebooting every few minutes. I can still see it in Itunes and DEMOCRACY2.

    Help, any suggestions on how to proceed fixing it ?
    Its an original 1.0.2 jail broken, upgraded to 1.1.1 unlocked and recently up grated to 1.1.2.
    Currently my iPhone has firmware 1.1.1.
    A friend running 1.1.2 reported a similar problem (if not the same) with iToggle and 1.1.2.

    What iToggle does when you press the Phone off switch is stop CommCenter.
    here is the code:
    system("launchctl unload -w /System/Library/LaunchDaemons/com.apple.CommCenter.plist");

    My friend could bring his phone back to life by restarting CommCenter via command line.
    telneting to the phone and typing the following command:
    launchctl load -w /System/Library/LaunchDaemons/com.apple.CommCenter.plist

    Based on his report it looks like the phone still works but for some reason the SpringBoard app dies on 1.1.2.

  13. #33
    Quote Originally Posted by buzios View Post
    Currently my iPhone has firmware 1.1.1.
    A friend running 1.1.2 reported a similar problem (if not the same) with iToggle and 1.1.2.

    What iToggle does when you press the Phone off switch is stop CommCenter.
    here is the code:
    system("launchctl unload -w /System/Library/LaunchDaemons/com.apple.CommCenter.plist");

    My friend could bring his phone back to life by restarting CommCenter via command line.
    telneting to the phone and typing the following command:
    launchctl load -w /System/Library/LaunchDaemons/com.apple.CommCenter.plist

    Based on his report it looks like the phone still works but for some reason the SpringBoard app dies on 1.1.2.
    When do you plan to release a new version that would work for 1.1.2?

  14. #34
    This is good to know NOW. Thanks alot. My iPhone (1.1.2) is now non booting.

    I'm going to attempt to start it w/ iPHUC.

    You need to put a disclaimer in your installer source regarding this app and 1.1.2

    EDIT:

    I'm in iPHUC, now what?

    What do I do to start the com.apple.CommCenter.plist??

    I try activate, no go.
    I try startservices, you guessed it.

    How do I get the phone to boot?


    I even try 'enterrecovery' with no luck.
    Last edited by Imahottguy; 2007-11-25 at 06:18 AM.

  15. #35
    Default iToggle 1.0.5
    Quote Originally Posted by rperalta View Post
    When do you plan to release a new version that would work for 1.1.2?
    iToggle 1.0.5 can be downloaded from http://web.newsguy.com/marcio/iphone/itoggle/

    It has new features and disables the "Phone switch" on 1.1.2 firmware

  16. #36
    Quote Originally Posted by buzios View Post
    iToggle 1.0.5 can be downloaded from http://web.newsguy.com/marcio/iphone/itoggle/

    It has new features and disables the "Phone switch" on 1.1.2 firmware
    Hi buzios,

    Awesome, I'll download it when I get home after work?

    It would be nice if you can add this to the Installer in the future (I could have downloaded it and don't have to wait after work).

    Thanks!

  17. #37
    I installed iToggle 1.0.5 ... but I cannot "turn" the EDGE (neither the BT) switch anymore! It's grayed out!

    Damn... I'm thinking of going back to 1.0.4 again, that one worked fine for me!

  18. #38
    Whenever I try and launch iToggle (1.0.5) it opens, then quits. It never stays open long enough to see the list of services...

    Of note, I have Customize.app installed but not Summerboard (it was making things crash)... Fresh restore -> Jailbreak just today (because of Summerboard crashing apps).

    Any clues?

  19. #39
    I had had the same issue. It means that your daemons.plist file is bad. For me I had an 'icon' header that pointed to a non existent file, AFP . I swapped it for 'wifi' and it works fine now.

    They need to code in a fallback for if the file is not found, so the app does not crash.

    I attached my daemons.plist in the zip below to make it easier to understand.

    Also make sure if you are running AFPD to remove the /Library/LaunchDaemons/com.core.afpd* file so that iToggle can manage it. Otherwise it will just relaunch when iToggle closes.

    Have not gotten firefly to work well yet. I had issues starting and stopping the service. Any help would be appreciated.
    Attached Files Attached Files
    Last edited by dwabraxus; 2007-11-28 at 01:30 AM. Reason: fix spelling

  20. #40
    ...
    Last edited by javanetllc; 2007-12-01 at 06:28 PM.

Page 2 of 3 FirstFirst 123 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •